aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2010-04-05 02:38:54 +0800
committermarcus <marcus@FreeBSD.org>2010-04-05 02:38:54 +0800
commit3cb675a3dac6226427c0e57a8c7661a833176058 (patch)
tree060b8d38eefc6f7b87e2bcc191d1ad8f10e6e9f1 /net
parent58d995644c7268a86499c20c80552482485a8d96 (diff)
downloadfreebsd-ports-gnome-3cb675a3dac6226427c0e57a8c7661a833176058.tar.gz
freebsd-ports-gnome-3cb675a3dac6226427c0e57a8c7661a833176058.tar.zst
freebsd-ports-gnome-3cb675a3dac6226427c0e57a8c7661a833176058.zip
Enable the use of OPTIONS.
Submitted by: knu
Diffstat (limited to 'net')
-rw-r--r--net/netatalk/Makefile25
1 files changed, 9 insertions, 16 deletions
diff --git a/net/netatalk/Makefile b/net/netatalk/Makefile
index 41df3acc1e49..ba2d268aad66 100644
--- a/net/netatalk/Makefile
+++ b/net/netatalk/Makefile
@@ -16,10 +16,6 @@ COMMENT= File and print server for AppleTalk networks
LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
-.if defined(WITH_SRVLOC)
-LIB_DEPENDS+= slp.1:${PORTSDIR}/net/openslp
-.endif
-
USE_AUTOTOOLS= libtool:22
USE_BZIP2= yes
USE_ICONV= yes
@@ -30,6 +26,13 @@ CONFIGURE_ARGS+= --with-tcp-wrappers \
--with-libiconv=${LOCALBASE} \
--with-libgcrypt-prefix=${LOCALBASE}
+OPTIONS= SRVLOC "Enable Service Location Protocol support" off \
+ PAM "Enable PAM support" off \
+ TIMELORD "Enable Timelord network time service" off \
+ KRB5 "Enable Kerberos V UAM" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_KRB5)
CONFIGURE_ARGS+= --enable-krbV-uam
PLIST_SUB+= NETATALKKRB5=""
@@ -47,6 +50,7 @@ PLIST_SUB+= NETATALKPAM="@comment "
.if defined(WITH_SRVLOC)
# Enable Service Location Protocol support. This allows MacOS X < 10.1 to
# pickup afpd servers in the network.
+LIB_DEPENDS+= slp.1:${PORTSDIR}/net/openslp
CONFIGURE_ARGS+= --enable-srvloc=${LOCALBASE}
.endif
CONFIGURE_ARGS+= --with-bdb=${LOCALBASE}
@@ -84,17 +88,6 @@ SUB_LIST+= SRVLOC="slpd"
SUB_LIST+= SRVLOC=""
.endif
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Netatalk has the following tunable options:"
- @${ECHO_MSG} " WITH_SRVLOC=yes Enable Service Location Protocol support"
- @${ECHO_MSG} " WITH_PAM=yes Enable PAM support"
- @${ECHO_MSG} " WITH_TIMELORD=yes Enable Timelord network time service"
- @${ECHO_MSG} " WITH_KRB5=yes Enable Kerberos V UAM"
- @${ECHO_MSG} ""
- @${ECHO_MSG} "See Netatalk's Makefile for more details on some of these options."
- @${ECHO_MSG} ""
-
post-patch:
@${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}| ; \
s|%%DB_LIB%%|-l${BDB_LIB_NAME}|g' \
@@ -115,4 +108,4 @@ post-install:
.endfor
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>