aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-04-14 21:23:49 +0800
committervs <vs@FreeBSD.org>2005-04-14 21:23:49 +0800
commit3e6000f57879f3baa7770b5b5f05a61d5df7ab30 (patch)
tree332dc6fed9f3580a03636b60978f98987b661ee7 /net
parentcfbe8b3e75a0c0c0b7255af42d870e0c3df8fd1b (diff)
downloadfreebsd-ports-gnome-3e6000f57879f3baa7770b5b5f05a61d5df7ab30.tar.gz
freebsd-ports-gnome-3e6000f57879f3baa7770b5b5f05a61d5df7ab30.tar.zst
freebsd-ports-gnome-3e6000f57879f3baa7770b5b5f05a61d5df7ab30.zip
Handle rc.subr correctly
Based on PR: ports/79246 Submitted by: Ari Maniatis Approved by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/asterisk-bristuff/Makefile4
-rw-r--r--net/asterisk-bristuff/files/asterisk.sh.in (renamed from net/asterisk-bristuff/files/asterisk.sh)4
-rw-r--r--net/asterisk-devel/Makefile4
-rw-r--r--net/asterisk-devel/files/asterisk.sh.in (renamed from net/asterisk-devel/files/asterisk.sh)4
-rw-r--r--net/asterisk/Makefile4
-rw-r--r--net/asterisk/files/asterisk.sh.in (renamed from net/asterisk/files/asterisk.sh)4
-rw-r--r--net/asterisk10/Makefile4
-rw-r--r--net/asterisk10/files/asterisk.sh.in (renamed from net/asterisk10/files/asterisk.sh)4
-rw-r--r--net/asterisk12/Makefile4
-rw-r--r--net/asterisk12/files/asterisk.sh25
-rw-r--r--net/asterisk12/files/asterisk.sh.in25
-rw-r--r--net/asterisk14/Makefile4
-rw-r--r--net/asterisk14/files/asterisk.sh25
-rw-r--r--net/asterisk14/files/asterisk.sh.in25
-rw-r--r--net/asterisk16/Makefile4
-rw-r--r--net/asterisk16/files/asterisk.sh25
-rw-r--r--net/asterisk16/files/asterisk.sh.in25
17 files changed, 97 insertions, 97 deletions
diff --git a/net/asterisk-bristuff/Makefile b/net/asterisk-bristuff/Makefile
index ce7f82474c8f..5802757f3e20 100644
--- a/net/asterisk-bristuff/Makefile
+++ b/net/asterisk-bristuff/Makefile
@@ -31,7 +31,7 @@ GNU_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
-USE_RC_SUBR= yes
+USE_RC_SUBR= asterisk.sh
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -69,6 +69,6 @@ PLIST_SUB+= WITH_ZAPTEL=""
.endif
post-install:
- @${INSTALL_SCRIPT} ${FILESDIR}/asterisk.sh ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${WRKDIR}/asterisk.sh ${PREFIX}/etc/rc.d
.include <bsd.port.post.mk>
diff --git a/net/asterisk-bristuff/files/asterisk.sh b/net/asterisk-bristuff/files/asterisk.sh.in
index deee10c0cbe4..10f0c4275c84 100644
--- a/net/asterisk-bristuff/files/asterisk.sh
+++ b/net/asterisk-bristuff/files/asterisk.sh.in
@@ -11,12 +11,12 @@
# asterisk_enable="YES"
#
-. /etc/rc.subr
+. %%RC_SUBR%%
name=asterisk
rcvar=`set_rcvar`
-command=/usr/local/sbin/asterisk
+command=%%PREFIX%%/sbin/asterisk
pidfile=/var/run/asterisk.pid
asterisk_enable=${asterisk_enable:-"NO"}
diff --git a/net/asterisk-devel/Makefile b/net/asterisk-devel/Makefile
index ce7f82474c8f..5802757f3e20 100644
--- a/net/asterisk-devel/Makefile
+++ b/net/asterisk-devel/Makefile
@@ -31,7 +31,7 @@ GNU_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
-USE_RC_SUBR= yes
+USE_RC_SUBR= asterisk.sh
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -69,6 +69,6 @@ PLIST_SUB+= WITH_ZAPTEL=""
.endif
post-install:
- @${INSTALL_SCRIPT} ${FILESDIR}/asterisk.sh ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${WRKDIR}/asterisk.sh ${PREFIX}/etc/rc.d
.include <bsd.port.post.mk>
diff --git a/net/asterisk-devel/files/asterisk.sh b/net/asterisk-devel/files/asterisk.sh.in
index deee10c0cbe4..10f0c4275c84 100644
--- a/net/asterisk-devel/files/asterisk.sh
+++ b/net/asterisk-devel/files/asterisk.sh.in
@@ -11,12 +11,12 @@
# asterisk_enable="YES"
#
-. /etc/rc.subr
+. %%RC_SUBR%%
name=asterisk
rcvar=`set_rcvar`
-command=/usr/local/sbin/asterisk
+command=%%PREFIX%%/sbin/asterisk
pidfile=/var/run/asterisk.pid
asterisk_enable=${asterisk_enable:-"NO"}
diff --git a/net/asterisk/Makefile b/net/asterisk/Makefile
index ce7f82474c8f..5802757f3e20 100644
--- a/net/asterisk/Makefile
+++ b/net/asterisk/Makefile
@@ -31,7 +31,7 @@ GNU_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
-USE_RC_SUBR= yes
+USE_RC_SUBR= asterisk.sh
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -69,6 +69,6 @@ PLIST_SUB+= WITH_ZAPTEL=""
.endif
post-install:
- @${INSTALL_SCRIPT} ${FILESDIR}/asterisk.sh ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${WRKDIR}/asterisk.sh ${PREFIX}/etc/rc.d
.include <bsd.port.post.mk>
diff --git a/net/asterisk/files/asterisk.sh b/net/asterisk/files/asterisk.sh.in
index deee10c0cbe4..10f0c4275c84 100644
--- a/net/asterisk/files/asterisk.sh
+++ b/net/asterisk/files/asterisk.sh.in
@@ -11,12 +11,12 @@
# asterisk_enable="YES"
#
-. /etc/rc.subr
+. %%RC_SUBR%%
name=asterisk
rcvar=`set_rcvar`
-command=/usr/local/sbin/asterisk
+command=%%PREFIX%%/sbin/asterisk
pidfile=/var/run/asterisk.pid
asterisk_enable=${asterisk_enable:-"NO"}
diff --git a/net/asterisk10/Makefile b/net/asterisk10/Makefile
index ce7f82474c8f..5802757f3e20 100644
--- a/net/asterisk10/Makefile
+++ b/net/asterisk10/Makefile
@@ -31,7 +31,7 @@ GNU_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
-USE_RC_SUBR= yes
+USE_RC_SUBR= asterisk.sh
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -69,6 +69,6 @@ PLIST_SUB+= WITH_ZAPTEL=""
.endif
post-install:
- @${INSTALL_SCRIPT} ${FILESDIR}/asterisk.sh ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${WRKDIR}/asterisk.sh ${PREFIX}/etc/rc.d
.include <bsd.port.post.mk>
diff --git a/net/asterisk10/files/asterisk.sh b/net/asterisk10/files/asterisk.sh.in
index deee10c0cbe4..10f0c4275c84 100644
--- a/net/asterisk10/files/asterisk.sh
+++ b/net/asterisk10/files/asterisk.sh.in
@@ -11,12 +11,12 @@
# asterisk_enable="YES"
#
-. /etc/rc.subr
+. %%RC_SUBR%%
name=asterisk
rcvar=`set_rcvar`
-command=/usr/local/sbin/asterisk
+command=%%PREFIX%%/sbin/asterisk
pidfile=/var/run/asterisk.pid
asterisk_enable=${asterisk_enable:-"NO"}
diff --git a/net/asterisk12/Makefile b/net/asterisk12/Makefile
index ce7f82474c8f..5802757f3e20 100644
--- a/net/asterisk12/Makefile
+++ b/net/asterisk12/Makefile
@@ -31,7 +31,7 @@ GNU_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
-USE_RC_SUBR= yes
+USE_RC_SUBR= asterisk.sh
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -69,6 +69,6 @@ PLIST_SUB+= WITH_ZAPTEL=""
.endif
post-install:
- @${INSTALL_SCRIPT} ${FILESDIR}/asterisk.sh ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${WRKDIR}/asterisk.sh ${PREFIX}/etc/rc.d
.include <bsd.port.post.mk>
diff --git a/net/asterisk12/files/asterisk.sh b/net/asterisk12/files/asterisk.sh
deleted file mode 100644
index deee10c0cbe4..000000000000
--- a/net/asterisk12/files/asterisk.sh
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-
-# PROVIDE asterisk
-# REQUIRE: NETWORKING SERVERS
-# BEFORE: DAEMON
-# KEYWORD: FreeBSD shutdown
-
-#
-# Add the following lines to /etc/rc.conf to enable asterisk:
-#
-# asterisk_enable="YES"
-#
-
-. /etc/rc.subr
-
-name=asterisk
-rcvar=`set_rcvar`
-
-command=/usr/local/sbin/asterisk
-pidfile=/var/run/asterisk.pid
-
-asterisk_enable=${asterisk_enable:-"NO"}
-
-load_rc_config $name
-run_rc_command "$1"
diff --git a/net/asterisk12/files/asterisk.sh.in b/net/asterisk12/files/asterisk.sh.in
new file mode 100644
index 000000000000..10f0c4275c84
--- /dev/null
+++ b/net/asterisk12/files/asterisk.sh.in
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+# PROVIDE asterisk
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: FreeBSD shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable asterisk:
+#
+# asterisk_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=asterisk
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/asterisk
+pidfile=/var/run/asterisk.pid
+
+asterisk_enable=${asterisk_enable:-"NO"}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/net/asterisk14/Makefile b/net/asterisk14/Makefile
index ce7f82474c8f..5802757f3e20 100644
--- a/net/asterisk14/Makefile
+++ b/net/asterisk14/Makefile
@@ -31,7 +31,7 @@ GNU_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
-USE_RC_SUBR= yes
+USE_RC_SUBR= asterisk.sh
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -69,6 +69,6 @@ PLIST_SUB+= WITH_ZAPTEL=""
.endif
post-install:
- @${INSTALL_SCRIPT} ${FILESDIR}/asterisk.sh ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${WRKDIR}/asterisk.sh ${PREFIX}/etc/rc.d
.include <bsd.port.post.mk>
diff --git a/net/asterisk14/files/asterisk.sh b/net/asterisk14/files/asterisk.sh
deleted file mode 100644
index deee10c0cbe4..000000000000
--- a/net/asterisk14/files/asterisk.sh
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-
-# PROVIDE asterisk
-# REQUIRE: NETWORKING SERVERS
-# BEFORE: DAEMON
-# KEYWORD: FreeBSD shutdown
-
-#
-# Add the following lines to /etc/rc.conf to enable asterisk:
-#
-# asterisk_enable="YES"
-#
-
-. /etc/rc.subr
-
-name=asterisk
-rcvar=`set_rcvar`
-
-command=/usr/local/sbin/asterisk
-pidfile=/var/run/asterisk.pid
-
-asterisk_enable=${asterisk_enable:-"NO"}
-
-load_rc_config $name
-run_rc_command "$1"
diff --git a/net/asterisk14/files/asterisk.sh.in b/net/asterisk14/files/asterisk.sh.in
new file mode 100644
index 000000000000..10f0c4275c84
--- /dev/null
+++ b/net/asterisk14/files/asterisk.sh.in
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+# PROVIDE asterisk
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: FreeBSD shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable asterisk:
+#
+# asterisk_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=asterisk
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/asterisk
+pidfile=/var/run/asterisk.pid
+
+asterisk_enable=${asterisk_enable:-"NO"}
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index ce7f82474c8f..5802757f3e20 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -31,7 +31,7 @@ GNU_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/editline
USE_GMAKE= yes
USE_BISON= yes
-USE_RC_SUBR= yes
+USE_RC_SUBR= asterisk.sh
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
MKDIR="${MKDIR}" \
@@ -69,6 +69,6 @@ PLIST_SUB+= WITH_ZAPTEL=""
.endif
post-install:
- @${INSTALL_SCRIPT} ${FILESDIR}/asterisk.sh ${PREFIX}/etc/rc.d
+ @${INSTALL_SCRIPT} ${WRKDIR}/asterisk.sh ${PREFIX}/etc/rc.d
.include <bsd.port.post.mk>
diff --git a/net/asterisk16/files/asterisk.sh b/net/asterisk16/files/asterisk.sh
deleted file mode 100644
index deee10c0cbe4..000000000000
--- a/net/asterisk16/files/asterisk.sh
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-
-# PROVIDE asterisk
-# REQUIRE: NETWORKING SERVERS
-# BEFORE: DAEMON
-# KEYWORD: FreeBSD shutdown
-
-#
-# Add the following lines to /etc/rc.conf to enable asterisk:
-#
-# asterisk_enable="YES"
-#
-
-. /etc/rc.subr
-
-name=asterisk
-rcvar=`set_rcvar`
-
-command=/usr/local/sbin/asterisk
-pidfile=/var/run/asterisk.pid
-
-asterisk_enable=${asterisk_enable:-"NO"}
-
-load_rc_config $name
-run_rc_command "$1"
diff --git a/net/asterisk16/files/asterisk.sh.in b/net/asterisk16/files/asterisk.sh.in
new file mode 100644
index 000000000000..10f0c4275c84
--- /dev/null
+++ b/net/asterisk16/files/asterisk.sh.in
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+# PROVIDE asterisk
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: FreeBSD shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable asterisk:
+#
+# asterisk_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=asterisk
+rcvar=`set_rcvar`
+
+command=%%PREFIX%%/sbin/asterisk
+pidfile=/var/run/asterisk.pid
+
+asterisk_enable=${asterisk_enable:-"NO"}
+
+load_rc_config $name
+run_rc_command "$1"