aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2009-04-08 00:02:44 +0800
committerume <ume@FreeBSD.org>2009-04-08 00:02:44 +0800
commit3f7c7cec924f3ba186294682758932c615055bf7 (patch)
tree7ce7d96e35376ab9b200d250a7788603f11edaf9 /net
parent62dc59cf61fdf5557b3512d0ca3238bd4ce56286 (diff)
downloadfreebsd-ports-gnome-3f7c7cec924f3ba186294682758932c615055bf7.tar.gz
freebsd-ports-gnome-3f7c7cec924f3ba186294682758932c615055bf7.tar.zst
freebsd-ports-gnome-3f7c7cec924f3ba186294682758932c615055bf7.zip
New port - p5-Net-INET6Glue
Make common modules IPv6 ready by hotpatching
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-INET6Glue/Makefile22
-rw-r--r--net/p5-Net-INET6Glue/distinfo3
-rw-r--r--net/p5-Net-INET6Glue/pkg-descr12
-rw-r--r--net/p5-Net-INET6Glue/pkg-plist8
5 files changed, 46 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ae25c50d4370..dcb90743dc1f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -517,6 +517,7 @@
SUBDIR += p5-Net-GrowlClient
SUBDIR += p5-Net-HL7
SUBDIR += p5-Net-Hiveminder
+ SUBDIR += p5-Net-INET6Glue
SUBDIR += p5-Net-IPTrie
SUBDIR += p5-Net-Ident
SUBDIR += p5-Net-Interface
diff --git a/net/p5-Net-INET6Glue/Makefile b/net/p5-Net-INET6Glue/Makefile
new file mode 100644
index 000000000000..23d70809af33
--- /dev/null
+++ b/net/p5-Net-INET6Glue/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Net-INET6Glue
+# Date created: 7 Apr 2009
+# Whom: Hajimu UMEMOTO <ume@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-INET6Glue
+PORTVERSION= 0.3
+CATEGORIES= net perl5 ipv6
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ume@FreeBSD.org
+COMMENT= Make common modules IPv6 ready by hotpatching
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/Socket/INET6.pm:${PORTSDIR}/net/p5-IO-INET6
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-INET6Glue/distinfo b/net/p5-Net-INET6Glue/distinfo
new file mode 100644
index 000000000000..47e2c745412d
--- /dev/null
+++ b/net/p5-Net-INET6Glue/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-INET6Glue-0.3.tar.gz) = 42ede5075db3519fe8895711d668cfb9
+SHA256 (Net-INET6Glue-0.3.tar.gz) = 129b2e3b71224ae5627c92b28404e3694e01a3eba903be9d5256fe8a5a0b5b31
+SIZE (Net-INET6Glue-0.3.tar.gz) = 4126
diff --git a/net/p5-Net-INET6Glue/pkg-descr b/net/p5-Net-INET6Glue/pkg-descr
new file mode 100644
index 000000000000..5c4486e04334
--- /dev/null
+++ b/net/p5-Net-INET6Glue/pkg-descr
@@ -0,0 +1,12 @@
+Net::INET6Glue is a collection of modules to make common modules IPv6
+ready by hotpatching them.
+
+Unfortunatly the current state of IPv6 support in perl is that no IPv6
+support is in the core and that a lot of important modules (like
+Net::FTP, Net::SMTP, LWP,...) do not support IPv6 even if the modules
+for IPv6 sockets Socket6, IO::Socket::INET6 are available.
+
+This module tries to mitigate this by hotpatching.
+
+Author: Hajimu UMEMOTO <ume@FreeBSD.org>
+WWW: http://search.cpan.org/dist/Net-INET6Glue/
diff --git a/net/p5-Net-INET6Glue/pkg-plist b/net/p5-Net-INET6Glue/pkg-plist
new file mode 100644
index 000000000000..1f80e409b96a
--- /dev/null
+++ b/net/p5-Net-INET6Glue/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Net/INET6Glue.pm
+%%SITE_PERL%%/Net/INET6Glue/FTP.pm
+%%SITE_PERL%%/Net/INET6Glue/INET_is_INET6.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/INET6Glue/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/INET6Glue
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/INET6Glue
+@dirrmtry %%SITE_PERL%%/Net