aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-04-09 08:11:47 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-04-09 08:11:47 +0800
commit41e497baaac21f13376d89c7886c726e2ce796d3 (patch)
treefa4315087588102508f97939dc1a87b85e442970 /net
parent8497f870f86b8ac7bdf56ba6b306ab6f2b88ae2c (diff)
downloadfreebsd-ports-gnome-41e497baaac21f13376d89c7886c726e2ce796d3.tar.gz
freebsd-ports-gnome-41e497baaac21f13376d89c7886c726e2ce796d3.tar.zst
freebsd-ports-gnome-41e497baaac21f13376d89c7886c726e2ce796d3.zip
- convert to RUBYGEM_AUTOPLIST
remove x-generate-plist and friends - use RF macro and remove SUBDIR where possible - remove some uneeded GEM_NAME=${DISTNAME} (this c/should be handled better in bsd.*.mk) other deltas specific to individual ports: audio/rubygem-mp3info - unbreak, fix packaging, bump PORTREVISION devel/rubygem-rapt - adopt devel/rubygem-rspec - remove BUILD_DEPENDS=RUN_DEPENDS -- neither set devel/rubygem-ruby2ruby - add #' for vim highlight graphics/rubygem-extifr - drop PORTREVISION=0 graphics/rubygem-gd2 - add #' for vim highlight www/rubygem-rubyfulsoup - swap GEM_NAME / DISTNAME for constistency Sponsored by: RideCharge Inc. Tested on: RideCharge's Tinderbox Reviewed by: stas
Diffstat (limited to 'net')
-rw-r--r--net/rubygem-macaddr/Makefile9
-rw-r--r--net/rubygem-net-netrc/Makefile3
-rw-r--r--net/rubygem-openid/Makefile3
-rw-r--r--net/rubygem-twitter/Makefile1
-rw-r--r--net/rubygem-twitter4r/Makefile9
-rw-r--r--net/rubygem-yadis/Makefile3
6 files changed, 3 insertions, 25 deletions
diff --git a/net/rubygem-macaddr/Makefile b/net/rubygem-macaddr/Makefile
index f9e3bd757d88..2a3f6eecc736 100644
--- a/net/rubygem-macaddr/Makefile
+++ b/net/rubygem-macaddr/Makefile
@@ -15,13 +15,6 @@ COMMENT= Cross Platform Mac Address Determination for Ruby
USE_RUBY= yes
USE_RUBYGEMS= yes
-
-post-install:
- @${ECHO} ${GEM_CACHE} > ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
- @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+RUBYGEM_AUTOPLIST= yes
.include <bsd.port.mk>
diff --git a/net/rubygem-net-netrc/Makefile b/net/rubygem-net-netrc/Makefile
index c93c659ee4ac..865a183b1c24 100644
--- a/net/rubygem-net-netrc/Makefile
+++ b/net/rubygem-net-netrc/Makefile
@@ -8,8 +8,7 @@
PORTNAME= net-netrc
PORTVERSION= 0.2.1
CATEGORIES= net rubygems
-MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= RF
MAINTAINER= don@na.rim.or.jp
COMMENT= Net::Netrc provides ftp(1)-style .netrc parsing
diff --git a/net/rubygem-openid/Makefile b/net/rubygem-openid/Makefile
index a3d5fa9913f6..809e04ef026a 100644
--- a/net/rubygem-openid/Makefile
+++ b/net/rubygem-openid/Makefile
@@ -22,7 +22,4 @@ USE_RUBYGEMS= yes
GEM_NAME= ${DISTNAME}
RUBYGEM_AUTOPLIST= yes
-post-install:
- @${FIND} ${PREFIX}/${GEM_LIB_DIR} -name "*~" -delete
-
.include <bsd.port.mk>
diff --git a/net/rubygem-twitter/Makefile b/net/rubygem-twitter/Makefile
index d1cf656b5f45..a6f79ed601d0 100644
--- a/net/rubygem-twitter/Makefile
+++ b/net/rubygem-twitter/Makefile
@@ -21,7 +21,6 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
USE_RUBYGEMS= yes
-GEM_NAME= ${DISTNAME}
RUBYGEM_AUTOPLIST= yes
PLIST_FILES= bin/twitter
diff --git a/net/rubygem-twitter4r/Makefile b/net/rubygem-twitter4r/Makefile
index 4eca7d57f11b..0182d9b10c5d 100644
--- a/net/rubygem-twitter4r/Makefile
+++ b/net/rubygem-twitter4r/Makefile
@@ -19,13 +19,6 @@ RUN_DEPENDS= rubygem-json>=0.4.3:${PORTSDIR}/devel/rubygem-json
USE_RUBY= yes
USE_RUBYGEMS= yes
-
-post-install:
- @${ECHO} ${GEM_CACHE} > ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},${GEM_DOC_DIR},' >> ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type f | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},${GEM_LIB_DIR},' >> ${TMPPLIST}
- @${ECHO} ${GEM_SPEC} >> ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_LIB_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_LIB_DIR},@dirrm ${GEM_LIB_DIR},' >> ${TMPPLIST}
- @${FIND} ${PREFIX}/${GEM_DOC_DIR} -type d -depth | ${SED} -e 's,${PREFIX}/${GEM_DOC_DIR},@dirrm ${GEM_DOC_DIR},' >> ${TMPPLIST}
+RUBYGEM_AUTOPLIST= yes
.include <bsd.port.mk>
diff --git a/net/rubygem-yadis/Makefile b/net/rubygem-yadis/Makefile
index c6db49decbc0..014442399c5a 100644
--- a/net/rubygem-yadis/Makefile
+++ b/net/rubygem-yadis/Makefile
@@ -19,7 +19,4 @@ USE_RUBYGEMS= yes
GEM_NAME= ${DISTNAME}
RUBYGEM_AUTOPLIST= yes
-post-install:
- @${FIND} ${PREFIX}/${GEM_LIB_DIR} -name "*~" -delete
-
.include <bsd.port.mk>