aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2012-03-18 01:38:00 +0800
committermezz <mezz@FreeBSD.org>2012-03-18 01:38:00 +0800
commit47c2df91b0dba5d70c173196dd0e24e237f04fd1 (patch)
treeac9509271d8832544e5d558a5e35457e259996a7 /net
parentdffeaaba8a724c892333d91c157f7d2b09565d5d (diff)
downloadfreebsd-ports-gnome-47c2df91b0dba5d70c173196dd0e24e237f04fd1.tar.gz
freebsd-ports-gnome-47c2df91b0dba5d70c173196dd0e24e237f04fd1.tar.zst
freebsd-ports-gnome-47c2df91b0dba5d70c173196dd0e24e237f04fd1.zip
Fix vinagre and possible other applications when trying to connect to
TightVNC V2. Bump the PORTREVISION. PR: ports/166192 Submitted by: Kevin Oberman <rkoberman@gmail.com> Obtained from: Its git. Feature safe: yes
Diffstat (limited to 'net')
-rw-r--r--net/gtk-vnc/Makefile2
-rw-r--r--net/gtk-vnc/files/patch-src_gvnc.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/gtk-vnc/Makefile b/net/gtk-vnc/Makefile
index 3ba77388a57b..76f503999f29 100644
--- a/net/gtk-vnc/Makefile
+++ b/net/gtk-vnc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gtk-vnc
PORTVERSION= 0.3.10
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net gnome
MASTER_SITES= GNOME
diff --git a/net/gtk-vnc/files/patch-src_gvnc.c b/net/gtk-vnc/files/patch-src_gvnc.c
new file mode 100644
index 000000000000..dcf479f23c49
--- /dev/null
+++ b/net/gtk-vnc/files/patch-src_gvnc.c
@@ -0,0 +1,11 @@
+--- src/gvnc.c.orig 2012-03-17 12:30:12.000000000 -0500
++++ src/gvnc.c 2012-03-17 12:31:37.000000000 -0500
+@@ -3543,7 +3543,7 @@
+ gvnc->minor = 8;
+ }
+
+- snprintf(version, 12, "RFB %03d.%03d\n", gvnc->major, gvnc->minor);
++ snprintf(version, 13, "RFB %03d.%03d\n", gvnc->major, gvnc->minor);
+ gvnc_write(gvnc, version, 12);
+ gvnc_flush(gvnc);
+ GVNC_DEBUG("Using version: %d.%d", gvnc->major, gvnc->minor);