aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormmoll <mmoll@FreeBSD.org>2015-06-08 05:15:53 +0800
committermmoll <mmoll@FreeBSD.org>2015-06-08 05:15:53 +0800
commit4808195443d9f8aa8bf7621c4c2536a370bdec03 (patch)
tree1fdde55a3057c71cd295dc2889f1ff9c619dfd92 /net
parent474f6ff4c0628277696412228f3987a7d811994a (diff)
downloadfreebsd-ports-gnome-4808195443d9f8aa8bf7621c4c2536a370bdec03.tar.gz
freebsd-ports-gnome-4808195443d9f8aa8bf7621c4c2536a370bdec03.tar.zst
freebsd-ports-gnome-4808195443d9f8aa8bf7621c4c2536a370bdec03.zip
new port: net/rubygem-rsync
Differential Revision: https://reviews.freebsd.org/D2753 Approved by: mat (mentor)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-rsync/Makefile21
-rw-r--r--net/rubygem-rsync/distinfo2
-rw-r--r--net/rubygem-rsync/pkg-descr4
4 files changed, 28 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 0b59c5bd75c8..80e205b3e1c5 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1100,6 +1100,7 @@
SUBDIR += rubygem-right_gogrid
SUBDIR += rubygem-right_http_connection
SUBDIR += rubygem-right_slicehost
+ SUBDIR += rubygem-rsync
SUBDIR += rubygem-ruby-growl
SUBDIR += rubygem-ruby-openid
SUBDIR += rubygem-ruby-yadis
diff --git a/net/rubygem-rsync/Makefile b/net/rubygem-rsync/Makefile
new file mode 100644
index 000000000000..c4c0b6cd06ac
--- /dev/null
+++ b/net/rubygem-rsync/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= rsync
+PORTVERSION= 1.0.9
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby rsync library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync
+
+NO_ARCH= yes
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-rsync/distinfo b/net/rubygem-rsync/distinfo
new file mode 100644
index 000000000000..f1516c0ea6fe
--- /dev/null
+++ b/net/rubygem-rsync/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/rsync-1.0.9.gem) = bbdb69727a7cf17a26be5dce197d15957dfaf8ed4814811da6b1ef17f0110b5d
+SIZE (rubygem/rsync-1.0.9.gem) = 9728
diff --git a/net/rubygem-rsync/pkg-descr b/net/rubygem-rsync/pkg-descr
new file mode 100644
index 000000000000..5b8ef8e7b40b
--- /dev/null
+++ b/net/rubygem-rsync/pkg-descr
@@ -0,0 +1,4 @@
+Ruby/Rsync is a Ruby library to syncronize files between remote
+hosts by wrapping calls to the rsync binary.
+
+WWW: https://github.com/jbussdieker/ruby-rsync