aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2018-08-26 16:46:29 +0800
committerdelphij <delphij@FreeBSD.org>2018-08-26 16:46:29 +0800
commit54b52e2b909a80b2a33f29f27a0ec4b96b8e735b (patch)
tree1578214d9a99ca57838e013205be04f1f1ae3a1e /net
parent7cc1f6832b5495113ef8b4baa3590a09b7311729 (diff)
downloadfreebsd-ports-gnome-54b52e2b909a80b2a33f29f27a0ec4b96b8e735b.tar.gz
freebsd-ports-gnome-54b52e2b909a80b2a33f29f27a0ec4b96b8e735b.tar.zst
freebsd-ports-gnome-54b52e2b909a80b2a33f29f27a0ec4b96b8e735b.zip
net/samba48: Do not use arc4random_stir.
PR: 230834, 230756 Approved by: portmgr (antoine)
Diffstat (limited to 'net')
-rw-r--r--net/samba48/Makefile2
-rw-r--r--net/samba48/files/patch-source4__heimdal__lib__roken__rand.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/net/samba48/Makefile b/net/samba48/Makefile
index a4080ceb183b..937fe04b0e57 100644
--- a/net/samba48/Makefile
+++ b/net/samba48/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ${SAMBA4_BASENAME}48
PORTVERSION= ${SAMBA4_VERSION}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= net
MASTER_SITES= SAMBA/samba/stable SAMBA/samba/rc
DISTNAME= ${SAMBA4_DISTNAME}
diff --git a/net/samba48/files/patch-source4__heimdal__lib__roken__rand.c b/net/samba48/files/patch-source4__heimdal__lib__roken__rand.c
new file mode 100644
index 000000000000..1412cd66367c
--- /dev/null
+++ b/net/samba48/files/patch-source4__heimdal__lib__roken__rand.c
@@ -0,0 +1,10 @@
+--- source4/heimdal/lib/roken/rand.c.orig 2018-01-14 12:41:58.000000000 -0800
++++ source4/heimdal/lib/roken/rand.c 2018-08-22 22:11:26.937151714 -0700
+@@ -37,7 +37,6 @@
+ rk_random_init(void)
+ {
+ #if defined(HAVE_ARC4RANDOM)
+- arc4random_stir();
+ #elif defined(HAVE_SRANDOMDEV)
+ srandomdev();
+ #elif defined(HAVE_RANDOM)