aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2016-03-07 20:49:46 +0800
committerhrs <hrs@FreeBSD.org>2016-03-07 20:49:46 +0800
commit5943c78b674fb95eab6b4367b7cc625b1f2d0567 (patch)
tree60e6acd293fa4338387c217db2c9b6f11fa8f843 /net
parent1860cfb8ed7e45885075142bf30a4ab35c36833d (diff)
downloadfreebsd-ports-gnome-5943c78b674fb95eab6b4367b7cc625b1f2d0567.tar.gz
freebsd-ports-gnome-5943c78b674fb95eab6b4367b7cc625b1f2d0567.tar.zst
freebsd-ports-gnome-5943c78b674fb95eab6b4367b7cc625b1f2d0567.zip
Revert a patch to avoid na_ifaddrconf() when renewing an IA-NA address.
This patch prevented from updating the address lifetime. Reported by: garga and pfSense Bug #5955
Diffstat (limited to 'net')
-rw-r--r--net/dhcp6/Makefile2
-rw-r--r--net/dhcp6/files/patch-addrconf.c11
2 files changed, 1 insertions, 12 deletions
diff --git a/net/dhcp6/Makefile b/net/dhcp6/Makefile
index 356094664995..2e6899c1a15e 100644
--- a/net/dhcp6/Makefile
+++ b/net/dhcp6/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dhcp6
PORTVERSION= 20080615
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net ipv6
MASTER_SITES= SF/wide-dhcpv6/wide-dhcpv6/wide-dhcpv6-${PORTVERSION}
DISTNAME= wide-dhcpv6-${PORTVERSION}
diff --git a/net/dhcp6/files/patch-addrconf.c b/net/dhcp6/files/patch-addrconf.c
deleted file mode 100644
index c96efb7b648a..000000000000
--- a/net/dhcp6/files/patch-addrconf.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- addrconf.c.orig 2008-06-15 07:48:40 UTC
-+++ addrconf.c
-@@ -173,7 +173,7 @@ update_address(ia, addr, dhcpifp, ctlp,
- sacreate ? "create" : "update",
- in6addr2str(&addr->addr, 0), addr->pltime, addr->vltime);
-
-- if (sa->addr.vltime != 0)
-+ if (sa->addr.vltime != 0 && sacreate)
- if (na_ifaddrconf(IFADDRCONF_ADD, sa) < 0)
- return (-1);
-