aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2008-12-10 15:35:19 +0800
committerlinimon <linimon@FreeBSD.org>2008-12-10 15:35:19 +0800
commit5dba952df544cb22578a4420dc76372bf8c11096 (patch)
tree63368d4aae4db9efc2ca032511e7db5f40e56105 /net
parent812b68b187731c45d5704e2e36d4a4d9ad5606b7 (diff)
downloadfreebsd-ports-gnome-5dba952df544cb22578a4420dc76372bf8c11096.tar.gz
freebsd-ports-gnome-5dba952df544cb22578a4420dc76372bf8c11096.tar.zst
freebsd-ports-gnome-5dba952df544cb22578a4420dc76372bf8c11096.zip
Mark as broken on sparc64.
Hat: portmgr
Diffstat (limited to 'net')
-rw-r--r--net/skystar2/Makefile8
-rw-r--r--net/ttbudget/Makefile8
-rw-r--r--net/xorp/Makefile4
3 files changed, 18 insertions, 2 deletions
diff --git a/net/skystar2/Makefile b/net/skystar2/Makefile
index e9103ba04f66..e9fd0b5e54da 100644
--- a/net/skystar2/Makefile
+++ b/net/skystar2/Makefile
@@ -43,4 +43,10 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/ttbudget/Makefile b/net/ttbudget/Makefile
index fbd85aa34e71..eb12f3b52727 100644
--- a/net/ttbudget/Makefile
+++ b/net/ttbudget/Makefile
@@ -32,4 +32,10 @@ pre-fetch:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/xorp/Makefile b/net/xorp/Makefile
index 1e93ff06dad1..35c4ddc24ac9 100644
--- a/net/xorp/Makefile
+++ b/net/xorp/Makefile
@@ -95,6 +95,10 @@ CONFIGURE_ARGS+= --enable-debug-msgs --enable-debug-fnames
CONFIGURE_ARGS+= --enable-profile
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile on sparc64
+.endif
+
post-install:
${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL