aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2015-12-27 20:53:32 +0800
committerriggs <riggs@FreeBSD.org>2015-12-27 20:53:32 +0800
commit5e988d1f0acc6385f35a595237dda8c32436321a (patch)
treea3c27ccdce535e112800f57e038f552c2984b5ad /net
parentca3fe96fd612a7067a12a766b5e9254522f44798 (diff)
downloadfreebsd-ports-gnome-5e988d1f0acc6385f35a595237dda8c32436321a.tar.gz
freebsd-ports-gnome-5e988d1f0acc6385f35a595237dda8c32436321a.tar.zst
freebsd-ports-gnome-5e988d1f0acc6385f35a595237dda8c32436321a.zip
Update to upstream version 2.2; general cleanup
Detailed log by submitter: - Update net/chrony to latest upstream version - 2.2 - install info - point to /var/db instead of /var/lib (per hier(7)) - use doc/install-docs target; install more docs (PORTDOCS) - use @sample to a sample .conf file (not for .keys which will require manual intervention); others in examples dir (use PORTEXAMPLES) - rm old post-install target - fix example files for freebsd/prefix paths & ntp server names, add info regarding how to do log rotation if logging turned on. PR: 204817 Submitted by: z7dr6ut7gs@snkmail.com Approved by: maintainer timeout
Diffstat (limited to 'net')
-rw-r--r--net/chrony/Makefile24
-rw-r--r--net/chrony/distinfo4
-rw-r--r--net/chrony/files/patch-examples-chrony.conf.example45
-rw-r--r--net/chrony/files/patch-examples-chrony.conf.example233
-rw-r--r--net/chrony/files/patch-examples_chrony.conf.example113
-rw-r--r--net/chrony/files/patch-examples_chrony.conf.example223
-rw-r--r--net/chrony/files/patch-examples_chrony.conf.example375
-rw-r--r--net/chrony/pkg-plist9
8 files changed, 133 insertions, 93 deletions
diff --git a/net/chrony/Makefile b/net/chrony/Makefile
index 29a5e7776677..0bb9c9fc2ca2 100644
--- a/net/chrony/Makefile
+++ b/net/chrony/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= chrony
-PORTVERSION= 1.31.1
+PORTVERSION= 2.2
CATEGORIES= net
MASTER_SITES= http://download.tuxfamily.org/chrony/
@@ -19,11 +19,19 @@ USES= cpe gmake makeinfo readline
CPE_VENDOR= tuxfamily
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --chronyvardir=/var/db/${PORTNAME} \
+ --infodir=${PREFIX}/info \
--sysconfdir=${PREFIX}/etc --mandir=${MANPREFIX}/man \
--datarootdir=${DATADIR} --docdir=${DOCSDIR}
USE_RC_SUBR= chronyd
-PORTDOCS= COPYING README chrony.txt
+ALL_TARGET= all docs
+INSTALL_TARGET= install install-docs
+INFO= chrony
+EXTRAPORTDOCS= FAQ NEWS README
+PORTDOCS= chrony.html chrony.txt ${EXTRAPORTDOCS}
+PORTEXAMPLES= chrony.conf.example1 chrony.conf.example2 \
+ chrony.conf.example3 chrony.keys.example
# XXX: there are also other potentially useful options worth looking into:
# --without-nss Don't use NSS even if it is available
@@ -38,10 +46,12 @@ IPV6_CONFIGURE_OFF= --disable-ipv6
post-stage:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/chronyc
${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/chronyd
-
-post-install:
-.for f in chrony.conf.example chrony.conf.example2 chrony.keys.example
- ${INSTALL_DATA} ${WRKSRC}/examples/${f} ${STAGEDIR}${PREFIX}/etc
-.endfor
+ cd ${WRKSRC}/${f} && \
+ ${INSTALL_DATA} ${EXTRAPORTDOCS} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && \
+ ${INSTALL_DATA} ${PORTEXAMPLES} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && \
+ ${INSTALL_DATA} chrony.conf.example3 ${STAGEDIR}${PREFIX}/etc/chrony.conf.sample
.include <bsd.port.mk>
diff --git a/net/chrony/distinfo b/net/chrony/distinfo
index 08faec048a07..f12517b2581d 100644
--- a/net/chrony/distinfo
+++ b/net/chrony/distinfo
@@ -1,2 +1,2 @@
-SHA256 (chrony-1.31.1.tar.gz) = 0ba9f4b58e20b2eaae921eb8c798108ef72d8ea6fdcc7eb0167b56690d212348
-SIZE (chrony-1.31.1.tar.gz) = 395797
+SHA256 (chrony-2.2.tar.gz) = d3fd820fa63badf54ee0e48a649b94ea739df3aac5efa104bd90f89795aa2485
+SIZE (chrony-2.2.tar.gz) = 340285
diff --git a/net/chrony/files/patch-examples-chrony.conf.example b/net/chrony/files/patch-examples-chrony.conf.example
deleted file mode 100644
index 3a21e0c09206..000000000000
--- a/net/chrony/files/patch-examples-chrony.conf.example
+++ /dev/null
@@ -1,45 +0,0 @@
---- examples/chrony.conf.example.orig 2015-04-07 14:35:16 UTC
-+++ examples/chrony.conf.example
-@@ -42,6 +42,13 @@
- # Failing that, there are a lot of public NTP servers. There is a list
- # you can access at http://support.ntp.org/bin/view/Servers/WebHome or
- # you can use servers from the pool.ntp.org project.
-+#
-+# The option `iburst' is used for faster initial synchronization.
-+
-+server 0.freebsd.pool.ntp.org iburst
-+server 1.freebsd.pool.ntp.org iburst
-+server 2.freebsd.pool.ntp.org iburst
-+#server 3.freebsd.pool.ntp.org iburst
-
- ! server 0.pool.ntp.org iburst
- ! server 1.pool.ntp.org iburst
-@@ -98,7 +105,7 @@ driftfile /var/lib/chrony/drift
- # exchanges between cooperating machines.) Again, this option is
- # assumed by default.
-
--keyfile /etc/chrony.keys
-+keyfile /usr/local/etc/chrony.keys
-
- # Tell chronyd which numbered key in the file is used as the password
- # for chronyc. (You can pick any integer up to 2**32-1. '1' is just a
-@@ -132,7 +139,7 @@ generatecommandkey
- # still running and bail out. If you want to change the path to the PID
- # file, uncomment this line and edit it. The default path is shown.
-
--! pidfile /var/run/chronyd.pid
-+pidfile /var/run/chronyd.pid
-
- #######################################################################
- ### INITIAL CLOCK CORRECTION
-@@ -155,8 +162,8 @@ generatecommandkey
- # produce some graphs of your system's timekeeping performance, or you
- # need help in debugging a problem.
-
--! logdir /var/log/chrony
--! log measurements statistics tracking
-+logdir /var/log/chrony
-+log measurements statistics tracking
-
- # If you have real time clock support enabled (see below), you might want
- # this line instead:
diff --git a/net/chrony/files/patch-examples-chrony.conf.example2 b/net/chrony/files/patch-examples-chrony.conf.example2
deleted file mode 100644
index c7f3cced3ed9..000000000000
--- a/net/chrony/files/patch-examples-chrony.conf.example2
+++ /dev/null
@@ -1,33 +0,0 @@
---- examples/chrony.conf.example2.orig 2015-04-07 14:35:16 UTC
-+++ examples/chrony.conf.example2
-@@ -1,9 +1,17 @@
- # Use public servers from the pool.ntp.org project.
- # Please consider joining the pool (http://www.pool.ntp.org/join.html).
--server 0.pool.ntp.org iburst
--server 1.pool.ntp.org iburst
--server 2.pool.ntp.org iburst
--server 3.pool.ntp.org iburst
-+#
-+# The option `iburst' is used for faster initial synchronization.
-+#
-+server 0.freebsd.pool.ntp.org iburst
-+server 1.freebsd.pool.ntp.org iburst
-+server 2.freebsd.pool.ntp.org iburst
-+#server 3.freebsd.pool.ntp.org iburst
-+
-+#server 0.pool.ntp.org iburst
-+#server 1.pool.ntp.org iburst
-+#server 2.pool.ntp.org iburst
-+#server 3.pool.ntp.org iburst
-
- # Ignore stratum in source selection.
- stratumweight 0
-@@ -28,7 +36,7 @@ bindcmdaddress ::1
- # Serve time even if not synchronized to any NTP server.
- #local stratum 10
-
--keyfile /etc/chrony.keys
-+keyfile /usr/local/etc/chrony.keys
-
- # Specify the key used as password for chronyc.
- commandkey 1
diff --git a/net/chrony/files/patch-examples_chrony.conf.example1 b/net/chrony/files/patch-examples_chrony.conf.example1
new file mode 100644
index 000000000000..fc005cd87ba5
--- /dev/null
+++ b/net/chrony/files/patch-examples_chrony.conf.example1
@@ -0,0 +1,13 @@
+--- examples/chrony.conf.example1.orig 2015-10-19 09:18:37 UTC
++++ examples/chrony.conf.example1
+@@ -1,8 +1,8 @@
+ # Use public NTP servers from the pool.ntp.org project.
+-pool pool.ntp.org iburst
++pool 0.freebsd.pool.ntp.org iburst
+
+ # Record the rate at which the system clock gains/losses time.
+-driftfile /var/lib/chrony/drift
++driftfile /var/db/chrony/drift
+
+ # In first three updates step the system clock instead of slew
+ # if the adjustment is larger than 1 second.
diff --git a/net/chrony/files/patch-examples_chrony.conf.example2 b/net/chrony/files/patch-examples_chrony.conf.example2
new file mode 100644
index 000000000000..14de65fac959
--- /dev/null
+++ b/net/chrony/files/patch-examples_chrony.conf.example2
@@ -0,0 +1,23 @@
+--- examples/chrony.conf.example2.orig 2015-10-19 09:18:37 UTC
++++ examples/chrony.conf.example2
+@@ -1,9 +1,9 @@
+ # Use public servers from the pool.ntp.org project.
+ # Please consider joining the pool (http://www.pool.ntp.org/join.html).
+-pool pool.ntp.org iburst
++pool 0.freebsd.pool.ntp.org iburst
+
+ # Record the rate at which the system clock gains/losses time.
+-driftfile /var/lib/chrony/drift
++driftfile /var/db/chrony/drift
+
+ # In first three updates step the system clock instead of slew
+ # if the adjustment is larger than 1 second.
+@@ -19,7 +19,7 @@ rtcsync
+ #local stratum 10
+
+ # Specify file containing keys for NTP authentication.
+-#keyfile /etc/chrony.keys
++#keyfile /usr/local/etc/chrony.keys
+
+ # Disable logging of client accesses.
+ noclientlog
diff --git a/net/chrony/files/patch-examples_chrony.conf.example3 b/net/chrony/files/patch-examples_chrony.conf.example3
new file mode 100644
index 000000000000..273e15d75045
--- /dev/null
+++ b/net/chrony/files/patch-examples_chrony.conf.example3
@@ -0,0 +1,75 @@
+--- examples/chrony.conf.example3.orig 2015-10-19 09:18:37 UTC
++++ examples/chrony.conf.example3
+@@ -1,7 +1,7 @@
+ #######################################################################
+ #
+ # This is an example chrony configuration file. You should copy it to
+-# /etc/chrony.conf after uncommenting and editing the options that you
++# /usr/local/etc/chrony.conf after uncommenting and editing the options that you
+ # want to enable. The more obscure options are not included. Refer
+ # to the documentation for these.
+ #
+@@ -47,7 +47,9 @@
+ ! server bar.example.net iburst
+ ! server baz.example.net iburst
+
+-! pool pool.ntp.org iburst
++# This is a reasonable default setting to have on in typical cases for
++# a workstation with a full-time internet connection:
++pool 0.freebsd.pool.ntp.org iburst
+
+ # However, for dial-up use you probably want these instead. The word
+ # 'offline' means that the server is not visible at boot time. Use
+@@ -58,7 +60,7 @@
+ ! server bar.example.net offline
+ ! server baz.example.net offline
+
+-! pool pool.ntp.org offline
++! pool 0.freebsd.pool.ntp.org offline
+
+ # You may want to specify NTP 'peers' instead. If you run a network
+ # with a lot of computers and want several computers running chrony to
+@@ -93,12 +95,12 @@
+ # immediately so that it doesn't gain or lose any more time. You
+ # generally want this, so it is uncommented.
+
+-driftfile /var/lib/chrony/drift
++driftfile /var/db/chrony/drift
+
+ # If you want to enable NTP authentication with symmetric keys, you will need
+ # to uncomment the following line and edit the file to set up the keys.
+
+-! keyfile /etc/chrony.keys
++! keyfile /usr/local/etc/chrony.keys
+
+ # chronyd can save the measurement history for the servers to files when
+ # it it exits. This is useful in 2 situations:
+@@ -116,7 +118,7 @@ driftfile /var/lib/chrony/drift
+ # Enable these two options to use this.
+
+ ! dumponexit
+-! dumpdir /var/lib/chrony
++! dumpdir /var/db/chrony
+
+ # chronyd writes its process ID to a file. If you try to start a second
+ # copy of chronyd, it will detect that the process named in the file is
+@@ -145,6 +147,10 @@ driftfile /var/lib/chrony/drift
+ # only need this if you really enjoy looking at the logs, you want to
+ # produce some graphs of your system's timekeeping performance, or you
+ # need help in debugging a problem.
++#
++# If you enable logging, you may want to add an entry to a log rotation
++# utility's configuration (e.g., newsyslog(8)). 'chronyc cyclelogs'
++# should be used to signal chronyd that a log file has been renamed.
+
+ ! logdir /var/log/chrony
+ ! log measurements statistics tracking
+@@ -259,7 +265,7 @@ driftfile /var/lib/chrony/drift
+ # You need to have 'enhanced RTC support' compiled into your Linux
+ # kernel. (Note, these options apply only to Linux.)
+
+-! rtcfile /var/lib/chrony/rtc
++! rtcfile /var/db/chrony/rtc
+
+ # Your RTC can be set to keep Universal Coordinated Time (UTC) or local
+ # time. (Local time means UTC +/- the effect of your timezone.) If you
diff --git a/net/chrony/pkg-plist b/net/chrony/pkg-plist
index 89d20cb36f4d..c201b1a10c8c 100644
--- a/net/chrony/pkg-plist
+++ b/net/chrony/pkg-plist
@@ -1,11 +1,8 @@
bin/chronyc
-etc/chrony.conf.example
-etc/chrony.conf.example2
-etc/chrony.keys.example
-man/man1/chrony.1.gz
+@sample etc/chrony.conf.sample
man/man1/chronyc.1.gz
man/man5/chrony.conf.5.gz
man/man8/chronyd.8.gz
sbin/chronyd
-@dir /var/lib/chrony
-@dir /var/lib
+@dir /var/db/chrony
+@dir /var/db