aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-07-23 06:45:51 +0800
committerpat <pat@FreeBSD.org>2002-07-23 06:45:51 +0800
commit634f969f1f4ba262e69a18f3aebd5c77d1a62ddc (patch)
tree813389aa0e9d60376a7d5aa823361855e9658595 /net
parent23fc82ca2c940130b53999beb327b1161bc7f831 (diff)
downloadfreebsd-ports-gnome-634f969f1f4ba262e69a18f3aebd5c77d1a62ddc.tar.gz
freebsd-ports-gnome-634f969f1f4ba262e69a18f3aebd5c77d1a62ddc.tar.zst
freebsd-ports-gnome-634f969f1f4ba262e69a18f3aebd5c77d1a62ddc.zip
Fix build: wrong location of included getopt.h
PR: ports/40902 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'net')
-rw-r--r--net/gnunet/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/net/gnunet/Makefile b/net/gnunet/Makefile
index fa97c6313885..1493af21d74c 100644
--- a/net/gnunet/Makefile
+++ b/net/gnunet/Makefile
@@ -33,5 +33,10 @@ MAN5= gnunet.conf.5
post-patch:
@${REINPLACE_CMD} 's|-pthread [\$$]CFLAGS|\$$CFLAGS|g ; \
s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+.for file in src/include/server/startup.h src/server/startup.c \
+ src/textui/gnunetdownload.c src/textui/insertmain.c \
+ src/textui/insertmulti.c src/util/getopt.c src/util/getopt1.c
+ @${REINPLACE_CMD} -e 's|"getopt.h"|"util/getopt.h"|g' ${WRKSRC}/${file}
+.endfor
.include <bsd.port.mk>