aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-03-04 08:06:59 +0800
committerantoine <antoine@FreeBSD.org>2014-03-04 08:06:59 +0800
commit766886adac08b20d63e99f2d9e18df8bfb93cc44 (patch)
treef0c7d15a9b021170f1b28c388a9e495e6ee0091f /net
parent94378812465702c10db677bfe9cca9bb65123b14 (diff)
downloadfreebsd-ports-gnome-766886adac08b20d63e99f2d9e18df8bfb93cc44.tar.gz
freebsd-ports-gnome-766886adac08b20d63e99f2d9e18df8bfb93cc44.tar.zst
freebsd-ports-gnome-766886adac08b20d63e99f2d9e18df8bfb93cc44.zip
Fix runtime on FreeBSD >= 10
Diffstat (limited to 'net')
-rw-r--r--net/scapy/Makefile3
-rw-r--r--net/scapy/files/patch-scapy__arch__unix.py32
2 files changed, 34 insertions, 1 deletions
diff --git a/net/scapy/Makefile b/net/scapy/Makefile
index 54268340beab..1a41c113d6dc 100644
--- a/net/scapy/Makefile
+++ b/net/scapy/Makefile
@@ -3,6 +3,7 @@
PORTNAME= scapy
PORTVERSION= 2.2.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://secdev.org/projects/scapy/files/
@@ -35,7 +36,7 @@ GRAPH_RUN_DEPENDS= ${LOCALBASE}/bin/MagickCore-config:${PORTSDIR}/graphics/Image
P0F_BASE_RUN_DEPENDS= ${LOCALBASE}/etc/p0f/p0f.fp:${PORTSDIR}/net-mgmt/p0f
QUESO_BASE_RUN_DEPENDS= ${LOCALBASE}/etc/queso.conf.sample:${PORTSDIR}/net/queso
NMAP_RUN_DEPENDS= ${LOCALBASE}/share/nmap/nmap-os-db:${PORTSDIR}/security/nmap
-MANUF_RUN_DEPENDS+= ${LOCALBASE}/share/wireshark/manuf:${PORTSDIR}/net/wireshark
+MANUF_RUN_DEPENDS= ${LOCALBASE}/share/wireshark/manuf:${PORTSDIR}/net/wireshark
SOX_RUN_DEPENDS= ${LOCALBASE}/bin/sox:${PORTSDIR}/audio/sox
post-patch:
diff --git a/net/scapy/files/patch-scapy__arch__unix.py b/net/scapy/files/patch-scapy__arch__unix.py
new file mode 100644
index 000000000000..d2d4d776be72
--- /dev/null
+++ b/net/scapy/files/patch-scapy__arch__unix.py
@@ -0,0 +1,32 @@
+--- ./scapy/arch/unix.py.orig 2010-08-10 23:09:40.000000000 +0000
++++ ./scapy/arch/unix.py 2014-03-03 23:59:21.000000000 +0000
+@@ -38,6 +38,8 @@
+ ok = 0
+ mtu_present = False
+ prio_present = False
++ refs_present = False
++ use_present = False
+ routes = []
+ pending_if = []
+ for l in f.readlines():
+@@ -51,6 +53,8 @@
+ ok = 1
+ mtu_present = l.find("Mtu") >= 0
+ prio_present = l.find("Prio") >= 0
++ refs_present = l.find("Refs") >= 0
++ use_present = l.find("Use") >= 0
+ continue
+ if not l:
+ break
+@@ -64,7 +68,10 @@
+ else:
+ rt = l.split()
+ dest,gw,flg = rt[:3]
+- netif = rt[5+mtu_present+prio_present]
++ if scapy.arch.FREEBSD:
++ netif = rt[3+refs_present+use_present+mtu_present]
++ else:
++ netif = rt[5+mtu_present+prio_present]
+ if flg.find("Lc") >= 0:
+ continue
+ if dest == "default":