aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-01-16 23:05:24 +0800
committermiwi <miwi@FreeBSD.org>2014-01-16 23:05:24 +0800
commit7bc486af9c21ff1d84f65334bdc950cf485d7010 (patch)
tree8f0126341e60521cef7cf6a5062f820b8f385417 /net
parentfcc1a1ff2240b72dfe19c69c327fba6c2ce3f6e1 (diff)
downloadfreebsd-ports-gnome-7bc486af9c21ff1d84f65334bdc950cf485d7010.tar.gz
freebsd-ports-gnome-7bc486af9c21ff1d84f65334bdc950cf485d7010.tar.zst
freebsd-ports-gnome-7bc486af9c21ff1d84f65334bdc950cf485d7010.zip
- Fix build on FreeBSD 10.
PR: 185683 Submitted by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/yconalyzer/Makefile3
-rw-r--r--net/yconalyzer/files/patch-yconalyzer.cc23
2 files changed, 25 insertions, 1 deletions
diff --git a/net/yconalyzer/Makefile b/net/yconalyzer/Makefile
index c36157daae65..f541752e5ae8 100644
--- a/net/yconalyzer/Makefile
+++ b/net/yconalyzer/Makefile
@@ -3,6 +3,7 @@
PORTNAME= yconalyzer
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,10 +15,10 @@ GNU_CONFIGURE= yes
PLIST_FILES= bin/yconalyzer
USE_BZIP2= yes
USE_GMAKE= yes
+NO_STAGE= yes
MAN8= yconalyzer.8
-NO_STAGE= yes
pre-install:
${CHMOD} a+x ${WRKSRC}/install-sh
diff --git a/net/yconalyzer/files/patch-yconalyzer.cc b/net/yconalyzer/files/patch-yconalyzer.cc
new file mode 100644
index 000000000000..1485560c10b5
--- /dev/null
+++ b/net/yconalyzer/files/patch-yconalyzer.cc
@@ -0,0 +1,23 @@
+--- yconalyzer.cc.orig 2014-01-12 14:15:17.000000000 +0800
++++ yconalyzer.cc 2014-01-12 14:17:49.000000000 +0800
+@@ -76,19 +76,11 @@
+
+ #include <string>
+
+-#if __GNUC__ > 2
+ #include <map>
+-using namespace _GLIBCXX_STD;
++using namespace std;
+ // Linux gcc-3 is not too happy with the format strings we use in BSD.
+ #define KEY_FMT_STRING "%#8x%#4x"
+
+-#else /* We are using gnu-c <= 2 */
+-
+-#include <hash_map.h>
+-#define KEY_FMT_STRING "%8ux%4hx"
+-
+-#endif
+-
+ static int debug = 0;
+ static u_short port = 0;
+ static int nbuckets;