aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-03-09 04:10:43 +0800
committerpav <pav@FreeBSD.org>2005-03-09 04:10:43 +0800
commit7eea453e733c7c716304ba6fb89a54ef334d9e9e (patch)
tree8201ade6d685b15f331f76daa59a4a610bf427de /net
parentc50ebe9feda4a5628d494cdc8659b1ed69e3e999 (diff)
downloadfreebsd-ports-gnome-7eea453e733c7c716304ba6fb89a54ef334d9e9e.tar.gz
freebsd-ports-gnome-7eea453e733c7c716304ba6fb89a54ef334d9e9e.tar.zst
freebsd-ports-gnome-7eea453e733c7c716304ba6fb89a54ef334d9e9e.zip
PEAR::Net_Dict provides a simple API to the DICT Protocol handling all the
network related issues and providing DICT responses in PHP datatypes to make it easy for a developer to use DICT servers in their programs. PR: ports/78550 Submitted by: Antonio Carlos Venancio Junior <antonio@php.net>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pear-Net_Dict/Makefile24
-rw-r--r--net/pear-Net_Dict/distinfo2
-rw-r--r--net/pear-Net_Dict/pkg-descr5
4 files changed, 32 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f229a8ae5e70..fef8796571a0 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -547,6 +547,7 @@
SUBDIR += pcnfsd
SUBDIR += pear-Net_CheckIP
SUBDIR += pear-Net_DIME
+ SUBDIR += pear-Net_Dict
SUBDIR += pear-Net_DNSBL
SUBDIR += pear-Net_IPv6
SUBDIR += pear-Net_NNTP
diff --git a/net/pear-Net_Dict/Makefile b/net/pear-Net_Dict/Makefile
new file mode 100644
index 000000000000..dea67a43d845
--- /dev/null
+++ b/net/pear-Net_Dict/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: pear-Net_Dict
+# Date created: 07 March 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_Dict
+PORTVERSION= 1.0.3
+CATEGORIES= net www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR interface to the DICT protocol
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Net
+FILES= Dict.php
+DOCS= dict.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/net/pear-Net_Dict/distinfo b/net/pear-Net_Dict/distinfo
new file mode 100644
index 000000000000..8a7ae8887a3a
--- /dev/null
+++ b/net/pear-Net_Dict/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Net_Dict-1.0.3.tgz) = 1c49798c35f2c1b4818dcd18f02fa7c1
+SIZE (PEAR/Net_Dict-1.0.3.tgz) = 5441
diff --git a/net/pear-Net_Dict/pkg-descr b/net/pear-Net_Dict/pkg-descr
new file mode 100644
index 000000000000..0cbaecc3cef1
--- /dev/null
+++ b/net/pear-Net_Dict/pkg-descr
@@ -0,0 +1,5 @@
+PEAR::Net_Dict provides a simple API to the DICT Protocol handling all the
+network related issues and providing DICT responses in PHP datatypes to
+make it easy for a developer to use DICT servers in their programs.
+
+WWW: http://pear.php.net/package/Net_Dict/