aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2016-01-11 00:31:33 +0800
committerbapt <bapt@FreeBSD.org>2016-01-11 00:31:33 +0800
commit834e21da3d78bade53f6940b62c4b1d11ff57062 (patch)
tree45355dccba19623f8780fff011f8b7e1a576c0e2 /net
parent0b449150804dd839d3aec0f8dcde508b07c60a84 (diff)
downloadfreebsd-ports-gnome-834e21da3d78bade53f6940b62c4b1d11ff57062.tar.gz
freebsd-ports-gnome-834e21da3d78bade53f6940b62c4b1d11ff57062.tar.zst
freebsd-ports-gnome-834e21da3d78bade53f6940b62c4b1d11ff57062.zip
Convert ports from s* t* and net* categories to USES=sqlite and USES=firebird
Diffstat (limited to 'net')
-rw-r--r--net/asterisk11/Makefile3
-rw-r--r--net/asterisk13/Makefile3
-rw-r--r--net/freeradius2/Makefile2
-rw-r--r--net/freeradius3/Makefile2
-rw-r--r--net/kget/Makefile3
-rw-r--r--net/liferea/Makefile3
-rw-r--r--net/ntopng/Makefile3
-rw-r--r--net/prosearch/Makefile2
-rw-r--r--net/quiterss/Makefile3
-rw-r--r--net/turnserver/Makefile2
10 files changed, 10 insertions, 16 deletions
diff --git a/net/asterisk11/Makefile b/net/asterisk11/Makefile
index 2f1e2ea1d833..34a96045b68b 100644
--- a/net/asterisk11/Makefile
+++ b/net/asterisk11/Makefile
@@ -21,12 +21,11 @@ EXTRACT_ONLY:= ${DISTNAME}${EXTRACT_SUFX}
ONLY_FOR_ARCHS= i386 amd64 powerpc sparc64
-USES= bison cpe gmake iconv localbase ncurses shebangfix
+USES= bison cpe gmake iconv localbase ncurses shebangfix sqlite
USE_CSTD= gnu89
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_OPENSSL= yes
-USE_SQLITE= 3
USE_RC_SUBR= asterisk
GNU_CONFIGURE= yes
diff --git a/net/asterisk13/Makefile b/net/asterisk13/Makefile
index 36159370cab0..a8513ecb9514 100644
--- a/net/asterisk13/Makefile
+++ b/net/asterisk13/Makefile
@@ -24,12 +24,11 @@ EXTRACT_ONLY:= ${DISTNAME}${EXTRACT_SUFX}
ONLY_FOR_ARCHS= i386 amd64 powerpc sparc64
-USES= bison cpe gmake iconv localbase ncurses shebangfix
+USES= bison cpe gmake iconv localbase ncurses shebangfix sqlite
USE_CSTD= gnu89
USE_GNOME= libxml2
USE_LDCONFIG= yes
USE_OPENSSL= yes
-USE_SQLITE= 3
USE_RC_SUBR= asterisk
GNU_CONFIGURE= yes
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index f025fe0dbf0f..7cfc9dc45848 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -177,7 +177,7 @@ PLIST_SUB+= UNIXODBC="@comment "
.endif
.if ${PORT_OPTIONS:MFIREBIRD}
-USE_FIREBIRD= YES
+USES+= firebird
CONFIGURE_ARGS+=--with-rlm_sql_firebird
PLIST_SUB+= FIREBIRD=""
.else
diff --git a/net/freeradius3/Makefile b/net/freeradius3/Makefile
index 61114a9db6a8..45ecb5f8512d 100644
--- a/net/freeradius3/Makefile
+++ b/net/freeradius3/Makefile
@@ -154,7 +154,7 @@ PLIST_SUB+= UNIXODBC="@comment "
.endif
.if ${PORT_OPTIONS:MFIREBIRD}
-USE_FIREBIRD= YES
+USES+= firebird
CONFIGURE_ARGS+=--with-rlm_sql_firebird
PLIST_SUB+= FIREBIRD=""
.else
diff --git a/net/kget/Makefile b/net/kget/Makefile
index ef8100dcb017..0ea2a148a3eb 100644
--- a/net/kget/Makefile
+++ b/net/kget/Makefile
@@ -16,11 +16,10 @@ LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme \
libqca.so:${PORTSDIR}/devel/qca \
libboost_thread.so:${PORTSDIR}/devel/boost-libs
-USE_SQLITE= yes
USE_KDE4= kdelibs kdeprefix workspace libkonq \
nepomuk-core nepomuk-widgets automoc4 ontologies \
soprano
-USES= cmake:outsource shebangfix tar:xz
+USES= cmake:outsource shebangfix sqlite tar:xz
SHEBANG_FILES= conf/*.pl
USE_QT4= gui sql moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index 947faa2d34a0..1e552dfaf372 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -19,10 +19,9 @@ RUN_DEPENDS= gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-sc
${PYTHON_PKGNAMEPREFIX}libpeas>=0:${PORTSDIR}/devel/py-libpeas
USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
- python:2 tar:bzip2
+ python:2 sqlite tar:bzip2
USE_GNOME= dconf:run gtk30 intltool introspection:build \
libxslt:build libxml2
-USE_SQLITE= 3
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
diff --git a/net/ntopng/Makefile b/net/ntopng/Makefile
index 12c463c9cb6f..b200b684a61d 100644
--- a/net/ntopng/Makefile
+++ b/net/ntopng/Makefile
@@ -21,10 +21,9 @@ LIB_DEPENDS= librrd.so:${PORTSDIR}/databases/rrdtool \
libzmq.so:${PORTSDIR}/net/libzmq4
GNU_CONFIGURE= yes
-USE_SQLITE= yes
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
-USES= autoreconf cpe gmake libtool pathfix pkgconfig tar:tgz
+USES= autoreconf cpe gmake libtool pathfix pkgconfig sqlite tar:tgz
SUB_FILES= ntopng-geoipupdate.sh
CPE_VENDOR= ntop
diff --git a/net/prosearch/Makefile b/net/prosearch/Makefile
index 7697850c0994..23da4d5d2c57 100644
--- a/net/prosearch/Makefile
+++ b/net/prosearch/Makefile
@@ -129,7 +129,7 @@ WANT_PGSQL= client server
.endif
.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= yes
+USES+= sqlite
RUN_DEPENDS+=\
p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
.endif
diff --git a/net/quiterss/Makefile b/net/quiterss/Makefile
index 0962837f1512..de8c9835065b 100644
--- a/net/quiterss/Makefile
+++ b/net/quiterss/Makefile
@@ -15,8 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
NO_WRKSUBDIR= yes
-USES= desktop-file-utils pkgconfig qmake:outsource
-USE_SQLITE= yes
+USES= desktop-file-utils pkgconfig qmake:outsource sqlite
INSTALLS_ICONS= yes
OPTIONS_DEFINE= DEBUG
diff --git a/net/turnserver/Makefile b/net/turnserver/Makefile
index ab4bc1f7bfbd..df4bb07b269e 100644
--- a/net/turnserver/Makefile
+++ b/net/turnserver/Makefile
@@ -94,7 +94,7 @@ CONFIGURE_ENG+= TURN_NO_MONGO=1
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSQLITE}
-USE_SQLITE= yes
+USES+= sqlite
.else
CONFIGURE_ENV+= TURN_NO_SQLITE=1
.endif