aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormm <mm@FreeBSD.org>2012-12-31 18:49:52 +0800
committermm <mm@FreeBSD.org>2012-12-31 18:49:52 +0800
commit8fb4a7f3ab56137426c2609ba1fb961341e34fc0 (patch)
tree90a777fd8234cb4f3af8a4c1f0fdfbab5c7571d4 /net
parentc1d1f5c85c8313305f35b99a9351f0df7236fe23 (diff)
downloadfreebsd-ports-gnome-8fb4a7f3ab56137426c2609ba1fb961341e34fc0.tar.gz
freebsd-ports-gnome-8fb4a7f3ab56137426c2609ba1fb961341e34fc0.tar.zst
freebsd-ports-gnome-8fb4a7f3ab56137426c2609ba1fb961341e34fc0.zip
Update some of my ports to new options framework
Submitted by: Baptiste Daroussin <bapt@FreeBSD.org>
Diffstat (limited to 'net')
-rw-r--r--net/relayd/Makefile10
-rw-r--r--net/smbldap-tools/Makefile23
2 files changed, 14 insertions, 19 deletions
diff --git a/net/relayd/Makefile b/net/relayd/Makefile
index 3d9977449cc0..1d899d5e4125 100644
--- a/net/relayd/Makefile
+++ b/net/relayd/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: relayd
-# Date created: 5 Jun 2007
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
+# Created by: Jun Kuriyama <kuriyama@FreeBSD.org>
# $FreeBSD$
PORTNAME= relayd
@@ -33,11 +30,12 @@ MAKE_ARGS+= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man
USERS= _relayd
GROUPS= _relayd
-OPTIONS= LIBEVENT_STATIC "Build with static libevent" Off
+OPTIONS_DEFINE= LIBEVENT_STATIC
+LIBEVENT_STATIC_DESC= Build with static libevent
.include <bsd.port.pre.mk>
-.if defined(WITH_LIBEVENT_STATIC)
+.if ${PORT_OPTIONS:MLIBEVENT_STATIC}
BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
MAKE_ARGS+= LIBEVENT=${LOCALBASE}/lib/libevent.a
.else
diff --git a/net/smbldap-tools/Makefile b/net/smbldap-tools/Makefile
index 509c4fa5af2a..2f2aa58dfe37 100644
--- a/net/smbldap-tools/Makefile
+++ b/net/smbldap-tools/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: smbldap-tools
-# Date created: May 8 2004
-# Whom: Florent Thoumie <flz@xbsd.org>
-#
+# Created by: Florent Thoumie <flz@xbsd.org>
# $FreeBSD$
-#
PORTNAME= smbldap-tools
PORTVERSION= 0.9.9
@@ -31,17 +27,18 @@ ALL_TARGET= build
PORTDOCS= *
-OPTIONS= MIGRATION_SCRIPTS "Install migration scripts" off \
- PDF_DOC "Install PDF documentation" off
+OPTIONS_DEFINE= MIGRATION_SCRIPTS PDF_DOC DOCS
+MIGRATION_SCRIPTS_DESC= Install migration scripts
+PDF_DOC_DESC= Install PDF documentation
CONFIGURE_ARGS+= --with-samba-sysconfdir=${LOCALBASE}/etc \
--with-samba-bindir=${LOCALBASE}/bin \
--with-perl=${PERL} \
--with-perl-libdir=sitelib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_MIGRATION_SCRIPTS)
+.if ${PORT_OPTIONS:MMIGRATION_SCRIPTS}
PLIST_SUB+= MIGRATION_SCRIPTS=""
.else
PLIST_SUB+= MIGRATION_SCRIPTS="@comment "
@@ -58,7 +55,7 @@ post-install:
@[ -f ${PREFIX}/etc/smbldap-tools/$i ] || ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/etc/smbldap-tools/$i
.endfor
-.if defined(WITH_MIGRATION_SCRIPTS)
+.if ${PORT_OPTIONS:MMIGRATION_SCRIPTS}
. for i in smbldap-migrate-pwdump-accounts smbldap-migrate-pwdump-groups \
smbldap-migrate-unix-accounts smbldap-migrate-unix-groups
@${SED} -e 's|/usr/bin/perl|${PERL}|g' \
@@ -66,7 +63,7 @@ smbldap-migrate-unix-accounts smbldap-migrate-unix-groups
. endfor
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_SCRIPT} ${WRKSRC}/smbldap-config.cmd ${DOCSDIR}/smbldap-config
${INSTALL_SCRIPT} ${WRKSRC}/smbldap-upgrade-0.9.6.cmd ${DOCSDIR}/smbldap-upgrade-0.9.6
@@ -74,9 +71,9 @@ smbldap-migrate-unix-accounts smbldap-migrate-unix-groups
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}/
.endfor
${INSTALL_DATA} ${WRKSRC}/doc/smbldap-tools.html ${DOCSDIR}/smbldap-tools.html
-.if defined(WITH_PDF_DOC)
+.if ${PORT_OPTIONS:MPDF_DOC}
${INSTALL_DATA} ${WRKSRC}/doc/smbldap-tools.pdf ${DOCSDIR}/smbldap-tools.pdf
.endif
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>