aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2010-08-26 21:12:40 +0800
committerbapt <bapt@FreeBSD.org>2010-08-26 21:12:40 +0800
commit9253410c423cb23509b5a71a665b83bab2f47c38 (patch)
treec530cfe01f264cff5ebe34bea9d0ed97fde91f30 /net
parent82d43aa015d24428611642be38915f527bd56470 (diff)
downloadfreebsd-ports-gnome-9253410c423cb23509b5a71a665b83bab2f47c38.tar.gz
freebsd-ports-gnome-9253410c423cb23509b5a71a665b83bab2f47c38.tar.zst
freebsd-ports-gnome-9253410c423cb23509b5a71a665b83bab2f47c38.zip
Net::Google::Code is a simple client library for projects hosted in
Google Code. WWW: http://search.cpan.org/dist/Net-Google-Code/ PR: ports/149985 Submitted by: Frederic Culot <frederic at culot.org> Approved by: jadawin (co-mentor)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Google-Code/Makefile57
-rw-r--r--net/p5-Net-Google-Code/distinfo3
-rw-r--r--net/p5-Net-Google-Code/pkg-descr4
-rw-r--r--net/p5-Net-Google-Code/pkg-plist29
5 files changed, 94 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 9b70f2a99724..869a24721fa2 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -561,6 +561,7 @@
SUBDIR += p5-Net-Google
SUBDIR += p5-Net-Google-AuthSub
SUBDIR += p5-Net-Google-Calendar
+ SUBDIR += p5-Net-Google-Code
SUBDIR += p5-Net-Google-DataAPI
SUBDIR += p5-Net-Google-Spreadsheets
SUBDIR += p5-Net-Gopher
diff --git a/net/p5-Net-Google-Code/Makefile b/net/p5-Net-Google-Code/Makefile
new file mode 100644
index 000000000000..b99f40e97cb4
--- /dev/null
+++ b/net/p5-Net-Google-Code/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: p5-Net-Google-Code
+# Date created: 2010-08-26
+# Whom: Frederic Culot <frederic@culot.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Google-Code
+PORTVERSION= 0.19
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= frederic@culot.org
+COMMENT= Simple client library for Google code
+
+BUILD_DEPENDS= ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp \
+ ${SITE_PERL}/Test/MockModule.pm:${PORTSDIR}/devel/p5-Test-MockModule \
+ ${SITE_PERL}/Test/Mock/LWP.pm:${PORTSDIR}/devel/p5-Test-Mock-LWP \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/Test/Mock/LWP.pm:${PORTSDIR}/devel/p5-Test-Mock-LWP \
+ ${SITE_PERL}/Test/MockModule.pm:${PORTSDIR}/devel/p5-Test-MockModule \
+ ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp \
+ ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/Any/Moose.pm:${PORTSDIR}/devel/p5-Any-Moose \
+ ${SITE_PERL}/File/MMagic.pm:${PORTSDIR}/devel/p5-File-MMagic \
+ ${SITE_PERL}/HTML/TreeBuilder.pm:${PORTSDIR}/www/p5-HTML-Tree \
+ ${SITE_PERL}/JSON.pm:${PORTSDIR}/converters/p5-JSON \
+ ${SITE_PERL}/MIME/Types.pm:${PORTSDIR}/mail/p5-MIME-Types \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/WWW/Mechanize/Link.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
+ ${SITE_PERL}/XML/FeedPP.pm:${PORTSDIR}/textproc/p5-XML-FeedPP
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Google::Code.3 \
+ Net::Google::Code::AtomParser.3 \
+ Net::Google::Code::DateTime.3 \
+ Net::Google::Code::Download.3 \
+ Net::Google::Code::Issue.3 \
+ Net::Google::Code::Issue::Attachment.3 \
+ Net::Google::Code::Issue::Base.3 \
+ Net::Google::Code::Issue::Comment.3 \
+ Net::Google::Code::Issue::Search.3 \
+ Net::Google::Code::Issue::Util.3 \
+ Net::Google::Code::Role::Authentication.3 \
+ Net::Google::Code::Role::Fetchable.3 \
+ Net::Google::Code::Role::HTMLTree.3 \
+ Net::Google::Code::Role::Pageable.3 \
+ Net::Google::Code::Role::Predefined.3 \
+ Net::Google::Code::Role::URL.3 \
+ Net::Google::Code::TypicalRoles.3 \
+ Net::Google::Code::Wiki.3 \
+ Net::Google::Code::Wiki::Comment.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Google-Code/distinfo b/net/p5-Net-Google-Code/distinfo
new file mode 100644
index 000000000000..2d0dd8c19aae
--- /dev/null
+++ b/net/p5-Net-Google-Code/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Google-Code-0.19.tar.gz) = b0155a7e78229a5208b30201718a0ca6
+SHA256 (Net-Google-Code-0.19.tar.gz) = 78a3e6b184c6aa61e501c3b2e7f4bc1d2988052dda765a1cbd47144b8aa14ca1
+SIZE (Net-Google-Code-0.19.tar.gz) = 73482
diff --git a/net/p5-Net-Google-Code/pkg-descr b/net/p5-Net-Google-Code/pkg-descr
new file mode 100644
index 000000000000..85c40ac44dc8
--- /dev/null
+++ b/net/p5-Net-Google-Code/pkg-descr
@@ -0,0 +1,4 @@
+Net::Google::Code is a simple client library for projects hosted in
+Google Code.
+
+WWW: http://search.cpan.org/dist/Net-Google-Code/
diff --git a/net/p5-Net-Google-Code/pkg-plist b/net/p5-Net-Google-Code/pkg-plist
new file mode 100644
index 000000000000..ead63fad5e89
--- /dev/null
+++ b/net/p5-Net-Google-Code/pkg-plist
@@ -0,0 +1,29 @@
+%%SITE_PERL%%/Net/Google/Code.pm
+%%SITE_PERL%%/Net/Google/Code/AtomParser.pm
+%%SITE_PERL%%/Net/Google/Code/DateTime.pm
+%%SITE_PERL%%/Net/Google/Code/Download.pm
+%%SITE_PERL%%/Net/Google/Code/Issue.pm
+%%SITE_PERL%%/Net/Google/Code/Issue/Attachment.pm
+%%SITE_PERL%%/Net/Google/Code/Issue/Base.pm
+%%SITE_PERL%%/Net/Google/Code/Issue/Comment.pm
+%%SITE_PERL%%/Net/Google/Code/Issue/Search.pm
+%%SITE_PERL%%/Net/Google/Code/Issue/Util.pm
+%%SITE_PERL%%/Net/Google/Code/Role/Authentication.pm
+%%SITE_PERL%%/Net/Google/Code/Role/Fetchable.pm
+%%SITE_PERL%%/Net/Google/Code/Role/HTMLTree.pm
+%%SITE_PERL%%/Net/Google/Code/Role/Pageable.pm
+%%SITE_PERL%%/Net/Google/Code/Role/Predefined.pm
+%%SITE_PERL%%/Net/Google/Code/Role/URL.pm
+%%SITE_PERL%%/Net/Google/Code/TypicalRoles.pm
+%%SITE_PERL%%/Net/Google/Code/Wiki.pm
+%%SITE_PERL%%/Net/Google/Code/Wiki/Comment.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google/Code/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google/Code
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Google
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Google/Code/Issue
+@dirrmtry %%SITE_PERL%%/Net/Google/Code/Role
+@dirrmtry %%SITE_PERL%%/Net/Google/Code/Wiki
+@dirrmtry %%SITE_PERL%%/Net/Google/Code
+@dirrmtry %%SITE_PERL%%/Net/Google
+@dirrmtry %%SITE_PERL%%/Net