aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorler <ler@FreeBSD.org>2018-01-15 02:29:19 +0800
committerler <ler@FreeBSD.org>2018-01-15 02:29:19 +0800
commit925955ff63226452265984a316ed4713f7987b1e (patch)
treedd10421819ae32e8a546d1518d8332dc405b7b4d /net
parentd61437851dbd1fdb4edebbaa6ce92cfc66182b58 (diff)
downloadfreebsd-ports-gnome-925955ff63226452265984a316ed4713f7987b1e.tar.gz
freebsd-ports-gnome-925955ff63226452265984a316ed4713f7987b1e.tar.zst
freebsd-ports-gnome-925955ff63226452265984a316ed4713f7987b1e.zip
net/boinc-client: upgrade to 7.8.6
- move to GitHub - pet portlint
Diffstat (limited to 'net')
-rw-r--r--net/boinc-client/Makefile21
-rw-r--r--net/boinc-client/distinfo5
-rw-r--r--net/boinc-client/files/boinc-client.in7
-rw-r--r--net/boinc-client/files/patch-api__boinc_api.cpp11
-rw-r--r--net/boinc-client/files/patch-client__client_msgs.h10
-rw-r--r--net/boinc-client/files/patch-client_hostinfo__unix.cpp13
-rw-r--r--net/boinc-client/files/patch-clientgui__AsyncRPC.cpp12
-rw-r--r--net/boinc-client/files/patch-lib__diagnostics.cpp10
-rw-r--r--net/boinc-client/files/patch-lib__gui_rpc_client_print.cpp10
-rw-r--r--net/boinc-client/files/patch-lib__str_util.cpp10
-rw-r--r--net/boinc-client/pkg-plist11
11 files changed, 37 insertions, 83 deletions
diff --git a/net/boinc-client/Makefile b/net/boinc-client/Makefile
index 7f0ad40f7fc0..e3b5212f6161 100644
--- a/net/boinc-client/Makefile
+++ b/net/boinc-client/Makefile
@@ -2,19 +2,28 @@
# $FreeBSD$
PORTNAME= boinc-client
-PORTVERSION= 7.2.33
-PORTREVISION= 8
+PORTVERSION= 7.8.6
CATEGORIES= net
-MASTER_SITES= LOCAL/rene
MAINTAINER= ler@FreeBSD.org
COMMENT= Berkeley Open Infrastructure for Network Computing client
-GNU_CONFIGURE= yes
+LICENSE= LGPL3
+
+LIB_DEPENDS+= libfreetype.so:print/freetype2
+
+USES= autoreconf dos2unix gettext gmake libtool pkgconfig ssl tar:xz
+USE_XORG+= x11 xscrnsaver
INSTALL_TARGET= install-strip
-USES= autoreconf dos2unix gmake libtool pkgconfig tar:xz
+GNU_CONFIGURE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= BOINC
+GH_PROJECT= boinc
+GH_TAGNAME= client_release/7.8/${PORTVERSION}
USE_LDCONFIG= yes
DOS2UNIX_GLOB= *.xpm
+NO_WRKSUBDIR= yes
+WRKSRC_SUBDIR= boinc-client_release-7.8-${PORTVERSION}
USERS= boinc
GROUPS= boinc
@@ -32,7 +41,7 @@ SUB_LIST= BOINC_CLIENT_HOME="${BOINC_CLIENT_HOME}" \
CONFIGURE_ARGS= --disable-server
CONFIGURE_ENV= OBJCXX="${CXX}"
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
OPTIONS_DEFINE= CLIENT MANAGER NLS X11 LINUX USER SKINS
OPTIONS_DEFAULT= CLIENT MANAGER X11 USER
diff --git a/net/boinc-client/distinfo b/net/boinc-client/distinfo
index 6081c4ce536e..4c7f02b952c7 100644
--- a/net/boinc-client/distinfo
+++ b/net/boinc-client/distinfo
@@ -1,2 +1,3 @@
-SHA256 (boinc-client-7.2.33.tar.xz) = 5829e82fc065adc08839af362bee4988a0867858e10f0d5bd8c39668f27a8298
-SIZE (boinc-client-7.2.33.tar.xz) = 21782836
+TIMESTAMP = 1515941947
+SHA256 (BOINC-boinc-7.8.6-client_release-7.8/7.8.6_GH0.tar.gz) = ed5f3dcdc8d1cc5277529afb701377e77d1ff89711368a7456553bf249940bad
+SIZE (BOINC-boinc-7.8.6-client_release-7.8/7.8.6_GH0.tar.gz) = 52037690
diff --git a/net/boinc-client/files/boinc-client.in b/net/boinc-client/files/boinc-client.in
index 2d2d3235f2b3..68d57fcec039 100644
--- a/net/boinc-client/files/boinc-client.in
+++ b/net/boinc-client/files/boinc-client.in
@@ -24,7 +24,7 @@ command="%%PREFIX%%/bin/boinc_client"
pidfile="/var/run/${name}.pid"
boinc_client_user=%%BOINC_CLIENT_USER%%
-command_args="--daemon %%OPTION_NO_GUI_RPC%% %%OPTION_NO_NET_INFO%% --dir \"%%BOINC_CLIENT_HOME%%\""
+command_args="--redirectio %%OPTION_NO_GUI_RPC%% %%OPTION_NO_NET_INFO%% --dir %%BOINC_CLIENT_HOME%%"
start_cmd=boinc_client_start
stop_postcmd=boinc_client_poststop
@@ -39,10 +39,7 @@ boinc_client_start()
return 1
fi
echo "Starting ${name}."
- idprio 31 su - ${boinc_client_user} -c \
- "\"${command}\" ${boinc_client_flags} ${command_args}" || return 1
- pgrep -U ${boinc_client_user} -n -t - '^boinc_client$' \
- > "${pidfile}" || return 1
+ idprio 31 daemon -u ${boinc_client_user} -p ${pidfile} -f ${command} ${boinc_client_flags} ${command_args} || return 1
}
boinc_client_poststop()
diff --git a/net/boinc-client/files/patch-api__boinc_api.cpp b/net/boinc-client/files/patch-api__boinc_api.cpp
deleted file mode 100644
index 932e18d3ecd4..000000000000
--- a/net/boinc-client/files/patch-api__boinc_api.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./api/boinc_api.cpp.orig 2013-07-24 15:13:28.000000000 +0000
-+++ ./api/boinc_api.cpp 2013-09-17 21:16:00.000000000 +0000
-@@ -120,7 +120,7 @@
- // CPPFLAGS=-DGETRUSAGE_IN_TIMER_THREAD
- #endif
-
--const char* api_version="API_VERSION_"PACKAGE_VERSION;
-+const char* api_version="API_VERSION_" PACKAGE_VERSION;
- static APP_INIT_DATA aid;
- static FILE_LOCK file_lock;
- APP_CLIENT_SHM* app_client_shm = 0;
diff --git a/net/boinc-client/files/patch-client__client_msgs.h b/net/boinc-client/files/patch-client__client_msgs.h
deleted file mode 100644
index c8688ce8edd4..000000000000
--- a/net/boinc-client/files/patch-client__client_msgs.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./client/client_msgs.h.orig 2013-07-24 15:13:28.000000000 +0000
-+++ ./client/client_msgs.h 2013-09-17 21:16:00.000000000 +0000
-@@ -73,6 +73,6 @@
- __attribute__ ((format (printf, 4, 5)))
- ;
-
--#define _(x) "_(\""x"\")"
-+#define _(x) "_(\"" x"\")"
-
- #endif
diff --git a/net/boinc-client/files/patch-client_hostinfo__unix.cpp b/net/boinc-client/files/patch-client_hostinfo__unix.cpp
new file mode 100644
index 000000000000..f1240ed92867
--- /dev/null
+++ b/net/boinc-client/files/patch-client_hostinfo__unix.cpp
@@ -0,0 +1,13 @@
+--- client/hostinfo_unix.cpp.orig 2018-01-14 16:39:30 UTC
++++ client/hostinfo_unix.cpp
+@@ -164,7 +164,9 @@ extern "C" {
+ // The following is intended to be true both on Linux
+ // and Debian GNU/kFreeBSD (see trac #521)
+ //
+-#define LINUX_LIKE_SYSTEM (defined(__linux__) || defined(__GNU__) || defined(__GLIBC__)) && !defined(__HAIKU__)
++#if (defined(__linux__) || defined(__GNU__) || defined(__GLIBC__) || defined (__freebsd__)) && !defined(__HAIKU__)
++#define LINUX_LIKE_SYSTEM 1
++#endif
+
+ // Returns the offset between LOCAL STANDARD TIME and UTC.
+ // LOCAL_STANDARD_TIME = UTC_TIME + get_timezone().
diff --git a/net/boinc-client/files/patch-clientgui__AsyncRPC.cpp b/net/boinc-client/files/patch-clientgui__AsyncRPC.cpp
deleted file mode 100644
index 1cd56a62554a..000000000000
--- a/net/boinc-client/files/patch-clientgui__AsyncRPC.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- clientgui/AsyncRPC.cpp.orig 2012-04-07 11:55:37.000000000 +0300
-+++ clientgui/AsyncRPC.cpp 2012-04-07 11:56:14.000000000 +0300
-@@ -31,7 +31,9 @@
- #include "util.h"
-
- #if !(defined(_WIN32) || (defined(__WXMAC__) && (MAC_OS_X_VERSION_MIN_REQUIRED < MAC_OS_X_VERSION_10_4)))
-+#if !defined(NO_PER_THREAD_LOCALE)
- #include <xlocale.h>
-+#endif
- #include "gui_rpc_client.h"
- #endif
-
diff --git a/net/boinc-client/files/patch-lib__diagnostics.cpp b/net/boinc-client/files/patch-lib__diagnostics.cpp
deleted file mode 100644
index 9849b6149868..000000000000
--- a/net/boinc-client/files/patch-lib__diagnostics.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./lib/diagnostics.cpp.orig 2013-07-24 15:13:29.000000000 +0000
-+++ ./lib/diagnostics.cpp 2013-09-17 21:40:56.000000000 +0000
-@@ -41,6 +41,7 @@
- #include <cstdarg>
- #include <cstdlib>
- #include <unistd.h>
-+#include <time.h>
- #endif
-
- #ifdef _USING_FCGI_
diff --git a/net/boinc-client/files/patch-lib__gui_rpc_client_print.cpp b/net/boinc-client/files/patch-lib__gui_rpc_client_print.cpp
deleted file mode 100644
index 2a86ae0681be..000000000000
--- a/net/boinc-client/files/patch-lib__gui_rpc_client_print.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./lib/gui_rpc_client_print.cpp.orig 2013-07-24 15:13:29.000000000 +0000
-+++ ./lib/gui_rpc_client_print.cpp 2013-09-17 21:43:21.000000000 +0000
-@@ -31,6 +31,7 @@
- #include <sys/un.h>
- #include <cstdio>
- #include <unistd.h>
-+#include <time.h>
- #include <cstdlib>
- #include <cstring>
- #endif
diff --git a/net/boinc-client/files/patch-lib__str_util.cpp b/net/boinc-client/files/patch-lib__str_util.cpp
deleted file mode 100644
index eabec39d4d16..000000000000
--- a/net/boinc-client/files/patch-lib__str_util.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./lib/str_util.cpp.orig 2013-07-24 15:13:29.000000000 +0000
-+++ ./lib/str_util.cpp 2013-09-17 21:45:40.000000000 +0000
-@@ -29,6 +29,7 @@
- #include <string>
- #include <math.h>
- #include <string.h>
-+#include <time.h>
- #include <stdlib.h>
- #include <ctype.h>
- #endif
diff --git a/net/boinc-client/pkg-plist b/net/boinc-client/pkg-plist
index e3fe3d830435..f5473104e2d5 100644
--- a/net/boinc-client/pkg-plist
+++ b/net/boinc-client/pkg-plist
@@ -10,7 +10,6 @@ include/boinc/base64.h
include/boinc/boinc_api.h
include/boinc/boinc_fcgi.h
include/boinc/boinc_opencl.h
-include/boinc/boinc_win.h
include/boinc/cal_boinc.h
include/boinc/cc_config.h
include/boinc/cert_sig.h
@@ -20,7 +19,6 @@ include/boinc/config.h
include/boinc/coproc.h
include/boinc/crypt.h
include/boinc/diagnostics.h
-include/boinc/diagnostics_win.h
include/boinc/error_numbers.h
include/boinc/filesys.h
include/boinc/graphics2.h
@@ -42,16 +40,15 @@ include/boinc/procinfo.h
include/boinc/project_specific_defines.h
include/boinc/proxy_info.h
include/boinc/reduce.h
+include/boinc/sched_msgs.h
include/boinc/shmem.h
include/boinc/stackwalker_imports.h
-include/boinc/stackwalker_win.h
include/boinc/std_fixes.h
include/boinc/str_util.h
include/boinc/svn_version.h
include/boinc/url.h
include/boinc/util.h
include/boinc/version.h
-include/boinc/win_util.h
%%X11%%include/boinc/boinc_gl.h
%%X11%%include/boinc/graphics_api.h
%%X11%%include/boinc/graphics_data.h
@@ -60,16 +57,16 @@ lib/libboinc.a
lib/libboinc_api.a
lib/libboinc_api.so
lib/libboinc_api.so.7
-lib/libboinc_api.so.7.2.33
+lib/libboinc_api.so.7.8.6
lib/libboinc_crypt.a
lib/libboinc_opencl.a
lib/libboinc_opencl.so
lib/libboinc_opencl.so.7
-lib/libboinc_opencl.so.7.2.33
+lib/libboinc_opencl.so.7.8.6
%%X11%%lib/libboinc_graphics2.a
%%X11%%lib/libboinc_graphics2.so
%%X11%%lib/libboinc_graphics2.so.7
-%%X11%%lib/libboinc_graphics2.so.7.2.33
+%%X11%%lib/libboinc_graphics2.so.7.8.6
%%SKINS%%share/boinc/skins/Charity Engine/background_image.png
%%SKINS%%share/boinc/skins/Charity Engine/ce_about.ico
%%SKINS%%share/boinc/skins/Charity Engine/ce_icon_play.png