aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormatusita <matusita@FreeBSD.org>2003-04-19 13:21:57 +0800
committermatusita <matusita@FreeBSD.org>2003-04-19 13:21:57 +0800
commit928e5f320350f499eb1488d4776ddffc6f4db014 (patch)
treec303eb8ee64046c73202f54a6de91803f0239898 /net
parente9cf8f8d748a76a30256e03c10d1e2801de30362 (diff)
downloadfreebsd-ports-gnome-928e5f320350f499eb1488d4776ddffc6f4db014.tar.gz
freebsd-ports-gnome-928e5f320350f499eb1488d4776ddffc6f4db014.tar.zst
freebsd-ports-gnome-928e5f320350f499eb1488d4776ddffc6f4db014.zip
Add a patch to fix a problem with *.org lookup redirection.
Bump PORTREVISION. Submitted by: Phil Pennock <pdp@nl.demon.net> Obtained from: jwhois vendor CVS repository
Diffstat (limited to 'net')
-rw-r--r--net/jwhois/Makefile2
-rw-r--r--net/jwhois/files/patch-ae20
2 files changed, 21 insertions, 1 deletions
diff --git a/net/jwhois/Makefile b/net/jwhois/Makefile
index d860a5060c8c..11901ae78d67 100644
--- a/net/jwhois/Makefile
+++ b/net/jwhois/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jwhois
PORTVERSION= 3.2.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= jwhois
diff --git a/net/jwhois/files/patch-ae b/net/jwhois/files/patch-ae
new file mode 100644
index 000000000000..8c6452e27103
--- /dev/null
+++ b/net/jwhois/files/patch-ae
@@ -0,0 +1,20 @@
+--- src/lookup.c 2002/08/02 22:17:41 1.33
++++ src/lookup.c 2003/02/04 21:21:16 1.34
+@@ -391,7 +391,7 @@
+ {
+ memcpy(bptr, text, strlen(text)+1);
+
+- strptr = (char *)strtok(bptr, "\n");
++ strptr = (char *)strtok(bptr, "\r\n");
+ while (strptr)
+ {
+ rpb.allocated = 0;
+@@ -443,7 +443,7 @@
+ }
+ else if (ind == -2)
+ return -1;
+- strptr = (char *)strtok(NULL, "\n");
++ strptr = (char *)strtok(NULL, "\r\n");
+ }
+ }
+ }