aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormmokhi <mmokhi@FreeBSD.org>2017-05-05 19:47:46 +0800
committermmokhi <mmokhi@FreeBSD.org>2017-05-05 19:47:46 +0800
commit9d267e6f9b60c69ad36c048ae2f013b45b137728 (patch)
tree7fdf26307231bbde05d43a436102c1b0e41c451b /net
parent54733a652d16973ac62cc7b47df2047e8070356b (diff)
downloadfreebsd-ports-gnome-9d267e6f9b60c69ad36c048ae2f013b45b137728.tar.gz
freebsd-ports-gnome-9d267e6f9b60c69ad36c048ae2f013b45b137728.tar.zst
freebsd-ports-gnome-9d267e6f9b60c69ad36c048ae2f013b45b137728.zip
net/ceph-devel: Add a patch to fix a linker-error happens on 110amd64
Reported by: Willem Jan Withagen <wjw@digiware.nl> (maintainer) Reviewed by: mat (mentor) Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D10608
Diffstat (limited to 'net')
-rw-r--r--net/ceph-devel/files/patch-src_test_rgw_CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/net/ceph-devel/files/patch-src_test_rgw_CMakeLists.txt b/net/ceph-devel/files/patch-src_test_rgw_CMakeLists.txt
new file mode 100644
index 000000000000..e08082e2d945
--- /dev/null
+++ b/net/ceph-devel/files/patch-src_test_rgw_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- src/test/rgw/CMakeLists.txt
++++ src/test/rgw/CMakeLists.txt
+@@ -99,9 +99,8 @@ target_link_libraries(unittest_rgw_crypto
+ cls_user_client
+ librados
+ global
+- curl
+- uuid
+- expat
++ ${CURL_LIBRARIES}
++ ${EXPAT_LIBRARIES}
+ ${CMAKE_DL_LIBS}
+ ${UNITTEST_LIBS}
+ ${CRYPTO_LIBS}
+