aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authornemysis <nemysis@FreeBSD.org>2013-10-30 02:10:58 +0800
committernemysis <nemysis@FreeBSD.org>2013-10-30 02:10:58 +0800
commita0820bbd697198060f05dfd5ff388c8426b42969 (patch)
tree4d0e97f2aecfe0025e3c51034f790ca8a8d93014 /net
parent414cf3d5363af042afbf1f92611af95cd93e6867 (diff)
downloadfreebsd-ports-gnome-a0820bbd697198060f05dfd5ff388c8426b42969.tar.gz
freebsd-ports-gnome-a0820bbd697198060f05dfd5ff388c8426b42969.tar.zst
freebsd-ports-gnome-a0820bbd697198060f05dfd5ff388c8426b42969.zip
gspreadsheet is a wrapper around a wrapper to get Google spreadsheets to look
like csv.DictReader. If you're used to working with CSVs or a human, you'll find that working with Google's Python API for spreadsheets is so frustrating. With gspreadsheet, you can adapt your existing csv code to work with Google Spreadsheets with just two line changes. As an added bonus, if you alter the dict, those changes get saved back to the original spreadsheet. WWW: https://github.com/texastribune/gspreadsheet PR: ports/181832 Submitted by: Johannes Jost Meixner <xmj@chaot.net> Approved by: wg (mentor)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-gspreadsheet/Makefile28
-rw-r--r--net/py-gspreadsheet/distinfo2
-rw-r--r--net/py-gspreadsheet/files/patch-setup.py8
-rw-r--r--net/py-gspreadsheet/pkg-descr8
5 files changed, 47 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6f929ceaa17d..71c043059966 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -904,6 +904,7 @@
SUBDIR += py-eventlet
SUBDIR += py-gntp
SUBDIR += py-google
+ SUBDIR += py-gspreadsheet
SUBDIR += py-impacket
SUBDIR += py-iplib
SUBDIR += py-kombu
diff --git a/net/py-gspreadsheet/Makefile b/net/py-gspreadsheet/Makefile
new file mode 100644
index 000000000000..e5630cbe7449
--- /dev/null
+++ b/net/py-gspreadsheet/Makefile
@@ -0,0 +1,28 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= gspreadsheet
+PORTVERSION= 0.3.0
+CATEGORIES= net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= xmj@chaot.net
+COMMENT= Wrapper around Google Spreadsheets to look like csv.DictReader
+
+LICENSE= AL2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gdata>0:${PORTSDIR}/devel/py-gdata
+USE_PYTHON= 2.7
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+PORTDOCS= README.rst
+
+OPTIONS_DEFINE= DOCS
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/net/py-gspreadsheet/distinfo b/net/py-gspreadsheet/distinfo
new file mode 100644
index 000000000000..de593a142e83
--- /dev/null
+++ b/net/py-gspreadsheet/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gspreadsheet-0.3.0.tar.gz) = 102e4714f5e9f21a1a0118aeaef6772d77013ca03f1028326e9b00fa13143460
+SIZE (gspreadsheet-0.3.0.tar.gz) = 7342
diff --git a/net/py-gspreadsheet/files/patch-setup.py b/net/py-gspreadsheet/files/patch-setup.py
new file mode 100644
index 000000000000..3c49bf70a987
--- /dev/null
+++ b/net/py-gspreadsheet/files/patch-setup.py
@@ -0,0 +1,8 @@
+--- ./setup.py.orig 2013-10-29 16:50:19.871040385 +0200
++++ ./setup.py 2013-10-29 16:51:00.781040301 +0200
+@@ -1,4 +1,4 @@
+-from setuptools import setup
++from distutils.core import setup
+
+ with open('README.rst') as f:
+ long_description = f.read()
diff --git a/net/py-gspreadsheet/pkg-descr b/net/py-gspreadsheet/pkg-descr
new file mode 100644
index 000000000000..0c1e89ea4b5d
--- /dev/null
+++ b/net/py-gspreadsheet/pkg-descr
@@ -0,0 +1,8 @@
+gspreadsheet is a wrapper around a wrapper to get Google spreadsheets to look
+like csv.DictReader. If you're used to working with CSVs or a human, you'll
+find that working with Google's Python API for spreadsheets is so frustrating.
+With gspreadsheet, you can adapt your existing csv code to work with Google
+Spreadsheets with just two line changes. As an added bonus, if you alter the
+dict, those changes get saved back to the original spreadsheet.
+
+WWW: https://github.com/texastribune/gspreadsheet