aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2010-05-22 13:23:54 +0800
committermarcus <marcus@FreeBSD.org>2010-05-22 13:23:54 +0800
commita49085abe6e5489253364ba0c0c24887040872d7 (patch)
tree7d6911b8ac220f95603c57d17bd035dd089fbe07 /net
parent765e4ee643b119f48f9a9d8ed3873a1d6479f003 (diff)
downloadfreebsd-ports-gnome-a49085abe6e5489253364ba0c0c24887040872d7.tar.gz
freebsd-ports-gnome-a49085abe6e5489253364ba0c0c24887040872d7.tar.zst
freebsd-ports-gnome-a49085abe6e5489253364ba0c0c24887040872d7.zip
Add optional C-ARES async DNS support.
PR: 145787 Submitted by: Anonymous <swell.k@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/wireshark/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 596268fb11dc..d7c81999ae1f 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -70,7 +70,8 @@ OPTIONS= RTP "Enable support for playing back RTP streams" off \
PCRE "Enable regular expression matching support" on \
IPV6 "Enable IPv6 support" on \
GEOIP "Enable GeoIP lookups" on \
- LUA "Enable LUA scripting integration" off
+ LUA "Enable LUA scripting integration" off \
+ CARES "Asynchronous DNS resolution via c-ares" off
.endif
.include <bsd.port.pre.mk>
@@ -140,6 +141,13 @@ CONFIGURE_ARGS+= --with-adns=${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-adns=no
.endif
+.if !defined(WITHOUT_CARES) && !defined(LITE)
+LIB_DEPENDS+= cares.2:${PORTSDIR}/dns/c-ares
+CONFIGURE_ARGS+= --with-c-ares=${LOCALBASE}/lib
+.else
+CONFIGURE_ARGS+= --with-c-ares=no
+.endif
+
.if !defined(WITHOUT_GEOIP) && !defined(LITE)
LIB_DEPENDS+= GeoIP.5:${PORTSDIR}/net/GeoIP
CONFIGURE_ARGS+= --with-geoip=${LOCALBASE}/lib