aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2010-08-21 05:13:38 +0800
committerrene <rene@FreeBSD.org>2010-08-21 05:13:38 +0800
commita4a19f17513dedb394787e9365d89d3952019905 (patch)
tree8bb0206e0a3a62eff0d015fc3ab414f90552b5e9 /net
parent2e3c5481a666deb0d980ba52bfebe6305c1bca7a (diff)
downloadfreebsd-ports-gnome-a4a19f17513dedb394787e9365d89d3952019905.tar.gz
freebsd-ports-gnome-a4a19f17513dedb394787e9365d89d3952019905.tar.zst
freebsd-ports-gnome-a4a19f17513dedb394787e9365d89d3952019905.zip
- make multi-job safe
- fix filename of manual page (should be mDNSResponderPosix(8)) PR: ports/149430 Submitted by: Ivan Klymenko [fidaj ukr.net], actual patch from arved Approved by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/mDNSResponder/files/patch-mDNSPosix_Makefile26
1 files changed, 24 insertions, 2 deletions
diff --git a/net/mDNSResponder/files/patch-mDNSPosix_Makefile b/net/mDNSResponder/files/patch-mDNSPosix_Makefile
index f37c7deac4f9..21b96a3b7650 100644
--- a/net/mDNSResponder/files/patch-mDNSPosix_Makefile
+++ b/net/mDNSResponder/files/patch-mDNSPosix_Makefile
@@ -1,5 +1,5 @@
---- mDNSPosix/Makefile.orig 2009-02-03 04:44:06.000000000 +0900
-+++ mDNSPosix/Makefile 2009-12-24 18:01:14.000000000 +0900
+--- mDNSPosix/Makefile.orig 2009-02-03 03:44:06.000000000 +0800
++++ mDNSPosix/Makefile 2010-08-17 23:23:31.000000000 +0800
@@ -380,7 +380,7 @@
LOCALBASE?=/usr/local
INSTBASE=$(LOCALBASE)
@@ -18,3 +18,25 @@
# 'setup' sets up the build directory structure the way we want
setup:
+@@ -514,10 +514,10 @@
+ @$(LD) $(LINKOPTS) -o $@ $+
+ @$(STRIP) $@
+
+-Clients: setup libdns_sd ../Clients/build/dns-sd
++Clients: ../Clients/build/dns-sd
+ @echo "Clients done"
+
+-../Clients/build/dns-sd:
++../Clients/build/dns-sd: setup libdns_sd
+ @$(MAKE) -C ../Clients
+
+ # nss_mdns target builds the Name Service Switch module
+@@ -592,7 +592,7 @@
+ cp $< $@
+ chmod 444 $@
+
+-$(MANPATH)/man8/mdnsd.8: $(SHAREDDIR)/mDNSResponder.8
++$(MANPATH)/man8/mdnsd.8: $(SHAREDDIR)/mDNSResponderPosix.8
+ cp $< $@
+ chmod 444 $@
+