aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-05-25 16:32:10 +0800
committerjylefort <jylefort@FreeBSD.org>2005-05-25 16:32:10 +0800
commita628e5b8d299f06cc87b34510faa2ae5f8a28b2f (patch)
tree787bd5323908c43e5f11b9173e3680daaa14a2b9 /net
parent10e7291f15e6ac9f6affac9c4d7e9a52b987ef91 (diff)
downloadfreebsd-ports-gnome-a628e5b8d299f06cc87b34510faa2ae5f8a28b2f.tar.gz
freebsd-ports-gnome-a628e5b8d299f06cc87b34510faa2ae5f8a28b2f.tar.zst
freebsd-ports-gnome-a628e5b8d299f06cc87b34510faa2ae5f8a28b2f.zip
Add p5-Net-OpenDHT.
The Net::OpenDHT module provides a simple interface to the Open DHT service. Open DHT is a publicly accessible distributed hash table (DHT) service. In contrast to the usual DHT model, clients of Open DHT do not need to run a DHT node in order to use the service. Instead, they can issue put and get operations to any DHT node, which processes the operations on their behalf. No credentials or accounts are required to use the service, and the available storage is fairly shared across all active clients. This service model of DHT usage greatly simplifies deploying client applications. By using Open DHT as a highly-available naming and storage service, clients can ignore the complexities of deploying and maintaining a DHT and instead concentrate on developing more sophisticated distributed applications. WWW: http://opendht.org/users-guide.html WWW: http://search.cpan.org/dist/Net-OpenDHT/ Author: Leon Brocard <acme@astray.com> PR: ports/81366 Submitted by: Aaron Dalton <aaron@daltons.ca>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-OpenDHT/Makefile34
-rw-r--r--net/p5-Net-OpenDHT/distinfo2
-rw-r--r--net/p5-Net-OpenDHT/pkg-descr22
-rw-r--r--net/p5-Net-OpenDHT/pkg-plist6
5 files changed, 65 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a48c3cd0f732..8c905dddc888 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -504,6 +504,7 @@
SUBDIR += p5-Net-MSN
SUBDIR += p5-Net-MovableType
SUBDIR += p5-Net-OSCAR
+ SUBDIR += p5-Net-OpenDHT
SUBDIR += p5-Net-Packet
SUBDIR += p5-Net-ParseWhois
SUBDIR += p5-Net-Patricia
diff --git a/net/p5-Net-OpenDHT/Makefile b/net/p5-Net-OpenDHT/Makefile
new file mode 100644
index 000000000000..e7b1ca21a8ec
--- /dev/null
+++ b/net/p5-Net-OpenDHT/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Net-OpenDHT
+# Date created: 21 May 2005
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-OpenDHT
+PORTVERSION= 0.29
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Access the Open Distributed Hash Table (Open DHT)
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor/Chained/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor-Chained \
+ ${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::OpenDHT.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Perl 5.6 or greater required. Please install lang/perl5 or lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-OpenDHT/distinfo b/net/p5-Net-OpenDHT/distinfo
new file mode 100644
index 000000000000..d615799f6c49
--- /dev/null
+++ b/net/p5-Net-OpenDHT/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-OpenDHT-0.29.tar.gz) = 248d5718ba7545d002450cc9fcb984e8
+SIZE (Net-OpenDHT-0.29.tar.gz) = 3949
diff --git a/net/p5-Net-OpenDHT/pkg-descr b/net/p5-Net-OpenDHT/pkg-descr
new file mode 100644
index 000000000000..60d77512acb1
--- /dev/null
+++ b/net/p5-Net-OpenDHT/pkg-descr
@@ -0,0 +1,22 @@
+The Net::OpenDHT module provides a simple interface to the Open DHT
+service. Open DHT is a publicly accessible distributed hash table (DHT)
+service. In contrast to the usual DHT model, clients of Open DHT do not
+need to run a DHT node in order to use the service. Instead, they can
+issue put and get operations to any DHT node, which processes the
+operations on their behalf. No credentials or accounts are required to use
+the service, and the available storage is fairly shared across all active
+clients.
+
+This service model of DHT usage greatly simplifies deploying client
+applications. By using Open DHT as a highly-available naming and storage
+service, clients can ignore the complexities of deploying and maintaining
+a DHT and instead concentrate on developing more sophisticated distributed
+applications.
+
+WWW: http://opendht.org/users-guide.html
+WWW: http://search.cpan.org/dist/Net-OpenDHT/
+
+Author: Leon Brocard <acme@astray.com>
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/net/p5-Net-OpenDHT/pkg-plist b/net/p5-Net-OpenDHT/pkg-plist
new file mode 100644
index 000000000000..366f912754a7
--- /dev/null
+++ b/net/p5-Net-OpenDHT/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Net/OpenDHT.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenDHT/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenDHT
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true
+