aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-10-10 16:03:42 +0800
committeritetcu <itetcu@FreeBSD.org>2006-10-10 16:03:42 +0800
commita6e8589ead7e1b01ee74e768729ba6e40132f7eb (patch)
tree295b10045c859e565186f473940ce364c43c3021 /net
parent31be7079a908553d5622dfdaf05121aed21cdead (diff)
downloadfreebsd-ports-gnome-a6e8589ead7e1b01ee74e768729ba6e40132f7eb.tar.gz
freebsd-ports-gnome-a6e8589ead7e1b01ee74e768729ba6e40132f7eb.tar.zst
freebsd-ports-gnome-a6e8589ead7e1b01ee74e768729ba6e40132f7eb.zip
- Update to 1.11
- doesn't build on 4.x PR: ports/101665 Submitted by: maintainer (Yonatan)
Diffstat (limited to 'net')
-rw-r--r--net/libdnet/Makefile20
-rw-r--r--net/libdnet/distinfo6
-rw-r--r--net/libdnet/pkg-plist6
3 files changed, 23 insertions, 9 deletions
diff --git a/net/libdnet/Makefile b/net/libdnet/Makefile
index efb71802c705..927e8dfbe856 100644
--- a/net/libdnet/Makefile
+++ b/net/libdnet/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libdnet
-PORTVERSION= 1.10
-PORTREVISION= 1
+PORTVERSION= 1.11
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -32,13 +31,19 @@ PLIST_FILES= %%PYTHON_SITELIBDIR%%/dnet.so
PLIST_SUB+= MASTER="@comment "
.else
CONFIGURE_ARGS+= --without-python
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
PLIST_SUB+= MASTER=""
MAN3= dnet.3
MAN8= dnet.8
.endif
+.include <bsd.port.pre.mk>
+.if ${OSVERSION}" < 500000
+IGNORE= doesn't build on FreeBSD 4.x
+.endif
+
+
pre-everything::
.if !defined(BUILD_PYTHON_MODULE)
@${ECHO_MSG} "===>"
@@ -47,9 +52,16 @@ pre-everything::
@sleep 2
.endif
+post-build:
+ @cd ${WRKSRC}/src ; ${CC} ${CFLAGS} -shared -o libdnet.so .libs/addr-util.o .libs/addr.o .libs/blob.o .libs/ip-util.o .libs/ip6.o .libs/rand.o .libs/arp-bsd.o .libs/eth-bsd.o .libs/fw-pf.o .libs/intf.o .libs/ip.o .libs/route-bsd.o .libs/tun-bsd.o
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}.so ${PREFIX}/lib/
+ @${LN} ${PREFIX}/lib/${PORTNAME}.so ${PREFIX}/lib/${PORTNAME}.so.1
+
.if defined(BUILD_PYTHON_MODULE) && defined(MAINTAINER_MODE)
test: install
${PYTHON_CMD} ${INSTALL_WRKSRC}/test.py
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/libdnet/distinfo b/net/libdnet/distinfo
index e8d0cfb0e3ea..2edda384c8ee 100644
--- a/net/libdnet/distinfo
+++ b/net/libdnet/distinfo
@@ -1,3 +1,3 @@
-MD5 (libdnet-1.10.tar.gz) = 416b765e9d9961501ac85e9a366fd219
-SHA256 (libdnet-1.10.tar.gz) = c6e2329df7556cc5004113b65d2d68740e87bbd15c5b2ef6c3fb7cde191cfe67
-SIZE (libdnet-1.10.tar.gz) = 419752
+MD5 (libdnet-1.11.tar.gz) = 04c394ed8e1e7fc455456e79e908916d
+SHA256 (libdnet-1.11.tar.gz) = 0eb78415c8f2564c2f1e8ad36e98473348d9c94852f796a226360c716cc7ca53
+SIZE (libdnet-1.11.tar.gz) = 446233
diff --git a/net/libdnet/pkg-plist b/net/libdnet/pkg-plist
index 9a808d80fad2..a111ab699324 100644
--- a/net/libdnet/pkg-plist
+++ b/net/libdnet/pkg-plist
@@ -1,9 +1,12 @@
-%%MASTER%%bin/dnet-config
%%MASTER%%sbin/dnet
+%%MASTER%%bin/dnet-config
+%%MASTER%%lib/libdnet
+%%MASTER%%lib/libdnet.1
%%MASTER%%lib/libdnet.a
%%MASTER%%lib/libdnet.la
%%MASTER%%lib/libdnet.so
%%MASTER%%lib/libdnet.so.1
+%%MASTER%%include/dnet.h
%%MASTER%%include/dnet/addr.h
%%MASTER%%include/dnet/arp.h
%%MASTER%%include/dnet/blob.h
@@ -19,5 +22,4 @@
%%MASTER%%include/dnet/tcp.h
%%MASTER%%include/dnet/tun.h
%%MASTER%%include/dnet/udp.h
-%%MASTER%%include/dnet.h
%%MASTER%%@dirrm include/dnet