aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-02-03 13:25:30 +0800
committerlioux <lioux@FreeBSD.org>2003-02-03 13:25:30 +0800
commitae0fba4e14923dbc8f02d1ea462c0a9942fbcba6 (patch)
treeb7cc4bcf5711dc1e0f47c658665a179572b63bc5 /net
parent8245c20180a77d0be1db4549d8a0d9f8cbaa52f4 (diff)
downloadfreebsd-ports-gnome-ae0fba4e14923dbc8f02d1ea462c0a9942fbcba6.tar.gz
freebsd-ports-gnome-ae0fba4e14923dbc8f02d1ea462c0a9942fbcba6.tar.zst
freebsd-ports-gnome-ae0fba4e14923dbc8f02d1ea462c0a9942fbcba6.zip
o After repo copy from mldonkey port:
- Update to source code version of mldonkey - Only build support for both eDonkey and Overnet networks for now Repo copied by: joe (cvs hat) Submitted by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/mldonkey-src/Makefile60
-rw-r--r--net/mldonkey-src/distinfo3
-rw-r--r--net/mldonkey-src/files/kill_mldonkey32
-rw-r--r--net/mldonkey-src/pkg-comment2
-rw-r--r--net/mldonkey-src/pkg-descr2
-rw-r--r--net/mldonkey-src/pkg-message7
-rw-r--r--net/mldonkey-src/pkg-plist4
7 files changed, 60 insertions, 50 deletions
diff --git a/net/mldonkey-src/Makefile b/net/mldonkey-src/Makefile
index 3b5cd7eb1dd9..a9da603df882 100644
--- a/net/mldonkey-src/Makefile
+++ b/net/mldonkey-src/Makefile
@@ -1,5 +1,5 @@
# New ports collection makefile for: mldonkey
-# Date created: 21 August 2002
+# Date created: 18 January 2003
# Whom: Holger Lamm <holger@e-gitt.net>
#
# $FreeBSD$
@@ -10,44 +10,72 @@ PORTVERSION= 2.02.0
PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://ernie.eit.uni-kl.de/mldonkey/ \
- http://savannah.nongnu.org/download/mldonkey/stable/contributed/
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/.0$/-0/}.shared.${ARCH}-${OPSYS}
+ http://savannah.nongnu.org/download/mldonkey/stable/
+PKGNAMESUFFIX= -src
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/.0$/-0/}.sources
MAINTAINER= holger@e-gitt.net
-ONLY_FOR_ARCHS= alpha i386
-USE_BZIP2= yes
-NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-distrib-${PORTVERSION:C/.(.)$/-\1/}
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-DIRNAME= ${HOME}/.mldonkey
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-multinet
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GMAKE= yes
+ALL_TARGET= depend all
+
+.if defined(WITHOUT_GUI)
+# have no 'without-' flag
+CONFIGURE_ENV= GTK_CONFIG=no
+PLIST_SUB+= GUI="@comment "
+.else
+PLIST_SUB+= GUI=""
+BUILD_DEPENDS+= lablgtk:${PORTSDIR}/x11-toolkits/ocaml-lablgtk
+# we don't need lablgtk as RUN dependency, but we need gtk+glib
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+.endif
DOCFILES= AUTHORS BUGS ChangeLog Developers.txt FAQ.html \
Readme.txt TODO ed2k_links.txt
+pre-everything::
+.if !defined(WITHOUT_GUI)
+ @${ECHO_MSG} "You can disable the GUI by defining WITHOUT_GUI."
+.endif
+
post-patch:
@${SED} -e "s|%%PREFIX%%|${PREFIX}|" ${FILESDIR}/wrapper.sh > \
${WRKDIR}/wrapper.sh
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/mldonkey ${PREFIX}/bin/mldonkey-real
+ @${INSTALL_SCRIPT} ${WRKSRC}/distrib/mldonkey_previewer ${PREFIX}/bin
@${INSTALL_SCRIPT} ${FILESDIR}/kill_mldonkey ${PREFIX}/bin
- @${INSTALL_SCRIPT} ${WRKSRC}/mldonkey_previewer ${PREFIX}/bin
@${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${PREFIX}/bin/mldonkey
+.ifndef(WITHOUT_GUI)
+ @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_guistarter ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_gui ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_gui2 ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/mlchat ${PREFIX}/bin
+.endif
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in ${DOCFILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/distrib/${file} ${DOCSDIR}
.endfor
.endif
post-install:
- @${SED} -e 's|/usr/local/|${PREFIX}/|' ${PKGMESSAGE}
-
-.include <bsd.port.pre.mk>
+ @${FMT} < ${PKGMESSAGE}
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
+install-user: extract
+.if !defined(LANG)
+ @${ECHO_MSG} "Please call as: make install-user LANG=<lang>"
+ @${ECHO_MSG} "with <lang> one of en,de,fr,fr.noaccents !"
+.else
+ @${CP} ${WRKSRC}/i18n/gui_messages.ini.${LANG}\
+ ${HOME}/.mldonkey_gui_messages.ini
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/mldonkey-src/distinfo b/net/mldonkey-src/distinfo
index c40dd20ec99f..3d5f29f75eca 100644
--- a/net/mldonkey-src/distinfo
+++ b/net/mldonkey-src/distinfo
@@ -1,2 +1 @@
-MD5 (mldonkey-2.02-0.shared.i386-FreeBSD.tar.bz2) = 76682acd24eedcca5be4f24b26abc7c0
-MD5 (mldonkey-2.02-0.shared.alpha-FreeBSD.tar.bz2) = 8ab6ba3a147fb72f8ce75e079b33b084
+MD5 (mldonkey-2.02-0.sources.tar.gz) = 9db7855e811d1bf2ffab23ebd565efc1
diff --git a/net/mldonkey-src/files/kill_mldonkey b/net/mldonkey-src/files/kill_mldonkey
index 17a7de100aad..2c4f923c3516 100644
--- a/net/mldonkey-src/files/kill_mldonkey
+++ b/net/mldonkey-src/files/kill_mldonkey
@@ -1,31 +1,3 @@
-#
-# Copyright (c) 2003
-# Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
-# Holger Lamm <holger@e-gitt.net>
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-# 1. Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
-# ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-# ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
-# FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
-# OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
-# LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
-# OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
-# SUCH DAMAGE.
-#
-
#!/bin/sh
#
@@ -42,9 +14,9 @@ HTTPURL="127.0.0.1:4080"
HTTP_COMMAND="/usr/bin/fetch"
HTTP_COMMAND_ARGS="-1 -q -s"
-if [ -n "${HTTPUSER}" -a -n "${HTTPPASS}" ]
+if [ -n "${HTTPUSER} -a -n "${HTTPPASS}" ]
then
- export HTTP_AUTH=basic:*:${HTTPUSER}:${HTTPPASS}
+ export HTTP_AUTH=basic:*:${HTTPUSER}:${HTTPPASS}
fi
${HTTP_COMMAND} ${HTTP_COMMAND_ARGS} "http://${HTTPURL}/submit?q=kill"
diff --git a/net/mldonkey-src/pkg-comment b/net/mldonkey-src/pkg-comment
index cb832da58948..0da2870eca0b 100644
--- a/net/mldonkey-src/pkg-comment
+++ b/net/mldonkey-src/pkg-comment
@@ -1 +1 @@
-A OCAML client for eDonkey and Overnet peer-to-peer networks (core)
+A OCAML client for eDonkey and Overnet peer-to-peer networks
diff --git a/net/mldonkey-src/pkg-descr b/net/mldonkey-src/pkg-descr
index a7cf4a8312ae..30534114f3cd 100644
--- a/net/mldonkey-src/pkg-descr
+++ b/net/mldonkey-src/pkg-descr
@@ -4,7 +4,7 @@ peer-to-peer networks.
(see http://www.overnet.com/)
It is separated into a core with telnet and web interfaces, and
-brings a GTK GUI (see the separate mldonkey-gui port).
+a GTK GUI. This port will build it from sources.
Other features over the original eDonkey client are:
- better stability
diff --git a/net/mldonkey-src/pkg-message b/net/mldonkey-src/pkg-message
index 8f51f832d1f3..24cf886c0572 100644
--- a/net/mldonkey-src/pkg-message
+++ b/net/mldonkey-src/pkg-message
@@ -13,3 +13,10 @@
- You can import the downloads you started with eDonkey
(try "import /home/directory/path/.edonkey2000-core"
on the console), but you can NOT go back!
+
+- If this is the first time you install mldonkey,
+ please go to the mldonkey-gui ports dir as a user and enter:
+
+ make install-user
+
+ this will set up your user config.
diff --git a/net/mldonkey-src/pkg-plist b/net/mldonkey-src/pkg-plist
index 6f7a26bf9180..bd38360c8a4c 100644
--- a/net/mldonkey-src/pkg-plist
+++ b/net/mldonkey-src/pkg-plist
@@ -1,7 +1,11 @@
bin/kill_mldonkey
bin/mldonkey
bin/mldonkey-real
+bin/mldonkey_guistarter
bin/mldonkey_previewer
+%%GUI%%bin/mlchat
+%%GUI%%bin/mldonkey_gui
+%%GUI%%bin/mldonkey_gui2
%%PORTDOCS%%share/doc/mldonkey/AUTHORS
%%PORTDOCS%%share/doc/mldonkey/BUGS
%%PORTDOCS%%share/doc/mldonkey/ChangeLog