aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-07-14 10:18:53 +0800
committermiwi <miwi@FreeBSD.org>2010-07-14 10:18:53 +0800
commitb9bca566744abf47dfaa17ef94aaf4e174dee807 (patch)
tree8241994c2786a3e951a35be3a0160b6afc489317 /net
parent5b5b224dac66e431338ae8b608110c1c3d4ff8db (diff)
downloadfreebsd-ports-gnome-b9bca566744abf47dfaa17ef94aaf4e174dee807.tar.gz
freebsd-ports-gnome-b9bca566744abf47dfaa17ef94aaf4e174dee807.tar.zst
freebsd-ports-gnome-b9bca566744abf47dfaa17ef94aaf4e174dee807.zip
Kwooty is a .nzb usenet binary downloader for KDE4.
It supports automatic file verifying/repairing with par2 files and automatic .rar archive extraction. WWW: http://kwooty.sourceforge.net/ PR: ports/146780 Submitted by: Mina R Waheeb <sycner at gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/kwooty/Makefile28
-rw-r--r--net/kwooty/distinfo3
-rw-r--r--net/kwooty/pkg-descr6
-rw-r--r--net/kwooty/pkg-plist8
5 files changed, 46 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index e6680ed8702c..8a83fed23ed6 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -291,6 +291,7 @@
SUBDIR += kojoney
SUBDIR += kphone
SUBDIR += krdesktop
+ SUBDIR += kwooty
SUBDIR += l2tpd
SUBDIR += l4ip
SUBDIR += ladvd
diff --git a/net/kwooty/Makefile b/net/kwooty/Makefile
new file mode 100644
index 000000000000..1deb23cde1b5
--- /dev/null
+++ b/net/kwooty/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: kwooty
+# Date created: 5 Apr 2010
+# Whom: Mina R Waheeb <sycner@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kwooty
+PORTVERSION= 0.4.0
+CATEGORIES= net kde
+MASTER_SITES= SF/${PORTNAME}
+
+MAINTAINER= sycner@gmail.com
+COMMENT= Usenet binary downloader for KDE4
+
+RUN_DEPENDS= ${LOCALBASE}/bin/unrar:${PORTSDIR}/archivers/unrar \
+ ${LOCALBASE}/bin/par2:${PORTSDIR}/archivers/par2cmdline \
+ ${LOCALBASE}/bin/7z:${PORTSDIR}/archivers/p7zip
+
+USE_CMAKE= yes
+USE_KDE4= kdelibs kdehier kdeprefix automoc4 workspace
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build rcc_build uic_build
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/bin|${LOCALBASE}/bin|g' ${WRKSRC}/src/preferences/settings.kcfg
+
+.include <bsd.port.mk>
diff --git a/net/kwooty/distinfo b/net/kwooty/distinfo
new file mode 100644
index 000000000000..885f59203e55
--- /dev/null
+++ b/net/kwooty/distinfo
@@ -0,0 +1,3 @@
+MD5 (kwooty-0.4.0.tar.gz) = d4c03a59fa04d26ff291ca55547191f7
+SHA256 (kwooty-0.4.0.tar.gz) = 31774f914e653092326fe20d26cd059ef77400c551e388a5865944453ad6bd1f
+SIZE (kwooty-0.4.0.tar.gz) = 119669
diff --git a/net/kwooty/pkg-descr b/net/kwooty/pkg-descr
new file mode 100644
index 000000000000..2779352c0f45
--- /dev/null
+++ b/net/kwooty/pkg-descr
@@ -0,0 +1,6 @@
+Kwooty is a .nzb usenet binary downloader for KDE4.
+
+It supports automatic file verifying/repairing
+with par2 files and automatic .rar archive extraction.
+
+WWW: http://kwooty.sourceforge.net/
diff --git a/net/kwooty/pkg-plist b/net/kwooty/pkg-plist
new file mode 100644
index 000000000000..22534864e8a1
--- /dev/null
+++ b/net/kwooty/pkg-plist
@@ -0,0 +1,8 @@
+bin/kwooty
+share/applications/kde4/kwooty.desktop
+share/apps/kwooty/kwootyui.rc
+share/config.kcfg/settings.kcfg
+share/icons/hicolor/16x16/apps/kwooty.png
+share/icons/hicolor/32x32/apps/kwooty.png
+share/icons/hicolor/64x64/apps/kwooty.png
+@dirrm share/apps/kwooty