aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2013-11-13 15:37:36 +0800
committeravilla <avilla@FreeBSD.org>2013-11-13 15:37:36 +0800
commitbcfe83ec01e9efd8f6d47688453d871bdeb7167c (patch)
treed87639550039e58636f6e13c214c3c154c550f3a /net
parent5db55c795aeeb692eae4e06e2512d7c619f8a6f4 (diff)
downloadfreebsd-ports-gnome-bcfe83ec01e9efd8f6d47688453d871bdeb7167c.tar.gz
freebsd-ports-gnome-bcfe83ec01e9efd8f6d47688453d871bdeb7167c.tar.zst
freebsd-ports-gnome-bcfe83ec01e9efd8f6d47688453d871bdeb7167c.zip
- Use CMAKE_BUILD_TYPE to fix plist when WITH_DEBUG is set.
- STAGEify. - Use LIB_DEPENDS new format.
Diffstat (limited to 'net')
-rw-r--r--net/libkvkontakte/Makefile7
-rw-r--r--net/libkvkontakte/pkg-plist3
2 files changed, 5 insertions, 5 deletions
diff --git a/net/libkvkontakte/Makefile b/net/libkvkontakte/Makefile
index e011fd8b14b7..703d13395414 100644
--- a/net/libkvkontakte/Makefile
+++ b/net/libkvkontakte/Makefile
@@ -5,12 +5,11 @@ PORTVERSION= ${DIGIKAM_VER}
CATEGORIES= net kde
MAINTAINER= kde@FreeBSD.org
-COMMENT= KDE4 library for accessing vk.com
+COMMENT= KDE library for accessing vk.com
-NO_STAGE= yes
-.include "${.CURDIR}/../../graphics/digikam-kde4/Makefile.common"
+.include "${.CURDIR:H:H}/graphics/digikam-kde4/Makefile.common"
-LIB_DEPENDS= qjson:${PORTSDIR}/devel/qjson
+LIB_DEPENDS= libqjson.so:${PORTSDIR}/devel/qjson
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/net/libkvkontakte/pkg-plist b/net/libkvkontakte/pkg-plist
index 13ed40ee6d29..e5a512f22ffd 100644
--- a/net/libkvkontakte/pkg-plist
+++ b/net/libkvkontakte/pkg-plist
@@ -33,10 +33,11 @@ include/libkvkontakte/version.h
include/libkvkontakte/vkontaktejobs.h
lib/cmake/LibKVkontakte/LibKVkontakteConfig.cmake
lib/cmake/LibKVkontakte/LibKVkontakteConfigVersion.cmake
-lib/cmake/LibKVkontakte/LibKVkontakteTargets-release.cmake
+lib/cmake/LibKVkontakte/LibKVkontakteTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/LibKVkontakte/LibKVkontakteTargets.cmake
lib/libkvkontakte.so
lib/libkvkontakte.so.1
lib/libkvkontakte.so.1.0.0
@dirrm lib/cmake/LibKVkontakte
+@dirrmtry lib/cmake
@dirrm include/libkvkontakte