aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-07-13 20:50:30 +0800
committertijl <tijl@FreeBSD.org>2014-07-13 20:50:30 +0800
commitbf9329b4d410b94e8bbe47b68a80f5023925e432 (patch)
tree6695cdd9311c953bb95012d360ba055deb8f46cf /net
parent588058b8d547a4da4935f053b1ea32ed53206db2 (diff)
downloadfreebsd-ports-gnome-bf9329b4d410b94e8bbe47b68a80f5023925e432.tar.gz
freebsd-ports-gnome-bf9329b4d410b94e8bbe47b68a80f5023925e432.tar.zst
freebsd-ports-gnome-bf9329b4d410b94e8bbe47b68a80f5023925e432.zip
New port: net/belle-sip
Belle-sip is a SIP (RFC3261) implementation written in C, with an object oriented API. * RFC3261 compliant implementation of SIP parser, writer, transactions and dialog layers * http client api * support of client TLS certificate * fully asynchronous transport layer (UDP, TCP, TLS) * fully asynchronous DNS resolution with SRV * full dual-stack IPv6 support * SIP transaction state machines with lastest corrections (RFC6026) * automatic management of request refreshes with network disconnection resiliency thanks to the "refresher" object * supported platforms: Linux, Mac OSX, windows XP+, iOS, Android, Blackberry 10 PR: 191528 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile2
-rw-r--r--net/belle-sip/Makefile50
-rw-r--r--net/belle-sip/distinfo4
-rw-r--r--net/belle-sip/files/patch-configure44
-rw-r--r--net/belle-sip/files/patch-src_belle__sip__internal.h10
-rw-r--r--net/belle-sip/pkg-descr17
-rw-r--r--net/belle-sip/pkg-plist32
7 files changed, 158 insertions, 1 deletions
diff --git a/net/Makefile b/net/Makefile
index 5405d7da8128..2ba8ac57420d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -44,6 +44,7 @@
SUBDIR += bcusdk-eibd
SUBDIR += beacon
SUBDIR += beanstalkd
+ SUBDIR += belle-sip
SUBDIR += bindtest
SUBDIR += binkd
SUBDIR += bird
@@ -346,7 +347,6 @@
SUBDIR += linc-reference
SUBDIR += linknx
SUBDIR += linphone
- SUBDIR += linphone-base
SUBDIR += linux-f10-nss_ldap
SUBDIR += linux-f10-openldap
SUBDIR += linuxigd
diff --git a/net/belle-sip/Makefile b/net/belle-sip/Makefile
new file mode 100644
index 000000000000..dcae13a360eb
--- /dev/null
+++ b/net/belle-sip/Makefile
@@ -0,0 +1,50 @@
+# $FreeBSD$
+
+PORTNAME= belle-sip
+PORTVERSION= 1.3.0
+CATEGORIES= net
+MASTER_SITES= SAVANNAH/linphone/${PORTNAME}/:source1 \
+ http://www.antlr3.org/download/:source2
+DISTFILES= belle-sip-1.3.0.tar.gz:source1 \
+ antlr-3.4-complete.jar:source2
+EXTRACT_ONLY= belle-sip-1.3.0.tar.gz
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= Belle-sip is a SIP (RFC3261) implementation written in C
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libantlr3c.so:${PORTSDIR}/devel/libantlr3c
+
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --disable-tests
+INSTALL_TARGET= install-strip
+USES= compiler:c11 gmake libtool pathfix
+USE_JAVA= yes
+JAVA_BUILD= jre
+JAVA_VERSION= 1.6+
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= POLARSSL
+OPTIONS_DEFAULT=POLARSSL
+
+POLARSSL_CONFIGURE_ENABLE= tls
+POLARSSL_LIB_DEPENDS= libpolarssl.so:${PORTSDIR}/security/polarssl
+
+.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
+post-extract:
+ @${CP} ${DISTDIR}/antlr-3.4-complete.jar ${WRKDIR}/antlr-complete.jar
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%WRKDIR%%|${WRKDIR}|' -e 's|-lrt||' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-timezone||' \
+ ${WRKSRC}/src/belle_sip_headers_impl.c
+
+.include <bsd.port.mk>
diff --git a/net/belle-sip/distinfo b/net/belle-sip/distinfo
new file mode 100644
index 000000000000..65601a0f7299
--- /dev/null
+++ b/net/belle-sip/distinfo
@@ -0,0 +1,4 @@
+SHA256 (belle-sip-1.3.0.tar.gz) = 50f0106903bdf67fcbc674dd6b3ec2930d5a5e735d9ba70dbe21f4bc76f08091
+SIZE (belle-sip-1.3.0.tar.gz) = 665281
+SHA256 (antlr-3.4-complete.jar) = 9d3e866b610460664522520f73b81777b5626fb0a282a5952b9800b751550bf7
+SIZE (antlr-3.4-complete.jar) = 2388361
diff --git a/net/belle-sip/files/patch-configure b/net/belle-sip/files/patch-configure
new file mode 100644
index 000000000000..32aa83806963
--- /dev/null
+++ b/net/belle-sip/files/patch-configure
@@ -0,0 +1,44 @@
+--- configure.orig
++++ configure
+@@ -15655,10 +15655,10 @@
+ resolv_h_hav_res_ndestroy=no
+ LIBS_save=$LIBS
+
+-LIBS="$LIBS -lresolv"
+
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
++#include <netinet/in.h>
+ #include <resolv.h>
+ int
+ main ()
+@@ -15683,7 +15683,8 @@
+ conftest$ac_exeext conftest.$ac_ext
+
+ ac_fn_c_check_decl "$LINENO" "res_ndestroy
+- " "ac_cv_have_decl_res_ndestroy___" "#include <resolv.h>
++ " "ac_cv_have_decl_res_ndestroy___" "#include <netinet/in.h>
++#include <resolv.h>
+ "
+ if test "x$ac_cv_have_decl_res_ndestroy___" = xyes; then :
+ resolv_h_hav_res_ndestroy=yes
+@@ -15748,17 +15749,11 @@
+
+
+ if test $ANTLR = "no" ; then
+-antlr_java_prefixes="$antlr_prefix/share/java /usr/local/share/java /usr/share/java /opt/local/share/java"
++antlr_java_prefixes="/usr/obj/ports/usr/home/tijl/projects/freebsd/ports/head/net/belle-sip/work"
+
+ for antlr_java_prefix in $antlr_java_prefixes
+ do
+- antlr_jar=$antlr_java_prefix/antlr.jar
+- if test -f $antlr_jar ; then
+- break
+- else
+- antlr_jar=no
+- fi
+- antlr_jar=$antlr_java_prefix/antlr3.jar
++ antlr_jar=$antlr_java_prefix/antlr-complete.jar
+ if test -f $antlr_jar ; then
+ break
+ else
diff --git a/net/belle-sip/files/patch-src_belle__sip__internal.h b/net/belle-sip/files/patch-src_belle__sip__internal.h
new file mode 100644
index 000000000000..3f12d1d794b4
--- /dev/null
+++ b/net/belle-sip/files/patch-src_belle__sip__internal.h
@@ -0,0 +1,10 @@
+--- src/belle_sip_internal.h.orig 2014-06-30 16:50:46.873520744 +0600
++++ src/belle_sip_internal.h 2014-06-30 16:51:05.264521071 +0600
+@@ -23,6 +23,7 @@
+ #include <stdio.h>
+ #include <sys/types.h>
+ #include <errno.h>
++#include <netinet/in.h>
+
+ /* include all public headers*/
+ #include "belle-sip/belle-sip.h"
diff --git a/net/belle-sip/pkg-descr b/net/belle-sip/pkg-descr
new file mode 100644
index 000000000000..46fea7aa7a30
--- /dev/null
+++ b/net/belle-sip/pkg-descr
@@ -0,0 +1,17 @@
+Belle-sip is a SIP (RFC3261) implementation written in C, with an object
+oriented API.
+
+* RFC3261 compliant implementation of SIP parser, writer, transactions and
+ dialog layers
+* http client api
+* support of client TLS certificate
+* fully asynchronous transport layer (UDP, TCP, TLS)
+* fully asynchronous DNS resolution with SRV
+* full dual-stack IPv6 support
+* SIP transaction state machines with lastest corrections (RFC6026)
+* automatic management of request refreshes with network disconnection
+ resiliency thanks to the "refresher" object
+* supported platforms: Linux, Mac OSX, windows XP+, iOS, Android,
+ Blackberry 10
+
+WWW: http://www.linphone.org/
diff --git a/net/belle-sip/pkg-plist b/net/belle-sip/pkg-plist
new file mode 100644
index 000000000000..bac7d05254f9
--- /dev/null
+++ b/net/belle-sip/pkg-plist
@@ -0,0 +1,32 @@
+include/belle-sip/auth-helper.h
+include/belle-sip/belle-sdp.h
+include/belle-sip/belle-sip.h
+include/belle-sip/defs.h
+include/belle-sip/dialog.h
+include/belle-sip/dict.h
+include/belle-sip/generic-uri.h
+include/belle-sip/headers.h
+include/belle-sip/http-listener.h
+include/belle-sip/http-message.h
+include/belle-sip/http-provider.h
+include/belle-sip/list.h
+include/belle-sip/listener.h
+include/belle-sip/listeningpoint.h
+include/belle-sip/mainloop.h
+include/belle-sip/message.h
+include/belle-sip/object.h
+include/belle-sip/parameters.h
+include/belle-sip/provider.h
+include/belle-sip/refresher.h
+include/belle-sip/resolver.h
+include/belle-sip/sip-uri.h
+include/belle-sip/sipstack.h
+include/belle-sip/transaction.h
+include/belle-sip/types.h
+include/belle-sip/utils.h
+lib/libbellesip.a
+lib/libbellesip.so
+lib/libbellesip.so.0
+lib/libbellesip.so.0.0.0
+libdata/pkgconfig/belle-sip.pc
+@dirrm include/belle-sip