aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2014-07-15 13:45:50 +0800
committerleeym <leeym@FreeBSD.org>2014-07-15 13:45:50 +0800
commitc05dfbf2c5499b5e5ca9c021743b9f7e49b98271 (patch)
treed75f25b8bd8384e6203eddef5dd3b6a59864f0ad /net
parentef78a778d8de461e6b378556a04f7ec852b2303f (diff)
downloadfreebsd-ports-gnome-c05dfbf2c5499b5e5ca9c021743b9f7e49b98271.tar.gz
freebsd-ports-gnome-c05dfbf2c5499b5e5ca9c021743b9f7e49b98271.tar.zst
freebsd-ports-gnome-c05dfbf2c5499b5e5ca9c021743b9f7e49b98271.zip
- update to 0.60
Diffstat (limited to 'net')
-rw-r--r--net/p5-Net-Amazon-S3/Makefile3
-rw-r--r--net/p5-Net-Amazon-S3/distinfo4
-rw-r--r--net/p5-Net-Amazon-S3/files/patch-moosefix44
3 files changed, 10 insertions, 41 deletions
diff --git a/net/p5-Net-Amazon-S3/Makefile b/net/p5-Net-Amazon-S3/Makefile
index 038475abd6cb..6faa292e2c12 100644
--- a/net/p5-Net-Amazon-S3/Makefile
+++ b/net/p5-Net-Amazon-S3/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= Net-Amazon-S3
-PORTVERSION= 0.59
-PORTREVISION= 2
+PORTVERSION= 0.60
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/net/p5-Net-Amazon-S3/distinfo b/net/p5-Net-Amazon-S3/distinfo
index 5996dbaa7854..5f756b969543 100644
--- a/net/p5-Net-Amazon-S3/distinfo
+++ b/net/p5-Net-Amazon-S3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Net-Amazon-S3-0.59.tar.gz) = 94f2bd6b317a9142e400d7d17bd573dc9d22284c3ceaa4864474ba674e0e2e9f
-SIZE (Net-Amazon-S3-0.59.tar.gz) = 52272
+SHA256 (Net-Amazon-S3-0.60.tar.gz) = 628937132268e501fb82410f96636e01b183423ea133b6c362894da109d6ac81
+SIZE (Net-Amazon-S3-0.60.tar.gz) = 53232
diff --git a/net/p5-Net-Amazon-S3/files/patch-moosefix b/net/p5-Net-Amazon-S3/files/patch-moosefix
index 1456ef7df098..d0ce4154061f 100644
--- a/net/p5-Net-Amazon-S3/files/patch-moosefix
+++ b/net/p5-Net-Amazon-S3/files/patch-moosefix
@@ -1,41 +1,11 @@
-diff --git a/lib/Net/Amazon/S3/Client/Object.pm b/lib/Net/Amazon/S3/Client/Object.pm
-index d10cba7..3d70d33 100755
---- lib/Net/Amazon/S3/Client/Object.pm
-+++ lib/Net/Amazon/S3/Client/Object.pm
-@@ -13,7 +13,7 @@ use IO::File 1.14;
- # ABSTRACT: An easy-to-use Amazon S3 client object
+--- lib/Net/Amazon/S3/Client/Object.pm.orig 2014-07-13 05:44:37.000000000 -0700
++++ lib/Net/Amazon/S3/Client/Object.pm 2014-07-13 05:44:46.000000000 -0700
+@@ -19,7 +19,7 @@
+ [ qw(private public-read public-read-write authenticated-read) ];
- enum 'AclShort' =>
-- qw(private public-read public-read-write authenticated-read);
-+ [ qw(private public-read public-read-write authenticated-read) ];
+ enum 'StorageClass' =>
+- qw(standard reduced_redundancy);
++ [ qw(standard reduced_redundancy) ];
has 'client' =>
( is => 'ro', isa => 'Net::Amazon::S3::Client', required => 1 );
-diff --git a/lib/Net/Amazon/S3/HTTPRequest.pm b/lib/Net/Amazon/S3/HTTPRequest.pm
-index 69c6327..eeb9584 100755
---- lib/Net/Amazon/S3/HTTPRequest.pm
-+++ lib/Net/Amazon/S3/HTTPRequest.pm
-@@ -13,7 +13,7 @@ use URI;
- my $METADATA_PREFIX = 'x-amz-meta-';
- my $AMAZON_HEADER_PREFIX = 'x-amz-';
-
--enum 'HTTPMethod' => qw(DELETE GET HEAD PUT POST);
-+enum 'HTTPMethod' => [ qw(DELETE GET HEAD PUT POST) ];
-
- has 's3' => ( is => 'ro', isa => 'Net::Amazon::S3', required => 1 );
- has 'method' => ( is => 'ro', isa => 'HTTPMethod', required => 1 );
-diff --git a/lib/Net/Amazon/S3/Request.pm b/lib/Net/Amazon/S3/Request.pm
-index 9dded27..0415880 100644
---- lib/Net/Amazon/S3/Request.pm
-+++ lib/Net/Amazon/S3/Request.pm
-@@ -7,8 +7,8 @@ use Regexp::Common qw /net/;
- # ABSTRACT: Base class for request objects
-
- enum 'AclShort' =>
-- qw(private public-read public-read-write authenticated-read);
--enum 'LocationConstraint' => ( 'US', 'EU' );
-+ [ qw(private public-read public-read-write authenticated-read) ];
-+enum 'LocationConstraint' => [ 'US', 'EU' ];
-
- # To comply with Amazon S3 requirements, bucket names must:
- # Contain lowercase letters, numbers, periods (.), underscores (_), and dashes (-)