aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2018-06-07 20:54:42 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2018-06-07 20:54:42 +0800
commitc28f5a8cd74d0f522db3a0a6b57d2a90582a1d80 (patch)
tree3a1b12fa54dbe5e7fb220d5cfd26636da8bbbc63 /net
parent81b7020619cb4ea31acfe84de33e8165518db6ed (diff)
downloadfreebsd-ports-gnome-c28f5a8cd74d0f522db3a0a6b57d2a90582a1d80.tar.gz
freebsd-ports-gnome-c28f5a8cd74d0f522db3a0a6b57d2a90582a1d80.tar.zst
freebsd-ports-gnome-c28f5a8cd74d0f522db3a0a6b57d2a90582a1d80.zip
mptsd receives mpegts streams from multicast (udp/rtp) or http and
combines them into one multiple program stream that is suitable for outputing to DVB-C modulator. WWW: https://github.com/gfto/mptsd
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/mptsd/Makefile21
-rw-r--r--net/mptsd/distinfo3
-rw-r--r--net/mptsd/files/patch-Makefile21
-rw-r--r--net/mptsd/files/patch-libfuncs_Makefile16
-rw-r--r--net/mptsd/files/patch-libtsfuncs_Makefile16
-rw-r--r--net/mptsd/files/patch-libtsfuncs_crc.c11
-rw-r--r--net/mptsd/files/patch-libtsfuncs_pes__data.c10
-rw-r--r--net/mptsd/files/patch-libtsfuncs_tsfuncs.h10
-rw-r--r--net/mptsd/files/patch-mptsd.c11
-rw-r--r--net/mptsd/pkg-descr5
-rw-r--r--net/mptsd/pkg-plist5
12 files changed, 130 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index c3e3afcdd3e3..e7b1eabedfc9 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -486,6 +486,7 @@
SUBDIR += mpich
SUBDIR += mpich2
SUBDIR += mping
+ SUBDIR += mptsd
SUBDIR += mrouted
SUBDIR += msend
SUBDIR += mtr
diff --git a/net/mptsd/Makefile b/net/mptsd/Makefile
new file mode 100644
index 000000000000..c943564a5ec3
--- /dev/null
+++ b/net/mptsd/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= mptsd
+PORTVERSION= 1.1
+CATEGORIES= net multimedia
+MASTER_SITES= https://georgi.unixsol.org/programs/mptsd/
+
+MAINTAINER= win2000rus@hotmail.com
+COMMENT= MPEG TS stream muxer
+
+LICENSE= GPLv2 MIT
+LICENSE_COMB= multi
+
+USES= gmake tar:bzip2
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}*.conf ${STAGEDIR}${ETCDIR}
+
+.include <bsd.port.mk>
diff --git a/net/mptsd/distinfo b/net/mptsd/distinfo
new file mode 100644
index 000000000000..f24ec2de6e68
--- /dev/null
+++ b/net/mptsd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523373210
+SHA256 (mptsd-1.1.tar.bz2) = 3609e13df7ee561f59f667d7700f13d515714c9b13c2220e88adb3c144b995f0
+SIZE (mptsd-1.1.tar.bz2) = 95989
diff --git a/net/mptsd/files/patch-Makefile b/net/mptsd/files/patch-Makefile
new file mode 100644
index 000000000000..32420b53455e
--- /dev/null
+++ b/net/mptsd/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig 2012-01-26 12:00:02 UTC
++++ Makefile
+@@ -1,17 +1,8 @@
+-CC = $(CROSS)$(TARGET)gcc
+ STRIP = $(CROSS)$(TARGET)strip
+-BUILD_ID = $(shell date +%F_%R)
+ VERSION="v1.1"
+-GIT_VER = $(shell git describe --tags --dirty --always 2>/dev/null)
+-CFLAGS = -ggdb -Wall -Wextra -Wshadow -Wformat-security -Wno-strict-aliasing -O2 -D_GNU_SOURCE -DBUILD_ID=\"$(BUILD_ID)\"
+-ifneq "$(GIT_VER)" ""
+-CFLAGS += -DGIT_VER=\"$(GIT_VER)\"
+-else
+-CFLAGS += -DGIT_VER=\"$(VERSION)\"
+-endif
++CFLAGS += -Wall -Wextra -Wshadow -Wformat-security -Wno-strict-aliasing -D_GNU_SOURCE -DBUILD_ID=\"FreeBSD_port\" -DGIT_VER=\"$(VERSION)\"
+
+ RM = /bin/rm -f
+-Q = @
+
+ LIBS = -lpthread -lm -lrt
+
diff --git a/net/mptsd/files/patch-libfuncs_Makefile b/net/mptsd/files/patch-libfuncs_Makefile
new file mode 100644
index 000000000000..69e1d6feeec9
--- /dev/null
+++ b/net/mptsd/files/patch-libfuncs_Makefile
@@ -0,0 +1,16 @@
+--- libfuncs/Makefile.orig 2012-01-05 12:40:53 UTC
++++ libfuncs/Makefile
+@@ -1,12 +1,9 @@
+-CC = $(CROSS)$(TARGET)gcc
+ LINK = $(CROSS)$(TARGET)ld -o
+ MKDEP = $(CC) -M -o $*.d $<
+
+ LIBRARY_LINK_OPTS = -L. -r
+-CFLAGS = -O2 -ggdb -std=c99 -D_GNU_SOURCE
+-CFLAGS += -Wall -Wextra -Wshadow -Wformat-security -Wstrict-prototypes
++CFLAGS += -std=c99 -D_GNU_SOURCE -Wall -Wextra -Wshadow -Wformat-security -Wstrict-prototypes
+ RM = /bin/rm -f
+-Q=@
+
+ OBJS = queue.o list.o cbuf.o io.o log.o http_response.o asyncdns.o \
+ server.o misc.o
diff --git a/net/mptsd/files/patch-libtsfuncs_Makefile b/net/mptsd/files/patch-libtsfuncs_Makefile
new file mode 100644
index 000000000000..af6c11733184
--- /dev/null
+++ b/net/mptsd/files/patch-libtsfuncs_Makefile
@@ -0,0 +1,16 @@
+--- libtsfuncs/Makefile.orig 2012-01-05 12:41:01 UTC
++++ libtsfuncs/Makefile
+@@ -1,12 +1,9 @@
+-CC = $(CROSS)$(TARGET)gcc
+ LINK = $(CROSS)$(TARGET)ld -o
+ MKDEP = $(CC) -M -o $*.d $<
+
+ LIBRARY_LINK_OPTS = -L. -r
+-CFLAGS = -O2 -ggdb -std=c99 -D_GNU_SOURCE
+-CFLAGS += -Wall -Wextra -Wshadow -Wformat-security -Wstrict-prototypes
++CFLAGS += -std=c99 -D_GNU_SOURCE -Wall -Wextra -Wshadow -Wformat-security -Wstrict-prototypes
+ RM = /bin/rm -f
+-Q=@
+
+ OBJS = log.o tsfuncs.o crc.o misc.o time.o \
+ sections.o secdata.o \
diff --git a/net/mptsd/files/patch-libtsfuncs_crc.c b/net/mptsd/files/patch-libtsfuncs_crc.c
new file mode 100644
index 000000000000..207a39234820
--- /dev/null
+++ b/net/mptsd/files/patch-libtsfuncs_crc.c
@@ -0,0 +1,11 @@
+--- libtsfuncs/crc.c.orig 2012-01-05 12:41:01 UTC
++++ libtsfuncs/crc.c
+@@ -46,7 +46,7 @@ uint32_t ts_crc32(uint8_t *data, int dat
+ return crc;
+ }
+
+-u_int32_t ts_crc32_section(struct ts_section_header *section_header) {
++uint32_t ts_crc32_section(struct ts_section_header *section_header) {
+ return ts_crc32(section_header->section_data, section_header->section_data_len);
+ }
+
diff --git a/net/mptsd/files/patch-libtsfuncs_pes__data.c b/net/mptsd/files/patch-libtsfuncs_pes__data.c
new file mode 100644
index 000000000000..07c199160ee4
--- /dev/null
+++ b/net/mptsd/files/patch-libtsfuncs_pes__data.c
@@ -0,0 +1,10 @@
+--- libtsfuncs/pes_data.c.orig 2011-09-16 12:32:55 UTC
++++ libtsfuncs/pes_data.c
+@@ -7,6 +7,7 @@
+ */
+ #include <stdlib.h>
+ #include <string.h>
++#include <stdint.h>
+
+ #include "tsdata.h"
+ #include "tsfuncs.h"
diff --git a/net/mptsd/files/patch-libtsfuncs_tsfuncs.h b/net/mptsd/files/patch-libtsfuncs_tsfuncs.h
new file mode 100644
index 000000000000..a25511de64d4
--- /dev/null
+++ b/net/mptsd/files/patch-libtsfuncs_tsfuncs.h
@@ -0,0 +1,10 @@
+--- libtsfuncs/tsfuncs.h.orig 2012-01-05 12:41:01 UTC
++++ libtsfuncs/tsfuncs.h
+@@ -8,6 +8,7 @@
+ #ifndef LIBTS_TSFUNCS_H
+ #define LIBTS_TSFUNCS_H
+
++#include <stdint.h>
+ #include <time.h>
+ #include <netdb.h>
+
diff --git a/net/mptsd/files/patch-mptsd.c b/net/mptsd/files/patch-mptsd.c
new file mode 100644
index 000000000000..731e7881245e
--- /dev/null
+++ b/net/mptsd/files/patch-mptsd.c
@@ -0,0 +1,11 @@
+--- mptsd.c.orig 2011-09-16 12:37:04 UTC
++++ mptsd.c
+@@ -34,7 +34,7 @@
+
+ #define PROGRAM_NAME "ux-mptsd"
+
+-const char *program_id = PROGRAM_NAME " " GIT_VER " build " BUILD_ID;
++const char *program_id = PROGRAM_NAME " FreeBSD port";
+
+ char *server_sig = PROGRAM_NAME;
+ char *server_ver = GIT_VER;
diff --git a/net/mptsd/pkg-descr b/net/mptsd/pkg-descr
new file mode 100644
index 000000000000..399df61d363e
--- /dev/null
+++ b/net/mptsd/pkg-descr
@@ -0,0 +1,5 @@
+mptsd receives mpegts streams from multicast (udp/rtp) or http and
+combines them into one multiple program stream that is suitable for
+outputing to DVB-C modulator.
+
+WWW: https://github.com/gfto/mptsd
diff --git a/net/mptsd/pkg-plist b/net/mptsd/pkg-plist
new file mode 100644
index 000000000000..bfd75739ad3e
--- /dev/null
+++ b/net/mptsd/pkg-plist
@@ -0,0 +1,5 @@
+bin/mptsd
+etc/mptsd/mptsd.conf
+etc/mptsd/mptsd_channels.conf
+etc/mptsd/mptsd_epg.conf
+etc/mptsd/mptsd_nit.conf