aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2010-08-05 04:00:20 +0800
committerohauer <ohauer@FreeBSD.org>2010-08-05 04:00:20 +0800
commitcb5487b881a28e491d51b341f5b8c863e8916c7a (patch)
treefcdc8893d990be6794e426bbbd52191fc9c9cbaa /net
parentc7284b20f917fb444f261ef13a659eddd132055a (diff)
downloadfreebsd-ports-gnome-cb5487b881a28e491d51b341f5b8c863e8916c7a.tar.gz
freebsd-ports-gnome-cb5487b881a28e491d51b341f5b8c863e8916c7a.tar.zst
freebsd-ports-gnome-cb5487b881a28e491d51b341f5b8c863e8916c7a.zip
PR: ports/148997
Submitted by: ohauer Approved by: glarkin (mentor) Say helo to new port subnetcalc SubNetCalc is an IPv4/IPv6 subnet address calculator. For given IPv4 or IPv6 address and netmask or prefix length, it calculates network address, broadcast address, maximum number of hosts and host address range. The output is colourized for better readability (e.g. network part, host part). Also, it prints the addresses in binary format for better understandability. Furthermore, it can identify the address type (e.g. multicast, unique local, site local, etc.) and extract additional information from the address (e.g. type, scope, interface ID, etc.). Finally, it can generate IPv6 unique local prefixes. WWW: http://www.iem.uni-due.de/~dreibh/subnetcalc/
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/subnetcalc/Makefile29
-rw-r--r--net/subnetcalc/distinfo3
-rw-r--r--net/subnetcalc/pkg-descr12
4 files changed, 45 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 3aa5b9f927dd..477a9064f992 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1008,6 +1008,7 @@
SUBDIR += stone
SUBDIR += straw
SUBDIR += stund
+ SUBDIR += subnetcalc
SUBDIR += suckblow
SUBDIR += sup
SUBDIR += tableutil
diff --git a/net/subnetcalc/Makefile b/net/subnetcalc/Makefile
new file mode 100644
index 000000000000..98aadb5d3f59
--- /dev/null
+++ b/net/subnetcalc/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: subnetcalc
+# Date created: 27 July 2010
+# Whom: Thomas Dreibholz <dreibh@iem.uni-due.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= subnetcalc
+PORTVERSION= 2.1.2
+CATEGORIES= net
+MASTER_SITES= http://www.iem.uni-due.de/~dreibh/subnetcalc/download/ \
+ http://www.exp-math.uni-essen.de/~dreibh/subnetcalc/download/
+
+MAINTAINER= dreibh@iem.uni-due.de
+COMMENT= IPv4/IPv6 Subnet Calculator
+
+LIB_DEPENDS= GeoIP.5:${PORTSDIR}/net/GeoIP
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= "--with-geoip=${LOCALBASE}"
+USE_GMAKE= yes
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+PLIST_FILES= bin/subnetcalc
+MAN8= subnetcalc.8
+
+.include <bsd.port.mk>
diff --git a/net/subnetcalc/distinfo b/net/subnetcalc/distinfo
new file mode 100644
index 000000000000..9fc5fa339963
--- /dev/null
+++ b/net/subnetcalc/distinfo
@@ -0,0 +1,3 @@
+MD5 (subnetcalc-2.1.2.tar.gz) = 106514c515037e3c8d4a15330e7ddb2f
+SHA256 (subnetcalc-2.1.2.tar.gz) = 6e28c63c128de098bd6b0a847681766e9fd115b3c36a3fe9bf769ce5ee5f9b17
+SIZE (subnetcalc-2.1.2.tar.gz) = 330159
diff --git a/net/subnetcalc/pkg-descr b/net/subnetcalc/pkg-descr
new file mode 100644
index 000000000000..c0e8ef6158ec
--- /dev/null
+++ b/net/subnetcalc/pkg-descr
@@ -0,0 +1,12 @@
+SubNetCalc is an IPv4/IPv6 subnet address calculator. For given IPv4 or IPv6
+address and netmask or prefix length, it calculates network address, broadcast
+address, maximum number of hosts and host address range. The output is
+colourized for better readability (e.g. network part, host part). Also, it
+prints the addresses in binary format for better understandability.
+
+Furthermore, it can identify the address type (e.g. multicast, unique local,
+site local, etc.) and extract additional information from the address
+(e.g. type, scope, interface ID, etc.). Finally, it can generate IPv6 unique
+local prefixes.
+
+WWW: http://www.iem.uni-due.de/~dreibh/subnetcalc/