aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-07-16 08:46:18 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-07-16 08:46:18 +0800
commitcb54beee70d21098914e31aa6a339155db139060 (patch)
treeace3799c7a9770e4933834c16a23b29fcd3edad7 /net
parent3ba126db5b380103cce9bf54ef96eb182d59b11c (diff)
downloadfreebsd-ports-gnome-cb54beee70d21098914e31aa6a339155db139060.tar.gz
freebsd-ports-gnome-cb54beee70d21098914e31aa6a339155db139060.tar.zst
freebsd-ports-gnome-cb54beee70d21098914e31aa6a339155db139060.zip
Add rubygem-proxifier 1.0.3
This gem was created for 2 purposes. First is to enable ruby programmers to use HTTP or SOCKS proxies interchangeably when using TCPSockets. Either manually with Proxifier::Proxy#open or by require "proxifier/env". The second purpose is to use ruby code that doesn't use proxies for users that have to use proxies. The pruby and pirb executables are simple wrappers for their respective ruby executables that support proxies from environment variables. WWW: https://github.com/samuelkadolph/ruby-proxifier
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-proxifier/Makefile21
-rw-r--r--net/rubygem-proxifier/distinfo3
-rw-r--r--net/rubygem-proxifier/pkg-descr12
4 files changed, 37 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 6710cb41ad9e..e9bcc2ddcab5 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1219,6 +1219,7 @@
SUBDIR += rubygem-opennebula
SUBDIR += rubygem-packetfu
SUBDIR += rubygem-pcaprub
+ SUBDIR += rubygem-proxifier
SUBDIR += rubygem-qiniu
SUBDIR += rubygem-rabbiter
SUBDIR += rubygem-rbvmomi
diff --git a/net/rubygem-proxifier/Makefile b/net/rubygem-proxifier/Makefile
new file mode 100644
index 000000000000..6c86a17b4168
--- /dev/null
+++ b/net/rubygem-proxifier/Makefile
@@ -0,0 +1,21 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= proxifier
+PORTVERSION= 1.0.3
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Add HTTP or SOCKS proxies support and force TCPSocket to use
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+PLIST_FILES= bin/pirb bin/pruby
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-proxifier/distinfo b/net/rubygem-proxifier/distinfo
new file mode 100644
index 000000000000..0e09395cb951
--- /dev/null
+++ b/net/rubygem-proxifier/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1500151692
+SHA256 (rubygem/proxifier-1.0.3.gem) = 40fef4d2c79313a12b8be2799146cb225b35665975a238ba0d513a96c6a37fa9
+SIZE (rubygem/proxifier-1.0.3.gem) = 8192
diff --git a/net/rubygem-proxifier/pkg-descr b/net/rubygem-proxifier/pkg-descr
new file mode 100644
index 000000000000..5b96fb27ed89
--- /dev/null
+++ b/net/rubygem-proxifier/pkg-descr
@@ -0,0 +1,12 @@
+This gem was created for 2 purposes.
+
+First is to enable ruby programmers to use HTTP or SOCKS proxies interchangeably
+when using TCPSockets. Either manually with Proxifier::Proxy#open or by require
+"proxifier/env".
+
+The second purpose is to use ruby code that doesn't use proxies for users that
+have to use proxies. The pruby and pirb executables are simple wrappers for
+their respective ruby executables that support proxies from environment
+variables.
+
+WWW: https://github.com/samuelkadolph/ruby-proxifier