aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-02-25 21:03:44 +0800
committerkoobs <koobs@FreeBSD.org>2016-02-25 21:03:44 +0800
commitcfca06a91cef8b3982a6a704f0ed6ba6c6ee9a80 (patch)
tree821871efd2f0af6b5ae97fbb68dab8cba74216df /net
parent40eb950427166c981c3c6e942ce31ffbd39bf616 (diff)
downloadfreebsd-ports-gnome-cfca06a91cef8b3982a6a704f0ed6ba6c6ee9a80.tar.gz
freebsd-ports-gnome-cfca06a91cef8b3982a6a704f0ed6ba6c6ee9a80.tar.zst
freebsd-ports-gnome-cfca06a91cef8b3982a6a704f0ed6ba6c6ee9a80.zip
net/py-port-for: Update to 0.3.1
- Update PORTVERSION and distinfo checksum (0.3.1) - Add TEST_DEPENDS and test target - Add LICENSE_FILE - Update COMMENT (matching setup.py:description) - Enable NO_ARCH (architecture independent) - Patch setup.py adding tests_require and support for test command
Diffstat (limited to 'net')
-rw-r--r--net/py-port-for/Makefile17
-rw-r--r--net/py-port-for/distinfo4
-rw-r--r--net/py-port-for/files/patch-setup.py22
3 files changed, 36 insertions, 7 deletions
diff --git a/net/py-port-for/Makefile b/net/py-port-for/Makefile
index 966174d64c93..43746c84d743 100644
--- a/net/py-port-for/Makefile
+++ b/net/py-port-for/Makefile
@@ -2,22 +2,29 @@
# $FreeBSD$
PORTNAME= port-for
-PORTVERSION= 0.3
-PORTREVISION= 1
+PORTVERSION= 0.3.1
CATEGORIES= net devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
-COMMENT= Python utility and library that helps with TCP ports management
+COMMENT= Utility that helps with local TCP ports managment
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:${PORTSDIR}/devel/py-nose \
+ ${PYTHON_PKGNAMEPREFIX}mock>=0.8:${PORTSDIR}/devel/py-mock
-# Python3 Ready
USES= python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= distutils concurrent autoplist
+
+NO_ARCH= yes
post-patch:
@${REINPLACE_CMD} '/DEFAULT_CONFIG_PATH/ s|/etc|${PREFIX}&|' ${WRKSRC}/port_for/store.py
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
.include <bsd.port.mk>
diff --git a/net/py-port-for/distinfo b/net/py-port-for/distinfo
index 6bbb86cd68f6..4ea5c6c0d385 100644
--- a/net/py-port-for/distinfo
+++ b/net/py-port-for/distinfo
@@ -1,2 +1,2 @@
-SHA256 (port-for-0.3.tar.gz) = 89a53e4ac858899b9c3dc69f6aedc1abb0b00dced6bb73fc31575b8050bdc479
-SIZE (port-for-0.3.tar.gz) = 18053
+SHA256 (port-for-0.3.1.tar.gz) = b16a84bb29c2954db44c29be38b17c659c9c27e33918dec16b90d375cc596f1c
+SIZE (port-for-0.3.1.tar.gz) = 18652
diff --git a/net/py-port-for/files/patch-setup.py b/net/py-port-for/files/patch-setup.py
new file mode 100644
index 000000000000..b3a3d77fd04d
--- /dev/null
+++ b/net/py-port-for/files/patch-setup.py
@@ -0,0 +1,22 @@
+--- setup.py.orig 2016-02-25 12:42:58 UTC
++++ setup.py
+@@ -8,6 +8,11 @@ for cmd in ('egg_info', 'develop'):
+
+ version='0.3.1'
+
++tests_require = [
++ 'nose',
++ 'mock>=0.8',
++]
++
+ setup(
+ name='port-for',
+ version=version,
+@@ -44,4 +49,7 @@ setup(
+ 'Topic :: System :: Systems Administration',
+ 'Topic :: Internet :: WWW/HTTP :: Site Management',
+ ],
++
++ tests_require=tests_require,
++ test_suite='nose.collector',
+ )