aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2012-08-08 03:19:02 +0800
committerdougb <dougb@FreeBSD.org>2012-08-08 03:19:02 +0800
commitd0d282e4f0d672d648268bec6b7fa95cb018a628 (patch)
tree88b2ee6ebcd676f050322dcbc4df29ab203c49bb /net
parenta6db40ca0ccffd6a2352286cfb854772ced9e498 (diff)
downloadfreebsd-ports-gnome-d0d282e4f0d672d648268bec6b7fa95cb018a628.tar.gz
freebsd-ports-gnome-d0d282e4f0d672d648268bec6b7fa95cb018a628.tar.zst
freebsd-ports-gnome-d0d282e4f0d672d648268bec6b7fa95cb018a628.zip
Fix problem introduced in r302141. The directory for the unpacked source
files is unversioned, so it conflicts with the name of the rc.d script in WRKDIR after SUB_FILES is applied. This is the same method as suggested in the PR (and that I've used previously), just slightly different in the details. PR: ports/170441 Submitted by: Frank Wall <fw@moov.de> Approved by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/rinetd/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/rinetd/Makefile b/net/rinetd/Makefile
index 493ca5176761..75e82e91a5c8 100644
--- a/net/rinetd/Makefile
+++ b/net/rinetd/Makefile
@@ -19,7 +19,7 @@ COMMENT= A simple TCP port redirector
OPTIONS_DEFINE= DOCS
-WRKSRC= ${WRKDIR}/rinetd/
+WRKSRC= ${WRKDIR}/rinetd-${PORTVERSION}
MAKE_JOBS_SAFE= yes
USE_DOS2UNIX= yes
@@ -32,6 +32,9 @@ USE_RC_SUBR= rinetd
.include <bsd.port.pre.mk>
+post-extract:
+ @${MV} ${WRKDIR}/rinetd ${WRKSRC}
+
post-patch:
@${REINPLACE_CMD} -E "s,(/etc/rinetd.conf),${PREFIX}\1," \
${WRKSRC}/rinetd.[8c]