aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2010-01-24 07:25:37 +0800
committermi <mi@FreeBSD.org>2010-01-24 07:25:37 +0800
commitd14befe4bbc0403d31f1d3710d7dbb74f71f3cff (patch)
tree6726f753f822e8ac4d0f927a18b987ebab28daf3 /net
parente24798cc85bdeb62b357942464ab486b22f7d669 (diff)
downloadfreebsd-ports-gnome-d14befe4bbc0403d31f1d3710d7dbb74f71f3cff.tar.gz
freebsd-ports-gnome-d14befe4bbc0403d31f1d3710d7dbb74f71f3cff.tar.zst
freebsd-ports-gnome-d14befe4bbc0403d31f1d3710d7dbb74f71f3cff.zip
Update to rely on USE_TCL API, instead of hardcoding 8.4.
Bump PORTREVISION, because 8.5 is now the default. This became a problem after recent update of x11-toolkits/blt, on which ttt depends. Notified by: pav Clean up pkg-descr a little.
Diffstat (limited to 'net')
-rw-r--r--net/ttt/Makefile15
-rw-r--r--net/ttt/pkg-descr9
2 files changed, 13 insertions, 11 deletions
diff --git a/net/ttt/Makefile b/net/ttt/Makefile
index d40d349ab1d6..cbef0b837f93 100644
--- a/net/ttt/Makefile
+++ b/net/ttt/Makefile
@@ -7,21 +7,24 @@
PORTNAME= ttt
PORTVERSION= 1.8.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net tk ipv6
MASTER_SITES= ftp://ftp.csl.sony.co.jp/pub/kjc/
MAINTAINER= ports@FreeBSD.org
COMMENT= Tele Traffic Tapper, a network traffic monitoring tool
-LIB_DEPENDS= BLT24.3:${PORTSDIR}/x11-toolkits/blt
+LIB_DEPENDS= BLT24:${PORTSDIR}/x11-toolkits/blt
+USE_TK= 84+
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.4 \
- --with-tk=${LOCALBASE}/lib/tk8.4
+CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl${TCL_VER} \
+ --with-tk=${LOCALBASE}/lib/tk${TK_VER}
INSTALL_TARGET= install install-man
MAN1= ttt.1 tttprobe.1 tttview.1
-.include <bsd.port.pre.mk>
+post-configure:
+ ${REINPLACE_CMD} 's|^CFLAGS *=.*|CFLAGS=${CFLAGS}|' \
+ ${WRKSRC}/Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/ttt/pkg-descr b/net/ttt/pkg-descr
index 0cf492107525..25d2086aa995 100644
--- a/net/ttt/pkg-descr
+++ b/net/ttt/pkg-descr
@@ -1,9 +1,6 @@
+ TTT: Tele Traffic Tapper
- TTT: Tele Traffic Tapper (version 1.6)
-
- 2000/12/21
-
-ttt is yet another decendant of tcpdump but it is capable of real-time,
+ttt is yet another descendant of tcpdump but it is capable of real-time,
graphical, and remote traffic-monitoring. ttt won't replace tcpdump,
rather, it helps you find out what to look into with tcpdump.
@@ -14,3 +11,5 @@ Features:
- IPv6 Aware: (experimental)
- Portable
- Easy to customize
+
+WWW: http://www.sonycsl.co.jp/~kjc/software.html#ttt