aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2017-07-19 04:20:43 +0800
committergarga <garga@FreeBSD.org>2017-07-19 04:20:43 +0800
commitd86b790c9c2946b5079c4369a6e56bf3ecf28c08 (patch)
treeea515b1e0db5d5c04b323eda28d584d02a043450 /net
parentcefc0a8177b2b2e8905abd298294329a707ca143 (diff)
downloadfreebsd-ports-gnome-d86b790c9c2946b5079c4369a6e56bf3ecf28c08.tar.gz
freebsd-ports-gnome-d86b790c9c2946b5079c4369a6e56bf3ecf28c08.tar.zst
freebsd-ports-gnome-d86b790c9c2946b5079c4369a6e56bf3ecf28c08.zip
Fix net/haproxy and net/haproxy-devel build on ARM
USE_REGPARM=1 is specific for amd64 and i386. Conditionalize its definition and let the port build on ARM Approved by: demon (maintainer) Obtained from: pfSense MFH: 2017Q3 Sponsored by: Rubicon Communications, LLC (Netgate) Differential Revision: https://reviews.freebsd.org/D11637
Diffstat (limited to 'net')
-rw-r--r--net/haproxy-devel/Makefile10
-rw-r--r--net/haproxy/Makefile6
2 files changed, 13 insertions, 3 deletions
diff --git a/net/haproxy-devel/Makefile b/net/haproxy-devel/Makefile
index f5d82a99ea26..5fa2f6063494 100644
--- a/net/haproxy-devel/Makefile
+++ b/net/haproxy-devel/Makefile
@@ -24,7 +24,7 @@ DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
- USE_ZLIB=1 USE_CPU_AFFINITY=1 USE_REGPARM=1 USE_ACCEPT4=1 \
+ USE_ZLIB=1 USE_CPU_AFFINITY=1 USE_ACCEPT4=1 \
CC="${CC}" DEBUG_CFLAGS="" CPU_CFLAGS="${CFLAGS}"
OPTIONS_DEFINE= DOCS EXAMPLES LUA OPENSSL DEVICEATLAS
@@ -82,4 +82,10 @@ do-install:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${EXAMPLESDIR})
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "i386"
+MAKE_ARGS+= USE_REGPARM=1
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index f4f98a9371fc..bb339027c8a6 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -23,7 +23,7 @@ DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
- USE_ZLIB=1 USE_CPU_AFFINITY=1 USE_REGPARM=1 USE_ACCEPT4=1 \
+ USE_ZLIB=1 USE_CPU_AFFINITY=1 USE_ACCEPT4=1 \
CC="${CC}" DEBUG_CFLAGS="" CPU_CFLAGS="${CFLAGS}"
OPTIONS_DEFINE= DOCS EXAMPLES LUA OPENSSL DEVICEATLAS
@@ -83,6 +83,10 @@ do-install:
.include <bsd.port.pre.mk>
+.if ${ARCH} == "amd64" || ${ARCH} == "i386"
+MAKE_ARGS+= USE_REGPARM=1
+.endif
+
.if ${PORT_OPTIONS:MOPENSSL} && ${SSL_DEFAULT:Mopenssl-devel}
BROKEN= Does not build with openssl-devel
.endif