aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2010-05-22 05:44:44 +0800
committerpgj <pgj@FreeBSD.org>2010-05-22 05:44:44 +0800
commitd938ba775380a1aa87e6735ab3b698d8e78d1296 (patch)
treed6f1378e8480048bdcada3f4062fd437d828f114 /net
parentda348869141464b52929e24085630d3f236e2847 (diff)
downloadfreebsd-ports-gnome-d938ba775380a1aa87e6735ab3b698d8e78d1296.tar.gz
freebsd-ports-gnome-d938ba775380a1aa87e6735ab3b698d8e78d1296.tar.zst
freebsd-ports-gnome-d938ba775380a1aa87e6735ab3b698d8e78d1296.zip
A very simple package providing a cross-platform means of determining
the hostname. WWW: http://hackage.haskell.org/package/hostname
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/hs-hostname/Makefile16
-rw-r--r--net/hs-hostname/distinfo3
-rw-r--r--net/hs-hostname/pkg-descr4
-rw-r--r--net/hs-hostname/pkg-plist14
5 files changed, 38 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 2fe8ce2c0304..f257303bd1c3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -223,6 +223,7 @@
SUBDIR += howl
SUBDIR += hping
SUBDIR += hping-devel
+ SUBDIR += hs-hostname
SUBDIR += hs-pcap
SUBDIR += htpdate
SUBDIR += http_ping
diff --git a/net/hs-hostname/Makefile b/net/hs-hostname/Makefile
new file mode 100644
index 000000000000..0f8d919cde10
--- /dev/null
+++ b/net/hs-hostname/Makefile
@@ -0,0 +1,16 @@
+# New ports collection makefile for: hs-hostname
+# Date created: May 21, 2010
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hostname
+PORTVERSION= 1.0
+CATEGORIES= net haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Cross-platform means of determining the hostname
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/net/hs-hostname/distinfo b/net/hs-hostname/distinfo
new file mode 100644
index 000000000000..0bdc711ed1ae
--- /dev/null
+++ b/net/hs-hostname/distinfo
@@ -0,0 +1,3 @@
+MD5 (hostname-1.0.tar.gz) = 9389c8634239e5d6096ef563e59a703f
+SHA256 (hostname-1.0.tar.gz) = 9b43dab1b6da521f35685b20555da00738c8e136eb972458c786242406a9cf5c
+SIZE (hostname-1.0.tar.gz) = 1982
diff --git a/net/hs-hostname/pkg-descr b/net/hs-hostname/pkg-descr
new file mode 100644
index 000000000000..828c88d112a3
--- /dev/null
+++ b/net/hs-hostname/pkg-descr
@@ -0,0 +1,4 @@
+A very simple package providing a cross-platform means of determining
+the hostname.
+
+WWW: http://hackage.haskell.org/package/hostname
diff --git a/net/hs-hostname/pkg-plist b/net/hs-hostname/pkg-plist
new file mode 100644
index 000000000000..be8e89c330ad
--- /dev/null
+++ b/net/hs-hostname/pkg-plist
@@ -0,0 +1,14 @@
+@comment $FreeBSD$
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Network/HostName.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Network
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
f="https://pypi.org/project/0x-contract-artifacts/">PyPI 0x smart contract compilation artifacts 0x-json-schemas PyPI 0x-related JSON schemas 0x-order-utils PyPI A set of utilities for generating, parsing, signing and validating 0x orders 0x-sra-client PyPI A Python client for interacting with servers conforming to the Standard Relayer API specification

Typescript/Javascript Packages

0x-specific packages

Package Version Description
0x.js npm An aggregate package combining many smaller utility packages for interacting with the 0x protocol
@0x/contract-addresses npm A tiny utility library for getting known deployed contract addresses for a particular network.
@0x/contract-wrappers npm JS/TS wrappers for interacting with the 0x smart contracts
@0x/order-utils npm A set of utilities for generating, parsing, signing and validating 0x orders
@0x/json-schemas npm 0x-related JSON schemas
@0x/order-watcher npm An order watcher daemon that watches for order validity
@0x/migrations npm Migration tool for deploying 0x smart contracts on private testnets
@0x/contract-artifacts npm 0x smart contract compilation artifacts
@0x/abi-gen-wrappers npm Low-level 0x smart contract wrappers generated using @0x/abi-gen
@0x/sra-spec npm OpenAPI specification for the Standard Relayer API
@0x/connect npm An HTTP/WS client for interacting with the Standard Relayer API
@0x/asset-buyer npm Convenience package for discovering and buying assets with Ether

Ethereum tooling

Package Version Description
@0x/web3-wrapper npm An Ethereum JSON RPC client
@dexon-foundation/sol-compiler npm A wrapper around solc-js that adds smart re-compilation, ability to compile an entire project, Solidity version specific compilation, standard input description support and much more.
@dexon-foundation/sol-coverage npm A solidity test coverage tool
@dexon-foundation/sol-profiler npm A solidity gas cost profiler
@0x/sol-trace npm A solidity stack trace tool
@0x/sol-resolver npm Import resolver for smart contracts dependencies
@dexon-foundation/subproviders npm Web3 provider middlewares (e.g. LedgerSubprovider)
@dexon-foundation/sol-doc npm Solidity documentation generator

Utilities

Package Version Description
@0x/abi-gen npm Tool to generate TS wrappers from smart contract ABIs
@0x/tslint-config npm Custom TSLint rules used by the 0x core team
@0x/types npm Shared type declarations
@0x/typescript-typings npm Repository of types for external packages
@0x/utils npm Shared utilities
@0x/react-docs npm React documentation component for rendering TypeDoc & sol-doc generated JSON
@0x/react-shared npm 0x shared react components
@0x/assert npm Type and schema assertions used by our packages
@0x/base-contract npm BaseContract used by auto-generated abi-gen wrapper contracts
@0x/dev-utils npm Dev utils to be shared across 0x packages
@0x/fill-scenarios npm 0x order fill scenario generator

Private Packages

Package Description
@0x/contracts 0x protocol solidity smart contracts & tests
@0x/instant A free and flexible way to offer simple crypto purchasing in any app or website.
@0x/testnet-faucets A faucet micro-service that dispenses test ERC20 tokens or Ether
@0x/website 0x website

Usage

Node version >= 6.12 is required.

Most of the packages require additional typings for external dependencies. You can include those by prepending the @0x/typescript-typings package to your typeRoots config.

"typeRoots": ["node_modules/@0x/typescript-typings/types", "node_modules/@types"],

Contributing

We strongly recommend that the community help us make improvements and determine the future direction of the protocol. To report bugs within this package, please create an issue in this repository.

Read our contribution guidelines.

Install dependencies

Make sure you are using Yarn v1.9.4. To install using brew:

brew install yarn@1.9.4

Then install dependencies

yarn install

Build

To build all packages:

yarn build

To build a specific package:

PKG=@0x/web3-wrapper yarn build

Watch

To re-build all packages on change:

yarn watch

To watch a specific package and all it's dependent packages:

PKG=[NPM_PACKAGE_NAME] yarn watch

e.g
PKG=@0x/web3-wrapper yarn watch

Clean

Clean all packages:

yarn clean

Clean a specific package

PKG=0x.js yarn clean

Rebuild

To re-build (clean & build) all packages:

yarn rebuild

To re-build (clean & build) a specific package & it's deps:

PKG=0x.js yarn rebuild

Lint

Lint all packages:

yarn lint

Lint a specific package:

PKG=0x.js yarn lint

Run Tests

Run all tests:

yarn test

Run a specific package's test:

PKG=@0x/web3-wrapper yarn test