aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-03-28 09:38:47 +0800
committerclsung <clsung@FreeBSD.org>2007-03-28 09:38:47 +0800
commitdad35ec6b27eecff3f111a643a186e8aa30fc508 (patch)
tree6c8d985378d800efb9d339f24685ee41692f4191 /net
parent597ebc22f9be24c37384316abc98b2b247b38054 (diff)
downloadfreebsd-ports-gnome-dad35ec6b27eecff3f111a643a186e8aa30fc508.tar.gz
freebsd-ports-gnome-dad35ec6b27eecff3f111a643a186e8aa30fc508.tar.zst
freebsd-ports-gnome-dad35ec6b27eecff3f111a643a186e8aa30fc508.zip
Add pecl-geoip 0.2.0, map IP address to geographic places.
PR: ports/110798 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/pecl-geoip/Makefile27
-rw-r--r--net/pecl-geoip/distinfo3
-rw-r--r--net/pecl-geoip/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 507d29fe1f6d..0e65d15fbc1a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -593,6 +593,7 @@
SUBDIR += pear-SOAP
SUBDIR += pear-XML_RPC
SUBDIR += pecl-cvsclient
+ SUBDIR += pecl-geoip
SUBDIR += pecl-radius
SUBDIR += pecl-yaz
SUBDIR += pen
diff --git a/net/pecl-geoip/Makefile b/net/pecl-geoip/Makefile
new file mode 100644
index 000000000000..039f20a017e3
--- /dev/null
+++ b/net/pecl-geoip/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: pecl-geoip
+# Date created: 2007-03-25
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= geoip
+PORTVERSION= 0.2.0
+CATEGORIES= net www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Map IP address to geographic places
+
+LIB_DEPENDS= GeoIP:${PORTSDIR}/net/GeoIP
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's/-ldl//g' ${WRKSRC}/config.m4
+
+.include <bsd.port.mk>
diff --git a/net/pecl-geoip/distinfo b/net/pecl-geoip/distinfo
new file mode 100644
index 000000000000..6a930da6eeca
--- /dev/null
+++ b/net/pecl-geoip/distinfo
@@ -0,0 +1,3 @@
+MD5 (geoip/geoip-0.2.0.tgz) = 4784c875e4955f59ca4455c4f562573d
+SHA256 (geoip/geoip-0.2.0.tgz) = bb2d0aee2f1eeaa97066485ec541809f42dd5baf2839742cd6d0efa3454d99dd
+SIZE (geoip/geoip-0.2.0.tgz) = 5661
diff --git a/net/pecl-geoip/pkg-descr b/net/pecl-geoip/pkg-descr
new file mode 100644
index 000000000000..532549e6c314
--- /dev/null
+++ b/net/pecl-geoip/pkg-descr
@@ -0,0 +1,5 @@
+This PHP extension allows you to find the location of an IP address -
+City, State, Country, Longitude, Latitude, and other information as
+all, such as ISP and connection type.
+
+WWW: http://www.maxmind.com/