aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2013-11-01 07:40:29 +0800
committergarga <garga@FreeBSD.org>2013-11-01 07:40:29 +0800
commite0eef30a06b5de74eec40b0ea6f8ceda3a5fa7bb (patch)
tree949b7535550b12ee4e2375ff5281570b781bf977 /net
parent336a623bcff7ba047a2e10a0456c200136858d13 (diff)
downloadfreebsd-ports-gnome-e0eef30a06b5de74eec40b0ea6f8ceda3a5fa7bb.tar.gz
freebsd-ports-gnome-e0eef30a06b5de74eec40b0ea6f8ceda3a5fa7bb.tar.zst
freebsd-ports-gnome-e0eef30a06b5de74eec40b0ea6f8ceda3a5fa7bb.zip
Simplify Makefile
Diffstat (limited to 'net')
-rw-r--r--net/xmlrpc-c/Makefile19
1 files changed, 5 insertions, 14 deletions
diff --git a/net/xmlrpc-c/Makefile b/net/xmlrpc-c/Makefile
index 49dede0ebcc4..62037b9534bb 100644
--- a/net/xmlrpc-c/Makefile
+++ b/net/xmlrpc-c/Makefile
@@ -28,26 +28,17 @@ MAKE_ARGS= LIBTOOL="${LIBTOOL}" \
MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
+CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+CURL_CONFIGURE_ENABLE= curl-client
+LIBWWW_LIB_DEPENDS= libwwwcore.so:${PORTSDIR}/www/libwww
+LIBWWW_CONFIGURE_ENABLE=libwww-client
+
.include <bsd.port.pre.mk>
.if empty(PORT_OPTIONS:MDEBUG)
CFLAGS+= -DNDEBUG
.endif
-.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
-CONFIGURE_ARGS+= --enable-curl-client
-.else
-CONFIGURE_ARGS+= --disable-curl-client
-.endif
-
-.if ${PORT_OPTIONS:MLIBWWW}
-LIB_DEPENDS+= wwwcore:${PORTSDIR}/www/libwww
-CONFIGURE_ARGS+= --enable-libwww-client
-.else
-CONFIGURE_ARGS+= --disable-libwww-client
-.endif
-
post-extract:
@${FIND} ${WRKSRC} -type l -name blddir -delete
@${FIND} ${WRKSRC} -type l -name srcdir -delete