aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-08-26 19:53:19 +0800
committertobik <tobik@FreeBSD.org>2018-08-26 19:53:19 +0800
commite3e564a0cfadaea468f73bb9bc1acd2b08ab064c (patch)
tree721562958d2855229c5a654bf51695fd7536a098 /net
parent3e48645f7145833a7f3d9cbe9ef11f1f9ae6cefd (diff)
downloadfreebsd-ports-gnome-e3e564a0cfadaea468f73bb9bc1acd2b08ab064c.tar.gz
freebsd-ports-gnome-e3e564a0cfadaea468f73bb9bc1acd2b08ab064c.tar.zst
freebsd-ports-gnome-e3e564a0cfadaea468f73bb9bc1acd2b08ab064c.zip
net/latd: Fix build with Clang 6
llogin.cc:233:25: error: non-constant-expression cannot be narrowed from type 'int' to 'char' in initializer list [-Wc++11-narrowing] char verboseflag[1] = {verbose}; ^~~~~~~ http://beefy11.nyi.freebsd.org/data/head-i386-default/p477696_s338122/logs/latd-1.31.log interfaces-bpf.cc:68:38: error: non-constant-expression cannot be narrowed from type 'long' to 'bpf_u_int32' (aka 'unsigned int') in initializer list [-Wc++11-narrowing] BPF_STMT(BPF_LD + BPF_H + BPF_ABS, LATD_OFFSETOF(struct ether_header, ether_type)), ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ interfaces-bpf.cc:62:29: note: expanded from macro 'LATD_OFFSETOF' #define LATD_OFFSETOF(t, m) (((char *) &(((t *) NULL)-> m)) - ((char *) ((t *) NULL))) ^
Diffstat (limited to 'net')
-rw-r--r--net/latd/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/latd/Makefile b/net/latd/Makefile
index 33d14127b9cb..a9644405a4c6 100644
--- a/net/latd/Makefile
+++ b/net/latd/Makefile
@@ -11,9 +11,12 @@ COMMENT= Linux-DECnet project LAT protocol suite
LICENSE= GPLv2
-USES= alias
+USES= alias compiler
GNU_CONFIGURE= yes
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
+
PLIST_FILES= bin/llogin etc/latd.conf.sample \
man/man1/llogin.1.gz man/man5/latd.conf.5.gz \
man/man8/latd.8.gz man/man8/latcp.8.gz man/man8/moprc.8.gz \