aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-09-23 20:28:37 +0800
committerlinimon <linimon@FreeBSD.org>2018-09-23 20:28:37 +0800
commitec580729a17e07a9e8bcaeab4aceb11575f749f3 (patch)
tree41ef8e56e26e32644f78b844ed74cdb02e54da8b /net
parent1edd9b33bf1a98f4283284d68c5e76c540115d63 (diff)
downloadfreebsd-ports-gnome-ec580729a17e07a9e8bcaeab4aceb11575f749f3.tar.gz
freebsd-ports-gnome-ec580729a17e07a9e8bcaeab4aceb11575f749f3.tar.zst
freebsd-ports-gnome-ec580729a17e07a9e8bcaeab4aceb11575f749f3.zip
Fix build on gcc-based archs.
Tested on powerpc64 and amd64. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'net')
-rw-r--r--net/liferea/Makefile4
-rw-r--r--net/reaver/Makefile2
2 files changed, 2 insertions, 4 deletions
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index f752ece191b4..1277f7dcdf60 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -11,8 +11,6 @@ COMMENT= Simple RSS/RDF feed reader
LICENSE= GPLv2
-BROKEN_powerpc64= fails to compile: WebKitWebEditor.h:40: redefinition of typedef 'WebKitWebEditor'
-
BUILD_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
@@ -21,7 +19,7 @@ LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
RUN_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas \
${PYTHON_PKGNAMEPREFIX}libpeas>=0:devel/py-libpeas@${PY_FLAVOR}
-USES= desktop-file-utils gettext gmake gnome libtool localbase \
+USES= compiler:c++11-lang desktop-file-utils gettext gmake gnome libtool localbase \
pathfix pkgconfig python:3.4+ sqlite tar:bzip2
USE_GNOME= cairo dconf:run gtk30 intltool introspection \
libxslt libxml2
diff --git a/net/reaver/Makefile b/net/reaver/Makefile
index 0345e8674eeb..83022ff4fa32 100644
--- a/net/reaver/Makefile
+++ b/net/reaver/Makefile
@@ -11,7 +11,7 @@ COMMENT= Reaver brute force attack against WPS (Wi-Fi Protected Setup)
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/../docs/LICENSE
-USES= gmake
+USES= compiler:c++11-lang gmake
GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= t6x