aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2012-05-12 04:38:09 +0800
committerade <ade@FreeBSD.org>2012-05-12 04:38:09 +0800
commitec81fd924ccfa4a135be31e8f27887286828c2de (patch)
treec4bd2f8529e840fa116e09d1f68e442cc7f2ce0c /net
parent497d7e487cb4abc3d85b201fc1bd72c134effbd4 (diff)
downloadfreebsd-ports-gnome-ec81fd924ccfa4a135be31e8f27887286828c2de.tar.gz
freebsd-ports-gnome-ec81fd924ccfa4a135be31e8f27887286828c2de.tar.zst
freebsd-ports-gnome-ec81fd924ccfa4a135be31e8f27887286828c2de.zip
Update autoconf to 2.69 and automake to 1.12
PR: 166836 Tested by: Multiple -exp runs (pav)
Diffstat (limited to 'net')
-rw-r--r--net/enet/Makefile10
-rw-r--r--net/msend/files/patch-Makefile.am6
-rw-r--r--net/msend/files/patch-configure.in6
-rw-r--r--net/ntp-devel/Makefile6
-rw-r--r--net/ntp/Makefile6
-rw-r--r--net/openvswitch/Makefile7
6 files changed, 40 insertions, 1 deletions
diff --git a/net/enet/Makefile b/net/enet/Makefile
index 386846dd214d..81a0106783f0 100644
--- a/net/enet/Makefile
+++ b/net/enet/Makefile
@@ -15,11 +15,19 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Simple and robust communication library based on UDP
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= automake
+USE_AUTOTOOLS= automake autoconf:env
USE_LDCONFIG= yes
DOCS= design.txt docs/FAQ.dox docs/design.dox docs/tutorial.dox
+
+AUTOTOOLSFILES= aclocal.m4
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|1.11.1|%%AUTOMAKE_APIVER%%|g' \
+ -e 's|2.67|%%AUTOCONF_VERSION%%|g' \
+ ${WRKSRC}/aclocal.m4
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/net/msend/files/patch-Makefile.am b/net/msend/files/patch-Makefile.am
new file mode 100644
index 000000000000..4b48599ad1e3
--- /dev/null
+++ b/net/msend/files/patch-Makefile.am
@@ -0,0 +1,6 @@
+--- Makefile.am.orig 1999-05-02 19:01:04.000000000 -0700
++++ Makefile.am 2012-05-03 16:56:22.000000000 -0700
+@@ -1,3 +1 @@
+-AUTOMAKE_OPTIONS = ansi2knr
+-
+ bin_PROGRAMS = msend
diff --git a/net/msend/files/patch-configure.in b/net/msend/files/patch-configure.in
new file mode 100644
index 000000000000..012646095595
--- /dev/null
+++ b/net/msend/files/patch-configure.in
@@ -0,0 +1,6 @@
+--- configure.in.orig 1999-05-02 05:58:01.000000000 -0700
++++ configure.in 2012-05-03 16:53:21.000000000 -0700
+@@ -17,3 +17,2 @@
+ dnl Checks for typedefs, structures, and compiler characteristics.
+-AM_C_PROTOTYPES
+ AC_C_CONST
diff --git a/net/ntp-devel/Makefile b/net/ntp-devel/Makefile
index f045efecf6d2..7cdc433923a6 100644
--- a/net/ntp-devel/Makefile
+++ b/net/ntp-devel/Makefile
@@ -77,6 +77,12 @@ MAN8+= ntpsnmpd.8
PLIST_SUB+= NETSNMP="@comment "
.endif
+AUTOTOOLSFILES= aclocal.m4
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|1.11.1|%%AUTOMAKE_APIVER%%|g' \
+ ${WRKSRC}/aclocal.m4
+
post-install:
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/conf/* ${EXAMPLESDIR}
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index 2d83f816b3cb..b4e038bbd9f1 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -61,6 +61,12 @@ CONFIGURE_ARGS+= --enable-${D}
.endif
.endfor
+AUTOTOOLSFILES= aclocal.m4
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|1.11.1|%%AUTOMAKE_APIVER%%|g' \
+ ${WRKSRC}/aclocal.m4
+
post-install:
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/conf/* ${EXAMPLESDIR}
diff --git a/net/openvswitch/Makefile b/net/openvswitch/Makefile
index 3868229e013d..028c374a193b 100644
--- a/net/openvswitch/Makefile
+++ b/net/openvswitch/Makefile
@@ -42,6 +42,13 @@ MAN8= ovs-appctl.8 ovs-controller.8 ovs-discover.8 ovs-dpctl.8 \
BROKEN= does not compile
.endif
+AUTOTOOLSFILES= aclocal.m4
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|1.11.1|%%AUTOMAKE_APIVER%%|g' \
+ -e 's|2.65|%%AUTOCONF_VERSION%%|g' \
+ ${WRKSRC}/aclocal.m4
+
post-install:
${INSTALL_DATA} ${WRKSRC}/vswitchd/vswitch.ovsschema ${PREFIX}/share/openvswitch/