aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2010-04-23 06:04:22 +0800
committerrene <rene@FreeBSD.org>2010-04-23 06:04:22 +0800
commitf3d854df1e711a63345a179c565567997320f3e8 (patch)
treea4cb51d9dc0a8c4c5e46aa4068da1ff9dd86130d /net
parent59930ffe445eb16dd8c83d724e7b60a167fb32de (diff)
downloadfreebsd-ports-gnome-f3d854df1e711a63345a179c565567997320f3e8.tar.gz
freebsd-ports-gnome-f3d854df1e711a63345a179c565567997320f3e8.tar.zst
freebsd-ports-gnome-f3d854df1e711a63345a179c565567997320f3e8.zip
Add babeld 0.98, a distance-vector routing protocol.
PR: ports/145861 Submitted by: Hung-Yi Chen <gaod at hychen.org> Approved by: tabthorpe (mentor)
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/babeld/Makefile20
-rw-r--r--net/babeld/distinfo3
-rw-r--r--net/babeld/files/patch-Makefile42
-rw-r--r--net/babeld/files/patch-util.c10
-rw-r--r--net/babeld/pkg-descr8
6 files changed, 84 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index adfb7c5c19f6..5ca10d751dc7 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -47,6 +47,7 @@
SUBDIR += avahi-qt4
SUBDIR += avahi-sharp
SUBDIR += b2bua
+ SUBDIR += babeld
SUBDIR += balance
SUBDIR += bbsnet
SUBDIR += bcusdk-eibd
diff --git a/net/babeld/Makefile b/net/babeld/Makefile
new file mode 100644
index 000000000000..3ca5d8a5b0c4
--- /dev/null
+++ b/net/babeld/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: babeld
+# Date created: 2010-04-20
+# Whom: Hung-Yi Chen <gaod@hychen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= babeld
+PORTVERSION= 0.98
+CATEGORIES= net
+MASTER_SITES= http://www.pps.jussieu.fr/~jch/software/files/
+
+MAINTAINER= gaod@hychen.org
+COMMENT= A distance-vector routing protocol
+
+PLIST_FILES= bin/babeld
+
+MAN8= babeld.8
+
+.include <bsd.port.mk>
diff --git a/net/babeld/distinfo b/net/babeld/distinfo
new file mode 100644
index 000000000000..37fd9bc43dcc
--- /dev/null
+++ b/net/babeld/distinfo
@@ -0,0 +1,3 @@
+MD5 (babeld-0.98.tar.gz) = 85af76e90914b82d9ece497e15df252f
+SHA256 (babeld-0.98.tar.gz) = 92af70126fe48e8d553475c155c7098b4d3037e31bbe9cf9c48adb04ead007ad
+SIZE (babeld-0.98.tar.gz) = 59007
diff --git a/net/babeld/files/patch-Makefile b/net/babeld/files/patch-Makefile
new file mode 100644
index 000000000000..fb7cdd699e8e
--- /dev/null
+++ b/net/babeld/files/patch-Makefile
@@ -0,0 +1,42 @@
+--- Makefile.orig 2010-02-09 01:42:25.000000000 +0800
++++ Makefile 2010-04-21 17:35:52.000000000 +0800
+@@ -1,12 +1,8 @@
+-PREFIX = /usr/local
+-
+-CDEBUGFLAGS = -Os -g -Wall
++CDEBUGFLAGS = -O2 -Wall
+
+ DEFINES = $(PLATFORM_DEFINES)
+
+-CFLAGS = $(CDEBUGFLAGS) $(DEFINES) $(EXTRA_DEFINES)
+-
+-LDLIBS = -lrt
++CFLAGS = $(CDEBUGFLAGS) $(DEFINES) $(EXTRA_DEFINES) -D__APPLE__
+
+ SRCS = babeld.c net.c kernel.c util.c network.c source.c neighbour.c \
+ route.c xroute.c message.c resend.c config.c local.c
+@@ -15,7 +11,7 @@
+ route.o xroute.o message.o resend.o config.o local.o
+
+ babeld: $(OBJS)
+- $(CC) $(CFLAGS) $(LDFLAGS) -o babeld $(OBJS) $(LDLIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o babeld $(OBJS)
+
+ .SUFFIXES: .man .html
+
+@@ -33,13 +29,10 @@
+ all: babeld babeld.man
+
+ install.minimal: babeld
+- -rm -f $(TARGET)$(PREFIX)/bin/babeld
+- mkdir -p $(TARGET)$(PREFIX)/bin
+- cp -f babeld $(TARGET)$(PREFIX)/bin
++ cp -f babeld $(PREFIX)/bin
+
+ install: install.minimal all
+- mkdir -p $(TARGET)$(PREFIX)/man/man8
+- cp -f babeld.man $(TARGET)$(PREFIX)/man/man8/babeld.8
++ cp -f babeld.man $(PREFIX)/man/man8/babeld.8
+
+ uninstall:
+ -rm -f $(TARGET)$(PREFIX)/bin/babeld
diff --git a/net/babeld/files/patch-util.c b/net/babeld/files/patch-util.c
new file mode 100644
index 000000000000..c5293bcc4d43
--- /dev/null
+++ b/net/babeld/files/patch-util.c
@@ -0,0 +1,10 @@
+--- util.c.orig 2010-04-20 05:48:52.000000000 +0800
++++ util.c 2010-04-20 05:49:28.000000000 +0800
+@@ -31,6 +31,7 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
++#include <netinet/in.h>
+
+ #include "babeld.h"
+ #include "util.h"
diff --git a/net/babeld/pkg-descr b/net/babeld/pkg-descr
new file mode 100644
index 000000000000..86f9bbfcfcc2
--- /dev/null
+++ b/net/babeld/pkg-descr
@@ -0,0 +1,8 @@
+Babel is a distance-vector routing protocol for
+IPv6 and IPv4 with fast convergence properties.
+It is based on the ideas in DSDV, AODV and
+Cisco's EIGRP, but uses a variant of ETX
+link cost estimation rather than a simple
+hop-count metric.
+
+WWW: http://www.pps.jussieu.fr/~jch/software/babel/