aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-06-22 00:55:26 +0800
committerdinoex <dinoex@FreeBSD.org>2002-06-22 00:55:26 +0800
commitf48092743067ff9e6a11f496870e1317b21dffec (patch)
tree84d9a2786b65d6e29600251ce653c29b0c2536e5 /net
parent1f4a3d74fb77ddd155fc32336d85bfec9f878374 (diff)
downloadfreebsd-ports-gnome-f48092743067ff9e6a11f496870e1317b21dffec.tar.gz
freebsd-ports-gnome-f48092743067ff9e6a11f496870e1317b21dffec.tar.zst
freebsd-ports-gnome-f48092743067ff9e6a11f496870e1317b21dffec.zip
Drop PERL for SED
Diffstat (limited to 'net')
-rw-r--r--net/crescendo/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/net/crescendo/Makefile b/net/crescendo/Makefile
index 010232eb3152..0b44a4963bb2 100644
--- a/net/crescendo/Makefile
+++ b/net/crescendo/Makefile
@@ -25,11 +25,15 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CFLAGS+= -g
PLIST_SUB= DOCDIR=share/doc/${PORTNAME}
+MODIFY= Makefile.in data/Makefile.in
pre-patch:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(prefix\)/share/|\$\(datadir\)/|g'
+.for i in ${MODIFY}
+ @${MV} ${WRKSRC}/${i} ${WRKSRC}/${i}.sed
+ ${SED} -e 's=$$(datadir)/gnome/=$$(datadir)/=g' \
+ -e 's=$$(prefix)/share/=$$(datadir)/=g' \
+ ${WRKSRC}/${i}.sed > ${WRKSRC}/${i}
+.endfor
post-install:
.if !defined(NOPORTDOCS)