aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-09-08 08:45:08 +0800
committerlinimon <linimon@FreeBSD.org>2007-09-08 08:45:08 +0800
commit07d9e093a64a0c7f96ed0775d50e0f818d98fd80 (patch)
tree02dbbd994569afd4c5091886b42b9fc57a56da98 /net
parent19b5365f6b139c7191946e258da022ec68b68aae (diff)
downloadfreebsd-ports-gnome-07d9e093a64a0c7f96ed0775d50e0f818d98fd80.tar.gz
freebsd-ports-gnome-07d9e093a64a0c7f96ed0775d50e0f818d98fd80.tar.zst
freebsd-ports-gnome-07d9e093a64a0c7f96ed0775d50e0f818d98fd80.zip
Remove support for antique perl.
Hat: portmgr
Diffstat (limited to 'net')
-rw-r--r--net/p5-IO-INET6/Makefile7
-rw-r--r--net/p5-IO-INET6/files/5.005_03.diff32
-rw-r--r--net/p5-IO-Socket-INET6/Makefile7
-rw-r--r--net/p5-IO-Socket-INET6/files/5.005_03.diff32
4 files changed, 2 insertions, 76 deletions
diff --git a/net/p5-IO-INET6/Makefile b/net/p5-IO-INET6/Makefile
index 0f885107c300..41e53ea21a2b 100644
--- a/net/p5-IO-INET6/Makefile
+++ b/net/p5-IO-INET6/Makefile
@@ -23,10 +23,5 @@ MAN3= IO::Socket::INET6.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-EXTRA_PATCHES= ${PATCHDIR}/5.005_03.diff
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-IO-INET6/files/5.005_03.diff b/net/p5-IO-INET6/files/5.005_03.diff
deleted file mode 100644
index 10dc9fa57dae..000000000000
--- a/net/p5-IO-INET6/files/5.005_03.diff
+++ /dev/null
@@ -1,32 +0,0 @@
-
-$FreeBSD$
-
---- INET6.pm.orig
-+++ INET6.pm
-@@ -10,7 +10,7 @@
- package IO::Socket::INET6;
-
- use strict;
--our(@ISA, $VERSION);
-+use vars qw(@ISA $VERSION);
- use IO::Socket;
- use Socket;
- use Socket6;
-@@ -22,7 +22,7 @@
- $VERSION = "2.51";
- #Purpose: allow protocol independent protocol and original interface.
-
--my $EINVAL = exists(&Errno::EINVAL) ? Errno::EINVAL() : 1;
-+my $EINVAL = defined(&Errno::EINVAL) ? Errno::EINVAL() : 1;
-
- IO::Socket::INET6->register_domain( AF_INET6 );
-
-@@ -190,7 +190,7 @@
- }
-
- if ($arg->{ReusePort}) {
-- $sock->sockopt(SO_REUSEPORT,1) or
-+ $sock->sockopt(0x0200,1) or
- return _error($sock, $!, "sockopt: $!");
- }
-
diff --git a/net/p5-IO-Socket-INET6/Makefile b/net/p5-IO-Socket-INET6/Makefile
index 0f885107c300..41e53ea21a2b 100644
--- a/net/p5-IO-Socket-INET6/Makefile
+++ b/net/p5-IO-Socket-INET6/Makefile
@@ -23,10 +23,5 @@ MAN3= IO::Socket::INET6.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-EXTRA_PATCHES= ${PATCHDIR}/5.005_03.diff
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-IO-Socket-INET6/files/5.005_03.diff b/net/p5-IO-Socket-INET6/files/5.005_03.diff
deleted file mode 100644
index 10dc9fa57dae..000000000000
--- a/net/p5-IO-Socket-INET6/files/5.005_03.diff
+++ /dev/null
@@ -1,32 +0,0 @@
-
-$FreeBSD$
-
---- INET6.pm.orig
-+++ INET6.pm
-@@ -10,7 +10,7 @@
- package IO::Socket::INET6;
-
- use strict;
--our(@ISA, $VERSION);
-+use vars qw(@ISA $VERSION);
- use IO::Socket;
- use Socket;
- use Socket6;
-@@ -22,7 +22,7 @@
- $VERSION = "2.51";
- #Purpose: allow protocol independent protocol and original interface.
-
--my $EINVAL = exists(&Errno::EINVAL) ? Errno::EINVAL() : 1;
-+my $EINVAL = defined(&Errno::EINVAL) ? Errno::EINVAL() : 1;
-
- IO::Socket::INET6->register_domain( AF_INET6 );
-
-@@ -190,7 +190,7 @@
- }
-
- if ($arg->{ReusePort}) {
-- $sock->sockopt(SO_REUSEPORT,1) or
-+ $sock->sockopt(0x0200,1) or
- return _error($sock, $!, "sockopt: $!");
- }
-