aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-08-26 21:12:33 +0800
committermat <mat@FreeBSD.org>2004-08-26 21:12:33 +0800
commit0bfda3dbd7e65d37d6be017e42c9b1ca17afb5fb (patch)
treeb66ea072a1e74096cdd391ab99a864e09ae2e0b9 /net
parent164d9cc93f9d29234abfeeeacea2ce21831de825 (diff)
downloadfreebsd-ports-gnome-0bfda3dbd7e65d37d6be017e42c9b1ca17afb5fb.tar.gz
freebsd-ports-gnome-0bfda3dbd7e65d37d6be017e42c9b1ca17afb5fb.tar.zst
freebsd-ports-gnome-0bfda3dbd7e65d37d6be017e42c9b1ca17afb5fb.zip
Add php4-rrdtool 1.05, a php/rrdtool glue.
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/php4-rrdtool/Makefile27
-rw-r--r--net/php4-rrdtool/distinfo2
-rw-r--r--net/php4-rrdtool/pkg-descr5
4 files changed, 35 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index be2b21f3f6b9..80420978d8b3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -526,6 +526,7 @@
SUBDIR += pfinger
SUBDIR += phex
SUBDIR += php4-ldap
+ SUBDIR += php4-rrdtool
SUBDIR += php4-sockets
SUBDIR += php4-xmlrpc
SUBDIR += php4-yp
diff --git a/net/php4-rrdtool/Makefile b/net/php4-rrdtool/Makefile
new file mode 100644
index 000000000000..252ea76043ca
--- /dev/null
+++ b/net/php4-rrdtool/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: php4-rrdtool
+# Date created: 26 Aug 2004
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= rrdtool
+PORTVERSION= 1.05
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_LOCAL} http://www.joeym.net/
+MASTER_SITE_SUBDIR= mat
+PKGNAMEPREFIX= php4-
+DISTNAME= ${UNIQUENAME}-${PORTVERSION}
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= A php/rrdtool glue
+
+LIB_DEPENDS= rrd:${PORTSDIR}/net/rrdtool
+
+GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${UNIQUENAME}-${PORTVERSION}
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+.include <bsd.port.mk>
diff --git a/net/php4-rrdtool/distinfo b/net/php4-rrdtool/distinfo
new file mode 100644
index 000000000000..70bce219049b
--- /dev/null
+++ b/net/php4-rrdtool/distinfo
@@ -0,0 +1,2 @@
+MD5 (php4-rrdtool-1.05.tar.gz) = 17816fc591c38135e81856e143aaab6f
+SIZE (php4-rrdtool-1.05.tar.gz) = 293555
diff --git a/net/php4-rrdtool/pkg-descr b/net/php4-rrdtool/pkg-descr
new file mode 100644
index 000000000000..efa020570b1f
--- /dev/null
+++ b/net/php4-rrdtool/pkg-descr
@@ -0,0 +1,5 @@
+Contained herein are bindings to allow you to interface php scripts with RRD
+tool directly via RRD tool's 'librrd' library, thus avoiding the need to use
+system() calls to the rrdtool binary.
+
+WWW: http://www.joeym.net/