aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authormarkus <markus@FreeBSD.org>2006-04-03 16:23:08 +0800
committermarkus <markus@FreeBSD.org>2006-04-03 16:23:08 +0800
commit0e599ec1002378059219227863ba110b51c0969d (patch)
tree5d38ab3f2b10f1475cfa0d41a9f13736f3a4bed0 /net
parent90625cb75d7a1304edb8366a06626f5efc8dd212 (diff)
downloadfreebsd-ports-gnome-0e599ec1002378059219227863ba110b51c0969d.tar.gz
freebsd-ports-gnome-0e599ec1002378059219227863ba110b51c0969d.tar.zst
freebsd-ports-gnome-0e599ec1002378059219227863ba110b51c0969d.zip
- Update to version 0.4.0
- Use MASTER_SITE_LOCAL to provide an own distfile, since the original one was created with unsermake. Apart from the buildsystem there are no changes. - Change WWW in pkg-descr to point to the new projectsite
Diffstat (limited to 'net')
-rw-r--r--net/knemo-kde4/Makefile8
-rw-r--r--net/knemo-kde4/distinfo6
-rw-r--r--net/knemo-kde4/files/patch-kcm-configdialog.cpp14
-rw-r--r--net/knemo-kde4/files/patch-knemod-global.h (renamed from net/knemo-kde4/files/patch-knemod-data.h)12
-rw-r--r--net/knemo-kde4/files/patch-knemod-interfacestatusdialog.cpp8
-rw-r--r--net/knemo-kde4/files/patch-knemod-interfacestatusdlg.ui17
-rw-r--r--net/knemo-kde4/files/patch-knemod-interfacetooltip.cpp8
-rw-r--r--net/knemo-kde4/files/patch-knemod-interfaceupdater.cpp30
-rw-r--r--net/knemo-kde4/pkg-descr2
-rw-r--r--net/knemo-kde4/pkg-plist62
-rw-r--r--net/knemo/Makefile8
-rw-r--r--net/knemo/distinfo6
-rw-r--r--net/knemo/files/patch-kcm-configdialog.cpp14
-rw-r--r--net/knemo/files/patch-knemod-global.h (renamed from net/knemo/files/patch-knemod-data.h)12
-rw-r--r--net/knemo/files/patch-knemod-interfacestatusdialog.cpp8
-rw-r--r--net/knemo/files/patch-knemod-interfacestatusdlg.ui17
-rw-r--r--net/knemo/files/patch-knemod-interfacetooltip.cpp8
-rw-r--r--net/knemo/files/patch-knemod-interfaceupdater.cpp30
-rw-r--r--net/knemo/pkg-descr2
-rw-r--r--net/knemo/pkg-plist62
20 files changed, 188 insertions, 146 deletions
diff --git a/net/knemo-kde4/Makefile b/net/knemo-kde4/Makefile
index 97deff7875bc..6a85dbc62a10 100644
--- a/net/knemo-kde4/Makefile
+++ b/net/knemo-kde4/Makefile
@@ -5,16 +5,14 @@
# $FreeBSD$
PORTNAME= knemo
-PORTVERSION= 0.3.1
-PORTREVISION= 4
+PORTVERSION= 0.4.0
CATEGORIES= net kde
-MASTER_SITES= http://www.eris23.de/knemo/
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= markus
MAINTAINER= markus@FreeBSD.org
COMMENT= Network monitor for KDE
-EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
-
USE_BZIP2= yes
USE_KDELIBS_VER=3
USE_GMAKE= yes
diff --git a/net/knemo-kde4/distinfo b/net/knemo-kde4/distinfo
index 2ce1cdb21878..5942c79f4203 100644
--- a/net/knemo-kde4/distinfo
+++ b/net/knemo-kde4/distinfo
@@ -1,3 +1,3 @@
-MD5 (knemo-0.3.1.tar.bz2) = 774b7b085e7b2d492bf811d7f89cee6e
-SHA256 (knemo-0.3.1.tar.bz2) = 66874172760eeab4d68ea9533db96f408ce3d9af6a5c07d45906092d0b4bdbef
-SIZE (knemo-0.3.1.tar.bz2) = 549018
+MD5 (knemo-0.4.0.tar.bz2) = 5fc147c23b5342d26ca74a03881829e0
+SHA256 (knemo-0.4.0.tar.bz2) = 3b07e892878433dbfbb5f8ff932a82fbafa85d4935dc8008f3446d297208830c
+SIZE (knemo-0.4.0.tar.bz2) = 899310
diff --git a/net/knemo-kde4/files/patch-kcm-configdialog.cpp b/net/knemo-kde4/files/patch-kcm-configdialog.cpp
index d8285d4fe55f..32a00999bf67 100644
--- a/net/knemo-kde4/files/patch-kcm-configdialog.cpp
+++ b/net/knemo-kde4/files/patch-kcm-configdialog.cpp
@@ -1,7 +1,7 @@
---- kcm/configdialog.cpp.orig Wed Sep 15 18:24:37 2004
-+++ kcm/configdialog.cpp Wed Jan 19 15:23:57 2005
+--- src/kcm/configdialog.cpp.orig Sat Apr 1 21:44:21 2006
++++ src/kcm/configdialog.cpp Sun Apr 2 19:14:11 2006
@@ -17,6 +17,16 @@
- Boston, MA 02111-1307, USA.
+ Boston, MA 02110-1301, USA.
*/
+#ifdef __FreeBSD__
@@ -17,7 +17,7 @@
#include <qfile.h>
#include <qdict.h>
#include <qlabel.h>
-@@ -355,6 +365,39 @@
+@@ -363,6 +373,39 @@
void ConfigDialog::defaults()
{
// Default interfaces
@@ -57,7 +57,7 @@
QFile proc( "/proc/net/dev" );
if ( proc.open( IO_ReadOnly ) )
{
-@@ -372,6 +415,7 @@
+@@ -380,6 +423,7 @@
if ( interface == "lo" )
continue;
@@ -65,8 +65,8 @@
InterfaceSettings* settings = new InterfaceSettings();
settings->customCommands = false;
settings->hideWhenNotAvailable = false;
-@@ -391,8 +435,10 @@
- mDlg->checkBoxNotExisting->setChecked( false );
+@@ -401,8 +445,10 @@
+ mDlg->checkBoxStatistics->setChecked( false );
mDlg->checkBoxCustom->setChecked( false );
}
+#ifndef __FreeBSD__
diff --git a/net/knemo-kde4/files/patch-knemod-data.h b/net/knemo-kde4/files/patch-knemod-global.h
index c45f8b191029..b20cda0a6a99 100644
--- a/net/knemo-kde4/files/patch-knemod-data.h
+++ b/net/knemo-kde4/files/patch-knemod-global.h
@@ -1,14 +1,14 @@
---- knemod/data.h.orig Sat Jan 22 00:10:05 2005
-+++ knemod/data.h Fri Jan 21 17:38:50 2005
+--- src/knemod/global.h.orig Sat Apr 1 21:44:22 2006
++++ src/knemod/global.h Sun Apr 2 21:33:36 2006
@@ -22,6 +22,7 @@
#include <qpair.h>
#include <qcolor.h>
+#include <qdict.h>
#include <qstring.h>
- #include <qvaluevector.h>
-@@ -41,6 +42,11 @@
+ /**
+@@ -36,6 +37,11 @@
int toolTipContent;
};
@@ -19,8 +19,8 @@
+
struct InterfaceData
{
- InterfaceData::InterfaceData()
-@@ -64,11 +70,9 @@
+ InterfaceData()
+@@ -59,11 +65,9 @@
unsigned long prevTxBytes;
unsigned long incomingBytes;
unsigned long outgoingBytes;
diff --git a/net/knemo-kde4/files/patch-knemod-interfacestatusdialog.cpp b/net/knemo-kde4/files/patch-knemod-interfacestatusdialog.cpp
index 822857eff083..217998e0b9f2 100644
--- a/net/knemo-kde4/files/patch-knemod-interfacestatusdialog.cpp
+++ b/net/knemo-kde4/files/patch-knemod-interfacestatusdialog.cpp
@@ -1,5 +1,5 @@
---- knemod/interfacestatusdialog.cpp.orig Sat Jan 22 00:11:02 2005
-+++ knemod/interfacestatusdialog.cpp Sat Jan 22 00:15:24 2005
+--- src/knemod/interfacestatusdialog.cpp.orig Sat Apr 1 21:44:22 2006
++++ src/knemod/interfacestatusdialog.cpp Sun Apr 2 21:34:55 2006
@@ -24,6 +24,7 @@
#include <qtabwidget.h>
@@ -8,7 +8,7 @@
#include <kconfig.h>
#include <klocale.h>
#include <kglobal.h>
-@@ -69,6 +70,10 @@
+@@ -92,6 +93,10 @@
mTimer = new QTimer();
connect( mTimer, SIGNAL( timeout() ), this, SLOT( updateDialog() ) );
mTimer->start( 1000 );
@@ -19,7 +19,7 @@
}
InterfaceStatusDialog::~InterfaceStatusDialog()
-@@ -152,12 +157,28 @@
+@@ -201,12 +206,28 @@
if ( data.available )
{
// ip tab
diff --git a/net/knemo-kde4/files/patch-knemod-interfacestatusdlg.ui b/net/knemo-kde4/files/patch-knemod-interfacestatusdlg.ui
index d506e3f44a0f..073ca19a3734 100644
--- a/net/knemo-kde4/files/patch-knemod-interfacestatusdlg.ui
+++ b/net/knemo-kde4/files/patch-knemod-interfacestatusdlg.ui
@@ -1,14 +1,5 @@
---- knemod/interfacestatusdlg.ui.orig Fri Jan 21 16:57:24 2005
-+++ knemod/interfacestatusdlg.ui Fri Jan 21 20:02:50 2005
-@@ -9,7 +9,7 @@
- <x>0</x>
- <y>0</y>
- <width>272</width>
-- <height>258</height>
-+ <height>237</height>
- </rect>
- </property>
- <property name="caption">
+--- src/knemod/interfacestatusdlg.ui.orig Sat Apr 1 21:44:22 2006
++++ src/knemod/interfacestatusdlg.ui Sun Apr 2 21:28:01 2006
@@ -145,7 +145,7 @@
</property>
<widget class="QLayoutWidget">
@@ -248,7 +239,7 @@
</widget>
</hbox>
</widget>
-@@ -728,8 +676,6 @@
+@@ -893,8 +841,6 @@
</widget>
</vbox>
</widget>
@@ -257,7 +248,7 @@
<connections>
<connection>
<sender>buttonClose</sender>
-@@ -740,10 +686,6 @@
+@@ -905,10 +851,6 @@
</connections>
<layoutdefaults spacing="6" margin="11"/>
<includehints>
diff --git a/net/knemo-kde4/files/patch-knemod-interfacetooltip.cpp b/net/knemo-kde4/files/patch-knemod-interfacetooltip.cpp
index 10235e4477c3..9dce92066cf6 100644
--- a/net/knemo-kde4/files/patch-knemod-interfacetooltip.cpp
+++ b/net/knemo-kde4/files/patch-knemod-interfacetooltip.cpp
@@ -1,6 +1,6 @@
---- knemod/interfacetooltip.cpp.orig Fri Jan 21 17:51:13 2005
-+++ knemod/interfacetooltip.cpp Fri Jan 21 17:59:47 2005
-@@ -99,6 +99,23 @@
+--- src/knemod/interfacetooltip.cpp.orig Sat Apr 1 21:44:22 2006
++++ src/knemod/interfacetooltip.cpp Sun Apr 2 21:30:52 2006
+@@ -101,6 +101,23 @@
if ( data.available )
{
@@ -24,7 +24,7 @@
if ( toolTipContent & IP_ADDRESS )
text += "<tr><td>" + mToolTips[4].first + "</td><td>" + data.ipAddress + "</td></tr>";
if ( toolTipContent & SUBNET_MASK )
-@@ -107,6 +124,7 @@
+@@ -109,6 +126,7 @@
{
if ( toolTipContent & BCAST_ADDRESS )
text += "<tr><td>" + mToolTips[18].first + "</td><td>" + data.broadcastAddress + "</td></tr>";
diff --git a/net/knemo-kde4/files/patch-knemod-interfaceupdater.cpp b/net/knemo-kde4/files/patch-knemod-interfaceupdater.cpp
index 4a743c105842..ba194f906dbd 100644
--- a/net/knemo-kde4/files/patch-knemod-interfaceupdater.cpp
+++ b/net/knemo-kde4/files/patch-knemod-interfaceupdater.cpp
@@ -1,7 +1,7 @@
---- knemod/interfaceupdater.cpp.orig Fri Aug 20 20:26:41 2004
-+++ knemod/interfaceupdater.cpp Sat Jan 22 13:34:49 2005
+--- src/knemod/interfaceupdater.cpp.orig Sat Apr 1 21:44:22 2006
++++ src/knemod/interfaceupdater.cpp Sun Apr 2 21:29:24 2006
@@ -17,6 +17,24 @@
- Boston, MA 02111-1307, USA.
+ Boston, MA 02110-1301, USA.
*/
+#ifdef __FreeBSD__
@@ -25,7 +25,7 @@
#include <qmap.h>
#include <qtimer.h>
#include <qregexp.h>
-@@ -48,6 +66,7 @@
+@@ -49,6 +67,7 @@
mTimer->stop();
delete mTimer;
@@ -33,7 +33,7 @@
if ( mRouteProcess )
{
mRouteProcess->kill();
-@@ -63,10 +82,12 @@
+@@ -64,10 +83,12 @@
mIwconfigProcess->kill();
delete mIwconfigProcess;
}
@@ -46,7 +46,7 @@
if ( !mIfconfigProcess )
{
mIfconfigStdout = QString::null;
-@@ -108,6 +129,7 @@
+@@ -109,6 +130,7 @@
}
}
#endif
@@ -54,7 +54,7 @@
#ifdef PATH_ROUTE
if ( !mRouteProcess )
-@@ -116,7 +138,11 @@
+@@ -117,7 +139,11 @@
mRouteProcess = new KProcess();
mRouteProcess->setEnvironment( "LANG", "C" );
mRouteProcess->setEnvironment( "LC_ALL", "C" );
@@ -66,7 +66,7 @@
connect( mRouteProcess, SIGNAL( receivedStdout( KProcess*, char*, int ) ),
this, SLOT( routeProcessStdout( KProcess*, char*, int ) ) );
connect( mRouteProcess, SIGNAL( receivedStderr( KProcess*, char*, int ) ),
-@@ -131,6 +157,140 @@
+@@ -132,6 +158,140 @@
}
}
#endif
@@ -207,7 +207,7 @@
}
void InterfaceUpdater::routeProcessExited( KProcess* process )
-@@ -180,6 +340,7 @@
+@@ -181,6 +341,7 @@
void InterfaceUpdater::parseIfconfigOutput()
{
@@ -215,7 +215,7 @@
/* mIfconfigStdout contains the complete output of 'ifconfig' which we
* are going to parse here.
*/
-@@ -235,10 +396,12 @@
+@@ -237,10 +398,12 @@
}
interface->activateMonitor();
}
@@ -228,7 +228,7 @@
QRegExp regExp( ".*RX.*:(\\d+).*:\\d+.*:\\d+.*:\\d+" );
if ( regExp.search( config ) > -1 )
data.rxPackets = regExp.cap( 1 ).toULong();
-@@ -318,10 +481,12 @@
+@@ -330,10 +493,12 @@
if ( regExp.search( config ) > -1 )
data.ptpAddress = regExp.cap( 2 );
}
@@ -241,7 +241,7 @@
/* mIwconfigStdout contains the complete output of 'iwconfig' which we
* are going to parse here.
*/
-@@ -364,10 +529,12 @@
+@@ -376,10 +541,12 @@
updateWirelessData( configs[key], interface->getWirelessData() );
}
}
@@ -254,15 +254,15 @@
QRegExp regExp( "ESSID:\"?([^\"]*)\"?" );
if ( regExp.search( config ) > -1 )
data.essid = regExp.cap( 1 );
-@@ -401,6 +568,7 @@
- regExp.setPattern( "Link Quality:([\\d/]*)" );
+@@ -413,6 +580,7 @@
+ regExp.setPattern( "Link Quality[=:]([\\d/]*)" );
if ( regExp.search( config ) > -1 )
data.linkQuality = regExp.cap( 1 );
+#endif
}
void InterfaceUpdater::parseRouteOutput()
-@@ -409,16 +577,25 @@
+@@ -421,16 +589,25 @@
* are going to parse here.
*/
QMap<QString, QStringList> configs;
diff --git a/net/knemo-kde4/pkg-descr b/net/knemo-kde4/pkg-descr
index 0fa8cdc5e1f4..1fe12fcb83a0 100644
--- a/net/knemo-kde4/pkg-descr
+++ b/net/knemo-kde4/pkg-descr
@@ -3,4 +3,4 @@ KNemo - the KDE Network Monitor
KNemo offers a network monitor similar to the one found in Windows.
For every network interface it displays an icon in the systray.
-WWW: http://www.kde-apps.org/content/show.php?content=12956
+WWW: http://extragear.kde.org/apps/knemo/
diff --git a/net/knemo-kde4/pkg-plist b/net/knemo-kde4/pkg-plist
index dd19f2ab8781..3b6ee1bbbc38 100644
--- a/net/knemo-kde4/pkg-plist
+++ b/net/knemo-kde4/pkg-plist
@@ -4,7 +4,7 @@ lib/kde3/kcm_knemo.so
lib/kde3/kded_knemod.a
lib/kde3/kded_knemod.la
lib/kde3/kded_knemod.so
-share/applnk/Settings/Network/kcm_knemo.desktop
+share/applications/kde/kcm_knemo.desktop
share/apps/knemo/eventsrc
share/icons/crystalsvg/16x16/apps/knemo.png
share/icons/crystalsvg/22x22/actions/network_connected.png
@@ -30,35 +30,67 @@ share/icons/crystalsvg/22x22/actions/network_traffic_wlan.png
share/icons/crystalsvg/32x32/apps/knemo.png
share/locale/bg/LC_MESSAGES/kcm_knemo.mo
share/locale/bg/LC_MESSAGES/knemod.mo
+share/locale/br/LC_MESSAGES/kcm_knemo.mo
+share/locale/br/LC_MESSAGES/knemod.mo
share/locale/cs/LC_MESSAGES/kcm_knemo.mo
share/locale/cs/LC_MESSAGES/knemod.mo
+share/locale/cy/LC_MESSAGES/kcm_knemo.mo
+share/locale/cy/LC_MESSAGES/knemod.mo
+share/locale/da/LC_MESSAGES/kcm_knemo.mo
+share/locale/da/LC_MESSAGES/knemod.mo
share/locale/de/LC_MESSAGES/kcm_knemo.mo
share/locale/de/LC_MESSAGES/knemod.mo
+share/locale/el/LC_MESSAGES/kcm_knemo.mo
+share/locale/el/LC_MESSAGES/knemod.mo
+share/locale/en_GB/LC_MESSAGES/kcm_knemo.mo
+share/locale/en_GB/LC_MESSAGES/knemod.mo
share/locale/es/LC_MESSAGES/kcm_knemo.mo
share/locale/es/LC_MESSAGES/knemod.mo
+share/locale/et/LC_MESSAGES/kcm_knemo.mo
+share/locale/et/LC_MESSAGES/knemod.mo
share/locale/fr/LC_MESSAGES/kcm_knemo.mo
share/locale/fr/LC_MESSAGES/knemod.mo
+share/locale/ga/LC_MESSAGES/kcm_knemo.mo
+share/locale/ga/LC_MESSAGES/knemod.mo
share/locale/it/LC_MESSAGES/kcm_knemo.mo
share/locale/it/LC_MESSAGES/knemod.mo
+share/locale/ka/LC_MESSAGES/kcm_knemo.mo
+share/locale/ka/LC_MESSAGES/knemod.mo
+share/locale/lt/LC_MESSAGES/kcm_knemo.mo
+share/locale/lt/LC_MESSAGES/knemod.mo
share/locale/nl/LC_MESSAGES/kcm_knemo.mo
share/locale/nl/LC_MESSAGES/knemod.mo
+share/locale/pl/LC_MESSAGES/kcm_knemo.mo
+share/locale/pl/LC_MESSAGES/knemod.mo
+share/locale/pt/LC_MESSAGES/kcm_knemo.mo
+share/locale/pt/LC_MESSAGES/knemod.mo
share/locale/pt_BR/LC_MESSAGES/kcm_knemo.mo
share/locale/pt_BR/LC_MESSAGES/knemod.mo
share/locale/ru/LC_MESSAGES/kcm_knemo.mo
share/locale/ru/LC_MESSAGES/knemod.mo
+share/locale/rw/LC_MESSAGES/kcm_knemo.mo
+share/locale/rw/LC_MESSAGES/knemod.mo
+share/locale/sr/LC_MESSAGES/kcm_knemo.mo
+share/locale/sr/LC_MESSAGES/knemod.mo
+share/locale/sr@Latn/LC_MESSAGES/kcm_knemo.mo
+share/locale/sr@Latn/LC_MESSAGES/knemod.mo
+share/locale/sv/LC_MESSAGES/kcm_knemo.mo
+share/locale/sv/LC_MESSAGES/knemod.mo
+share/locale/tr/LC_MESSAGES/kcm_knemo.mo
+share/locale/tr/LC_MESSAGES/knemod.mo
share/services/kded/knemod.desktop
-@dirrmtry share/services/kded
-@dirrmtry share/services
-@dirrmtry share/icons/crystalsvg/32x32/apps
-@dirrmtry share/icons/crystalsvg/32x32
-@dirrmtry share/icons/crystalsvg/22x22/actions
-@dirrmtry share/icons/crystalsvg/22x22
-@dirrmtry share/icons/crystalsvg/16x16/apps
-@dirrmtry share/icons/crystalsvg/16x16
-@dirrmtry share/icons/crystalsvg
-@dirrmtry share/icons
+@dirrm share/services/kded
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
@dirrm share/apps/knemo
-@dirrmtry share/apps
-@dirrmtry share/applnk/Settings/Network
-@dirrmtry share/applnk/Settings
-@dirrmtry share/applnk
+@dirrmtry share/applications/kde
diff --git a/net/knemo/Makefile b/net/knemo/Makefile
index 97deff7875bc..6a85dbc62a10 100644
--- a/net/knemo/Makefile
+++ b/net/knemo/Makefile
@@ -5,16 +5,14 @@
# $FreeBSD$
PORTNAME= knemo
-PORTVERSION= 0.3.1
-PORTREVISION= 4
+PORTVERSION= 0.4.0
CATEGORIES= net kde
-MASTER_SITES= http://www.eris23.de/knemo/
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= markus
MAINTAINER= markus@FreeBSD.org
COMMENT= Network monitor for KDE
-EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
-
USE_BZIP2= yes
USE_KDELIBS_VER=3
USE_GMAKE= yes
diff --git a/net/knemo/distinfo b/net/knemo/distinfo
index 2ce1cdb21878..5942c79f4203 100644
--- a/net/knemo/distinfo
+++ b/net/knemo/distinfo
@@ -1,3 +1,3 @@
-MD5 (knemo-0.3.1.tar.bz2) = 774b7b085e7b2d492bf811d7f89cee6e
-SHA256 (knemo-0.3.1.tar.bz2) = 66874172760eeab4d68ea9533db96f408ce3d9af6a5c07d45906092d0b4bdbef
-SIZE (knemo-0.3.1.tar.bz2) = 549018
+MD5 (knemo-0.4.0.tar.bz2) = 5fc147c23b5342d26ca74a03881829e0
+SHA256 (knemo-0.4.0.tar.bz2) = 3b07e892878433dbfbb5f8ff932a82fbafa85d4935dc8008f3446d297208830c
+SIZE (knemo-0.4.0.tar.bz2) = 899310
diff --git a/net/knemo/files/patch-kcm-configdialog.cpp b/net/knemo/files/patch-kcm-configdialog.cpp
index d8285d4fe55f..32a00999bf67 100644
--- a/net/knemo/files/patch-kcm-configdialog.cpp
+++ b/net/knemo/files/patch-kcm-configdialog.cpp
@@ -1,7 +1,7 @@
---- kcm/configdialog.cpp.orig Wed Sep 15 18:24:37 2004
-+++ kcm/configdialog.cpp Wed Jan 19 15:23:57 2005
+--- src/kcm/configdialog.cpp.orig Sat Apr 1 21:44:21 2006
++++ src/kcm/configdialog.cpp Sun Apr 2 19:14:11 2006
@@ -17,6 +17,16 @@
- Boston, MA 02111-1307, USA.
+ Boston, MA 02110-1301, USA.
*/
+#ifdef __FreeBSD__
@@ -17,7 +17,7 @@
#include <qfile.h>
#include <qdict.h>
#include <qlabel.h>
-@@ -355,6 +365,39 @@
+@@ -363,6 +373,39 @@
void ConfigDialog::defaults()
{
// Default interfaces
@@ -57,7 +57,7 @@
QFile proc( "/proc/net/dev" );
if ( proc.open( IO_ReadOnly ) )
{
-@@ -372,6 +415,7 @@
+@@ -380,6 +423,7 @@
if ( interface == "lo" )
continue;
@@ -65,8 +65,8 @@
InterfaceSettings* settings = new InterfaceSettings();
settings->customCommands = false;
settings->hideWhenNotAvailable = false;
-@@ -391,8 +435,10 @@
- mDlg->checkBoxNotExisting->setChecked( false );
+@@ -401,8 +445,10 @@
+ mDlg->checkBoxStatistics->setChecked( false );
mDlg->checkBoxCustom->setChecked( false );
}
+#ifndef __FreeBSD__
diff --git a/net/knemo/files/patch-knemod-data.h b/net/knemo/files/patch-knemod-global.h
index c45f8b191029..b20cda0a6a99 100644
--- a/net/knemo/files/patch-knemod-data.h
+++ b/net/knemo/files/patch-knemod-global.h
@@ -1,14 +1,14 @@
---- knemod/data.h.orig Sat Jan 22 00:10:05 2005
-+++ knemod/data.h Fri Jan 21 17:38:50 2005
+--- src/knemod/global.h.orig Sat Apr 1 21:44:22 2006
++++ src/knemod/global.h Sun Apr 2 21:33:36 2006
@@ -22,6 +22,7 @@
#include <qpair.h>
#include <qcolor.h>
+#include <qdict.h>
#include <qstring.h>
- #include <qvaluevector.h>
-@@ -41,6 +42,11 @@
+ /**
+@@ -36,6 +37,11 @@
int toolTipContent;
};
@@ -19,8 +19,8 @@
+
struct InterfaceData
{
- InterfaceData::InterfaceData()
-@@ -64,11 +70,9 @@
+ InterfaceData()
+@@ -59,11 +65,9 @@
unsigned long prevTxBytes;
unsigned long incomingBytes;
unsigned long outgoingBytes;
diff --git a/net/knemo/files/patch-knemod-interfacestatusdialog.cpp b/net/knemo/files/patch-knemod-interfacestatusdialog.cpp
index 822857eff083..217998e0b9f2 100644
--- a/net/knemo/files/patch-knemod-interfacestatusdialog.cpp
+++ b/net/knemo/files/patch-knemod-interfacestatusdialog.cpp
@@ -1,5 +1,5 @@
---- knemod/interfacestatusdialog.cpp.orig Sat Jan 22 00:11:02 2005
-+++ knemod/interfacestatusdialog.cpp Sat Jan 22 00:15:24 2005
+--- src/knemod/interfacestatusdialog.cpp.orig Sat Apr 1 21:44:22 2006
++++ src/knemod/interfacestatusdialog.cpp Sun Apr 2 21:34:55 2006
@@ -24,6 +24,7 @@
#include <qtabwidget.h>
@@ -8,7 +8,7 @@
#include <kconfig.h>
#include <klocale.h>
#include <kglobal.h>
-@@ -69,6 +70,10 @@
+@@ -92,6 +93,10 @@
mTimer = new QTimer();
connect( mTimer, SIGNAL( timeout() ), this, SLOT( updateDialog() ) );
mTimer->start( 1000 );
@@ -19,7 +19,7 @@
}
InterfaceStatusDialog::~InterfaceStatusDialog()
-@@ -152,12 +157,28 @@
+@@ -201,12 +206,28 @@
if ( data.available )
{
// ip tab
diff --git a/net/knemo/files/patch-knemod-interfacestatusdlg.ui b/net/knemo/files/patch-knemod-interfacestatusdlg.ui
index d506e3f44a0f..073ca19a3734 100644
--- a/net/knemo/files/patch-knemod-interfacestatusdlg.ui
+++ b/net/knemo/files/patch-knemod-interfacestatusdlg.ui
@@ -1,14 +1,5 @@
---- knemod/interfacestatusdlg.ui.orig Fri Jan 21 16:57:24 2005
-+++ knemod/interfacestatusdlg.ui Fri Jan 21 20:02:50 2005
-@@ -9,7 +9,7 @@
- <x>0</x>
- <y>0</y>
- <width>272</width>
-- <height>258</height>
-+ <height>237</height>
- </rect>
- </property>
- <property name="caption">
+--- src/knemod/interfacestatusdlg.ui.orig Sat Apr 1 21:44:22 2006
++++ src/knemod/interfacestatusdlg.ui Sun Apr 2 21:28:01 2006
@@ -145,7 +145,7 @@
</property>
<widget class="QLayoutWidget">
@@ -248,7 +239,7 @@
</widget>
</hbox>
</widget>
-@@ -728,8 +676,6 @@
+@@ -893,8 +841,6 @@
</widget>
</vbox>
</widget>
@@ -257,7 +248,7 @@
<connections>
<connection>
<sender>buttonClose</sender>
-@@ -740,10 +686,6 @@
+@@ -905,10 +851,6 @@
</connections>
<layoutdefaults spacing="6" margin="11"/>
<includehints>
diff --git a/net/knemo/files/patch-knemod-interfacetooltip.cpp b/net/knemo/files/patch-knemod-interfacetooltip.cpp
index 10235e4477c3..9dce92066cf6 100644
--- a/net/knemo/files/patch-knemod-interfacetooltip.cpp
+++ b/net/knemo/files/patch-knemod-interfacetooltip.cpp
@@ -1,6 +1,6 @@
---- knemod/interfacetooltip.cpp.orig Fri Jan 21 17:51:13 2005
-+++ knemod/interfacetooltip.cpp Fri Jan 21 17:59:47 2005
-@@ -99,6 +99,23 @@
+--- src/knemod/interfacetooltip.cpp.orig Sat Apr 1 21:44:22 2006
++++ src/knemod/interfacetooltip.cpp Sun Apr 2 21:30:52 2006
+@@ -101,6 +101,23 @@
if ( data.available )
{
@@ -24,7 +24,7 @@
if ( toolTipContent & IP_ADDRESS )
text += "<tr><td>" + mToolTips[4].first + "</td><td>" + data.ipAddress + "</td></tr>";
if ( toolTipContent & SUBNET_MASK )
-@@ -107,6 +124,7 @@
+@@ -109,6 +126,7 @@
{
if ( toolTipContent & BCAST_ADDRESS )
text += "<tr><td>" + mToolTips[18].first + "</td><td>" + data.broadcastAddress + "</td></tr>";
diff --git a/net/knemo/files/patch-knemod-interfaceupdater.cpp b/net/knemo/files/patch-knemod-interfaceupdater.cpp
index 4a743c105842..ba194f906dbd 100644
--- a/net/knemo/files/patch-knemod-interfaceupdater.cpp
+++ b/net/knemo/files/patch-knemod-interfaceupdater.cpp
@@ -1,7 +1,7 @@
---- knemod/interfaceupdater.cpp.orig Fri Aug 20 20:26:41 2004
-+++ knemod/interfaceupdater.cpp Sat Jan 22 13:34:49 2005
+--- src/knemod/interfaceupdater.cpp.orig Sat Apr 1 21:44:22 2006
++++ src/knemod/interfaceupdater.cpp Sun Apr 2 21:29:24 2006
@@ -17,6 +17,24 @@
- Boston, MA 02111-1307, USA.
+ Boston, MA 02110-1301, USA.
*/
+#ifdef __FreeBSD__
@@ -25,7 +25,7 @@
#include <qmap.h>
#include <qtimer.h>
#include <qregexp.h>
-@@ -48,6 +66,7 @@
+@@ -49,6 +67,7 @@
mTimer->stop();
delete mTimer;
@@ -33,7 +33,7 @@
if ( mRouteProcess )
{
mRouteProcess->kill();
-@@ -63,10 +82,12 @@
+@@ -64,10 +83,12 @@
mIwconfigProcess->kill();
delete mIwconfigProcess;
}
@@ -46,7 +46,7 @@
if ( !mIfconfigProcess )
{
mIfconfigStdout = QString::null;
-@@ -108,6 +129,7 @@
+@@ -109,6 +130,7 @@
}
}
#endif
@@ -54,7 +54,7 @@
#ifdef PATH_ROUTE
if ( !mRouteProcess )
-@@ -116,7 +138,11 @@
+@@ -117,7 +139,11 @@
mRouteProcess = new KProcess();
mRouteProcess->setEnvironment( "LANG", "C" );
mRouteProcess->setEnvironment( "LC_ALL", "C" );
@@ -66,7 +66,7 @@
connect( mRouteProcess, SIGNAL( receivedStdout( KProcess*, char*, int ) ),
this, SLOT( routeProcessStdout( KProcess*, char*, int ) ) );
connect( mRouteProcess, SIGNAL( receivedStderr( KProcess*, char*, int ) ),
-@@ -131,6 +157,140 @@
+@@ -132,6 +158,140 @@
}
}
#endif
@@ -207,7 +207,7 @@
}
void InterfaceUpdater::routeProcessExited( KProcess* process )
-@@ -180,6 +340,7 @@
+@@ -181,6 +341,7 @@
void InterfaceUpdater::parseIfconfigOutput()
{
@@ -215,7 +215,7 @@
/* mIfconfigStdout contains the complete output of 'ifconfig' which we
* are going to parse here.
*/
-@@ -235,10 +396,12 @@
+@@ -237,10 +398,12 @@
}
interface->activateMonitor();
}
@@ -228,7 +228,7 @@
QRegExp regExp( ".*RX.*:(\\d+).*:\\d+.*:\\d+.*:\\d+" );
if ( regExp.search( config ) > -1 )
data.rxPackets = regExp.cap( 1 ).toULong();
-@@ -318,10 +481,12 @@
+@@ -330,10 +493,12 @@
if ( regExp.search( config ) > -1 )
data.ptpAddress = regExp.cap( 2 );
}
@@ -241,7 +241,7 @@
/* mIwconfigStdout contains the complete output of 'iwconfig' which we
* are going to parse here.
*/
-@@ -364,10 +529,12 @@
+@@ -376,10 +541,12 @@
updateWirelessData( configs[key], interface->getWirelessData() );
}
}
@@ -254,15 +254,15 @@
QRegExp regExp( "ESSID:\"?([^\"]*)\"?" );
if ( regExp.search( config ) > -1 )
data.essid = regExp.cap( 1 );
-@@ -401,6 +568,7 @@
- regExp.setPattern( "Link Quality:([\\d/]*)" );
+@@ -413,6 +580,7 @@
+ regExp.setPattern( "Link Quality[=:]([\\d/]*)" );
if ( regExp.search( config ) > -1 )
data.linkQuality = regExp.cap( 1 );
+#endif
}
void InterfaceUpdater::parseRouteOutput()
-@@ -409,16 +577,25 @@
+@@ -421,16 +589,25 @@
* are going to parse here.
*/
QMap<QString, QStringList> configs;
diff --git a/net/knemo/pkg-descr b/net/knemo/pkg-descr
index 0fa8cdc5e1f4..1fe12fcb83a0 100644
--- a/net/knemo/pkg-descr
+++ b/net/knemo/pkg-descr
@@ -3,4 +3,4 @@ KNemo - the KDE Network Monitor
KNemo offers a network monitor similar to the one found in Windows.
For every network interface it displays an icon in the systray.
-WWW: http://www.kde-apps.org/content/show.php?content=12956
+WWW: http://extragear.kde.org/apps/knemo/
diff --git a/net/knemo/pkg-plist b/net/knemo/pkg-plist
index dd19f2ab8781..3b6ee1bbbc38 100644
--- a/net/knemo/pkg-plist
+++ b/net/knemo/pkg-plist
@@ -4,7 +4,7 @@ lib/kde3/kcm_knemo.so
lib/kde3/kded_knemod.a
lib/kde3/kded_knemod.la
lib/kde3/kded_knemod.so
-share/applnk/Settings/Network/kcm_knemo.desktop
+share/applications/kde/kcm_knemo.desktop
share/apps/knemo/eventsrc
share/icons/crystalsvg/16x16/apps/knemo.png
share/icons/crystalsvg/22x22/actions/network_connected.png
@@ -30,35 +30,67 @@ share/icons/crystalsvg/22x22/actions/network_traffic_wlan.png
share/icons/crystalsvg/32x32/apps/knemo.png
share/locale/bg/LC_MESSAGES/kcm_knemo.mo
share/locale/bg/LC_MESSAGES/knemod.mo
+share/locale/br/LC_MESSAGES/kcm_knemo.mo
+share/locale/br/LC_MESSAGES/knemod.mo
share/locale/cs/LC_MESSAGES/kcm_knemo.mo
share/locale/cs/LC_MESSAGES/knemod.mo
+share/locale/cy/LC_MESSAGES/kcm_knemo.mo
+share/locale/cy/LC_MESSAGES/knemod.mo
+share/locale/da/LC_MESSAGES/kcm_knemo.mo
+share/locale/da/LC_MESSAGES/knemod.mo
share/locale/de/LC_MESSAGES/kcm_knemo.mo
share/locale/de/LC_MESSAGES/knemod.mo
+share/locale/el/LC_MESSAGES/kcm_knemo.mo
+share/locale/el/LC_MESSAGES/knemod.mo
+share/locale/en_GB/LC_MESSAGES/kcm_knemo.mo
+share/locale/en_GB/LC_MESSAGES/knemod.mo
share/locale/es/LC_MESSAGES/kcm_knemo.mo
share/locale/es/LC_MESSAGES/knemod.mo
+share/locale/et/LC_MESSAGES/kcm_knemo.mo
+share/locale/et/LC_MESSAGES/knemod.mo
share/locale/fr/LC_MESSAGES/kcm_knemo.mo
share/locale/fr/LC_MESSAGES/knemod.mo
+share/locale/ga/LC_MESSAGES/kcm_knemo.mo
+share/locale/ga/LC_MESSAGES/knemod.mo
share/locale/it/LC_MESSAGES/kcm_knemo.mo
share/locale/it/LC_MESSAGES/knemod.mo
+share/locale/ka/LC_MESSAGES/kcm_knemo.mo
+share/locale/ka/LC_MESSAGES/knemod.mo
+share/locale/lt/LC_MESSAGES/kcm_knemo.mo
+share/locale/lt/LC_MESSAGES/knemod.mo
share/locale/nl/LC_MESSAGES/kcm_knemo.mo
share/locale/nl/LC_MESSAGES/knemod.mo
+share/locale/pl/LC_MESSAGES/kcm_knemo.mo
+share/locale/pl/LC_MESSAGES/knemod.mo
+share/locale/pt/LC_MESSAGES/kcm_knemo.mo
+share/locale/pt/LC_MESSAGES/knemod.mo
share/locale/pt_BR/LC_MESSAGES/kcm_knemo.mo
share/locale/pt_BR/LC_MESSAGES/knemod.mo
share/locale/ru/LC_MESSAGES/kcm_knemo.mo
share/locale/ru/LC_MESSAGES/knemod.mo
+share/locale/rw/LC_MESSAGES/kcm_knemo.mo
+share/locale/rw/LC_MESSAGES/knemod.mo
+share/locale/sr/LC_MESSAGES/kcm_knemo.mo
+share/locale/sr/LC_MESSAGES/knemod.mo
+share/locale/sr@Latn/LC_MESSAGES/kcm_knemo.mo
+share/locale/sr@Latn/LC_MESSAGES/knemod.mo
+share/locale/sv/LC_MESSAGES/kcm_knemo.mo
+share/locale/sv/LC_MESSAGES/knemod.mo
+share/locale/tr/LC_MESSAGES/kcm_knemo.mo
+share/locale/tr/LC_MESSAGES/knemod.mo
share/services/kded/knemod.desktop
-@dirrmtry share/services/kded
-@dirrmtry share/services
-@dirrmtry share/icons/crystalsvg/32x32/apps
-@dirrmtry share/icons/crystalsvg/32x32
-@dirrmtry share/icons/crystalsvg/22x22/actions
-@dirrmtry share/icons/crystalsvg/22x22
-@dirrmtry share/icons/crystalsvg/16x16/apps
-@dirrmtry share/icons/crystalsvg/16x16
-@dirrmtry share/icons/crystalsvg
-@dirrmtry share/icons
+@dirrm share/services/kded
+@dirrmtry share/locale/sr/LC_MESSAGES
+@dirrmtry share/locale/sr
+@dirrmtry share/locale/rw/LC_MESSAGES
+@dirrmtry share/locale/rw
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
@dirrm share/apps/knemo
-@dirrmtry share/apps
-@dirrmtry share/applnk/Settings/Network
-@dirrmtry share/applnk/Settings
-@dirrmtry share/applnk
+@dirrmtry share/applications/kde