aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2006-04-21 15:29:15 +0800
committervs <vs@FreeBSD.org>2006-04-21 15:29:15 +0800
commit3fa662a90517944023a85325787343804a6af82b (patch)
treee6e9dcb5ada3d8c7e17ab879b37b4541eb0a115d /net
parentc7b92a7368e1e77b1d59effd4e2e10089a7d1e0a (diff)
downloadfreebsd-ports-gnome-3fa662a90517944023a85325787343804a6af82b.tar.gz
freebsd-ports-gnome-3fa662a90517944023a85325787343804a6af82b.tar.zst
freebsd-ports-gnome-3fa662a90517944023a85325787343804a6af82b.zip
Minor cleanup
PR: ports/95827 Submitted by: maintainer
Diffstat (limited to 'net')
-rw-r--r--net/unison/Makefile4
-rw-r--r--net/unison/files/patch-aa31
-rw-r--r--net/unison232/Makefile4
-rw-r--r--net/unison232/files/patch-aa31
4 files changed, 6 insertions, 64 deletions
diff --git a/net/unison/Makefile b/net/unison/Makefile
index 6039bd0515bf..2b53480a81c0 100644
--- a/net/unison/Makefile
+++ b/net/unison/Makefile
@@ -53,8 +53,10 @@ post-build:
@${GMAKE} -C ${WRKSRC} UISTYLE=text NAME=unison-text
.endif
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/unison ${PREFIX}/bin
+
post-install:
- @${STRIP_CMD} ${PREFIX}/bin/unison
.if defined(WITH_GTK2)
@${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${PREFIX}/bin
.endif
diff --git a/net/unison/files/patch-aa b/net/unison/files/patch-aa
deleted file mode 100644
index 483f1bab2391..000000000000
--- a/net/unison/files/patch-aa
+++ /dev/null
@@ -1,31 +0,0 @@
---- Makefile.orig Sat Aug 27 15:49:56 2005
-+++ Makefile Sat Aug 27 15:51:55 2005
-@@ -68,15 +68,15 @@
- ######################################################################
- # Installation
-
--INSTALLDIR = $(HOME)/bin/
-+INSTALLDIR = ${PREFIX}/bin/
-
- # This has two names because on OSX the file INSTALL shadows the target 'install'!
- install: doinstall
-
- doinstall: $(NAME)$(EXEC_EXT)
-- -mv $(INSTALLDIR)/$(NAME)$(EXEC_EXT) /tmp/$(NAME)-$(shell echo $$$$)
-- cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)
-- cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(MAJORVERSION)$(EXEC_EXT)
-+# -mv $(INSTALLDIR)/$(NAME)$(EXEC_EXT) /tmp/$(NAME)-$(shell echo $$$$)
-+ ${BSD_INSTALL_PROGRAM} $(NAME)$(EXEC_EXT) $(INSTALLDIR)
-+# cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(MAJORVERSION)$(EXEC_EXT)
-
-
- ######################################################################
-@@ -353,7 +353,7 @@
- .PHONY: tags
-
- tags:
-- -$(ETAGS) *.mli */*.mli *.ml */*.ml *.m */*.m *.c */*.c *.txt
-+ -$(ETAGS) *.mli */*.mli *.ml */*.ml */*.m *.c */*.c *.txt
-
- all:: TAGS
-
diff --git a/net/unison232/Makefile b/net/unison232/Makefile
index 6039bd0515bf..2b53480a81c0 100644
--- a/net/unison232/Makefile
+++ b/net/unison232/Makefile
@@ -53,8 +53,10 @@ post-build:
@${GMAKE} -C ${WRKSRC} UISTYLE=text NAME=unison-text
.endif
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/unison ${PREFIX}/bin
+
post-install:
- @${STRIP_CMD} ${PREFIX}/bin/unison
.if defined(WITH_GTK2)
@${INSTALL_PROGRAM} ${WRKSRC}/unison-text ${PREFIX}/bin
.endif
diff --git a/net/unison232/files/patch-aa b/net/unison232/files/patch-aa
deleted file mode 100644
index 483f1bab2391..000000000000
--- a/net/unison232/files/patch-aa
+++ /dev/null
@@ -1,31 +0,0 @@
---- Makefile.orig Sat Aug 27 15:49:56 2005
-+++ Makefile Sat Aug 27 15:51:55 2005
-@@ -68,15 +68,15 @@
- ######################################################################
- # Installation
-
--INSTALLDIR = $(HOME)/bin/
-+INSTALLDIR = ${PREFIX}/bin/
-
- # This has two names because on OSX the file INSTALL shadows the target 'install'!
- install: doinstall
-
- doinstall: $(NAME)$(EXEC_EXT)
-- -mv $(INSTALLDIR)/$(NAME)$(EXEC_EXT) /tmp/$(NAME)-$(shell echo $$$$)
-- cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)
-- cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(MAJORVERSION)$(EXEC_EXT)
-+# -mv $(INSTALLDIR)/$(NAME)$(EXEC_EXT) /tmp/$(NAME)-$(shell echo $$$$)
-+ ${BSD_INSTALL_PROGRAM} $(NAME)$(EXEC_EXT) $(INSTALLDIR)
-+# cp $(NAME)$(EXEC_EXT) $(INSTALLDIR)$(NAME)-$(MAJORVERSION)$(EXEC_EXT)
-
-
- ######################################################################
-@@ -353,7 +353,7 @@
- .PHONY: tags
-
- tags:
-- -$(ETAGS) *.mli */*.mli *.ml */*.ml *.m */*.m *.c */*.c *.txt
-+ -$(ETAGS) *.mli */*.mli *.ml */*.ml */*.m *.c */*.c *.txt
-
- all:: TAGS
-