aboutsummaryrefslogtreecommitdiffstats
path: root/net
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-04-19 10:20:29 +0800
committerclsung <clsung@FreeBSD.org>2006-04-19 10:20:29 +0800
commit43501986177dcf8e65a4314ea73e4a7548879117 (patch)
treec423b589d4753499a6267d5ab09d5eebfc11ed68 /net
parentf110d7e7da0ae73024ff595c03feee9603e2fc60 (diff)
downloadfreebsd-ports-gnome-43501986177dcf8e65a4314ea73e4a7548879117.tar.gz
freebsd-ports-gnome-43501986177dcf8e65a4314ea73e4a7548879117.tar.zst
freebsd-ports-gnome-43501986177dcf8e65a4314ea73e4a7548879117.zip
- update to 0.42
Diffstat (limited to 'net')
-rw-r--r--net/p5-File-Rsync/Makefile14
-rw-r--r--net/p5-File-Rsync/distinfo6
-rw-r--r--net/p5-File-Rsync/files/patch-Makefile.PL17
-rw-r--r--net/p5-File-Rsync/files/patch-makepm.PL38
4 files changed, 14 insertions, 61 deletions
diff --git a/net/p5-File-Rsync/Makefile b/net/p5-File-Rsync/Makefile
index a927ae18fb75..e077de67957a 100644
--- a/net/p5-File-Rsync/Makefile
+++ b/net/p5-File-Rsync/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= File-Rsync
-PORTVERSION= 0.34
+PORTVERSION= 0.42
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= File
@@ -19,7 +19,15 @@ BUILD_DEPENDS= rsync:${PORTSDIR}/net/rsync
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= </dev/null
-MAN3= File::Rsync.3 File::Rsync::Config.3
+MAN3= File::Rsync.3 File::config.3
-.include <bsd.port.mk>
+do-patch:
+ @${REINPLACE_CMD} -e "s,<STDIN>,'${LOCALBASE}/bin/rsync'," ${WRKSRC}/makepm.PL
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+.include <bsd.port.post.mk>
diff --git a/net/p5-File-Rsync/distinfo b/net/p5-File-Rsync/distinfo
index d6f96862a2d8..7ec44907a8c1 100644
--- a/net/p5-File-Rsync/distinfo
+++ b/net/p5-File-Rsync/distinfo
@@ -1,3 +1,3 @@
-MD5 (File-Rsync-0.34.tar.gz) = 06b2f134c4d3aa134d3813b7c1c538f1
-SHA256 (File-Rsync-0.34.tar.gz) = 2d208a200ef72fc9905580409c6fee37a6ca07b981290d5ae6f85c42a089cfd5
-SIZE (File-Rsync-0.34.tar.gz) = 17620
+MD5 (File-Rsync-0.42.tar.gz) = c4f0f92227ede564f0109f9e190643d8
+SHA256 (File-Rsync-0.42.tar.gz) = 7349100bd7b1d8929ace71a50333f2051cc746f11ad836fb8d84dec5f26580f4
+SIZE (File-Rsync-0.42.tar.gz) = 19407
diff --git a/net/p5-File-Rsync/files/patch-Makefile.PL b/net/p5-File-Rsync/files/patch-Makefile.PL
deleted file mode 100644
index e40e7094dfa1..000000000000
--- a/net/p5-File-Rsync/files/patch-Makefile.PL
+++ /dev/null
@@ -1,17 +0,0 @@
---- Makefile.PL.orig Tue Jun 26 01:36:15 2001
-+++ Makefile.PL Fri May 16 17:55:25 2003
-@@ -16,9 +16,13 @@
- DISTNAME => $DISTNAME,
- AUTHOR => $AUTHOR,
- ABSTRACT => $ABSTRACT,
-- PL_FILES => { 'makepm.PL' => 'Config.pm' },
-+ PL_FILES => { 'makepm.PL ${LOCALBASE}' => 'Config.pm' },
- PM => { 'Rsync.pm' => '$(INST_LIB)/File/Rsync.pm',
- 'Config.pm' => '$(INST_ARCHLIB)/File/Rsync/Config.pm' },
-+ MAN3PODS => {
-+ '$(INST_LIB)/File/Rsync.pm' => '$(INST_MAN3DIR)/File::Rsync.$(MAN3EXT)',
-+ '$(INST_ARCHLIB)/File/Rsync/Config.pm' => '$(INST_MAN3DIR)/File::Rsync::Config.$(MAN3EXT)',
-+ },
- dist => { COMPRESS => 'gzip', SUFFIX => 'gz' },
- realclean => { FILES => 'Config.pm' },
- );
diff --git a/net/p5-File-Rsync/files/patch-makepm.PL b/net/p5-File-Rsync/files/patch-makepm.PL
deleted file mode 100644
index d7f78af10c3a..000000000000
--- a/net/p5-File-Rsync/files/patch-makepm.PL
+++ /dev/null
@@ -1,38 +0,0 @@
---- makepm.PL.orig Sun May 20 10:23:34 2001
-+++ makepm.PL Sun May 20 10:30:05 2001
-@@ -1,32 +1,8 @@
- # makepm.PL -- Builds Rsync.pm from Rsync.in. -*- perl -*-
--sub find_rsync {
-- my @dirs = map { s/^$/./; $_ } split (':', $ENV{PATH});
-- push (@dirs, qw(/usr/local/bin /usr/bin /opt/bin));
-- for my $dir (@dirs) {
-- next unless -d $dir;
-- next unless -x "$dir/rsync";
-- return "$dir/rsync";
-- }
--}
- $|=1;
--$RSYNC=&find_rsync;
--print <<'EOT';
--
--File::Rsync needs to know the path to the rsync binary. This path is encoded
--in the installed module as the default path to rsync (it can be overridden
--at runtime). Please enter the full path to the rsync program or just hit
--Enter if the guess is correct. (If you always want the module to depend on
--the $PATH environment variable at runtime, just set the path to 'rsync'
--(this is not recommended)).
--
--EOT
--$RSYNC||='/usr/local/bin/rsync';
--print "Path to rsync [$RSYNC]: ";
--my $ans=<STDIN>;
--chomp $ans;
--$RSYNC=$ans || $RSYNC;
--$RSYNC=~s/\\/\\\\/g;
--$RSYNC=~s/\'/\\\'/g;
-+$PREFIX=@ARGV[0];
-+$RSYNC=$PREFIX . "/bin/rsync";
-+print "Path to rsync [$RSYNC]";
- open IN,'Config.in' or die "Cannot read Config.in: $!\n";
- open OUT,'>Config.pm' or die "Cannot write Config.pm: $!\n";
- while (<IN>) {